summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-22 10:04:38 +0100
committerRemi Collet <remi@remirepo.net>2018-11-22 10:04:38 +0100
commit2424e9380947a5bcfb9ee8d63b26fe83b4227a73 (patch)
tree51a08f5eeacb6df390886fa8977de577340db6dd
parent3cd9d08dd8200462615c1e53c790d741ba8096b1 (diff)
v2.6.3
-rw-r--r--composer.json39
-rw-r--r--php-doctrine-orm-php73.patch31
-rw-r--r--php-doctrine-orm.spec13
3 files changed, 33 insertions, 50 deletions
diff --git a/composer.json b/composer.json
index a2ec7ce..5f40e2a 100644
--- a/composer.json
+++ b/composer.json
@@ -9,39 +9,48 @@
{"name": "Guilherme Blanco", "email": "guilhermeblanco@gmail.com"},
{"name": "Roman Borschel", "email": "roman@code-factory.org"},
{"name": "Benjamin Eberlei", "email": "kontakt@beberlei.de"},
- {"name": "Jonathan Wage", "email": "jonwage@gmail.com"}
+ {"name": "Jonathan Wage", "email": "jonwage@gmail.com"},
+ {"name": "Marco Pivetta", "email": "ocramius@gmail.com"}
],
- "minimum-stability": "dev",
+ "config": {
+ "sort-packages": true
+ },
"require": {
- "php": ">=5.4",
+ "php": "^7.1",
"ext-pdo": "*",
- "doctrine/collections": "~1.2",
- "doctrine/dbal": ">=2.5-dev,<2.7-dev",
- "doctrine/instantiator": "^1.0.1",
- "doctrine/common": ">=2.5-dev,<2.9-dev",
- "doctrine/cache": "~1.4",
- "symfony/console": "~2.5|~3.0|~4.0"
+ "doctrine/annotations": "~1.5",
+ "doctrine/cache": "~1.6",
+ "doctrine/collections": "^1.4",
+ "doctrine/common": "^2.7.1",
+ "doctrine/dbal": "^2.6",
+ "doctrine/instantiator": "~1.1",
+ "symfony/console": "~3.0|~4.0"
},
"require-dev": {
- "symfony/yaml": "~2.3|~3.0|~4.0",
- "phpunit/phpunit": "~4.0"
+ "doctrine/coding-standard": "^1.0",
+ "phpunit/phpunit": "^6.5",
+ "squizlabs/php_codesniffer": "^3.2",
+ "symfony/yaml": "~3.4|~4.0"
},
"suggest": {
"symfony/yaml": "If you want to use YAML Metadata Mapping Driver"
},
"autoload": {
- "psr-0": { "Doctrine\\ORM\\": "lib/" }
+ "psr-4": { "Doctrine\\ORM\\": "lib/Doctrine/ORM" }
},
"autoload-dev": {
- "psr-0": { "Doctrine\\Tests\\": "tests/" }
+ "psr-4": {
+ "Doctrine\\Tests\\": "tests/Doctrine/Tests",
+ "Doctrine\\Performance\\": "tests/Doctrine/Performance"
+ }
},
- "bin": ["bin/doctrine", "bin/doctrine.php"],
+ "bin": ["bin/doctrine"],
"extra": {
"branch-alias": {
"dev-master": "2.6.x-dev"
}
},
"archive": {
- "exclude": ["!vendor", "tests", "*phpunit.xml", ".travis.yml", "build.xml", "build.properties", "composer.phar", "vendor/satooshi", "lib/vendor", "*.swp", "*coveralls.yml"]
+ "exclude": ["!vendor", "tests", "*phpunit.xml", ".travis.yml", "build.xml", "build.properties", "composer.phar", "vendor/satooshi", "lib/vendor", "*.swp"]
}
}
diff --git a/php-doctrine-orm-php73.patch b/php-doctrine-orm-php73.patch
deleted file mode 100644
index d0b3f2b..0000000
--- a/php-doctrine-orm-php73.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 07fc401d255a4cdb4a557147d1c8a3fc7a0c718d Mon Sep 17 00:00:00 2001
-From: Cyril PASCAL <cyril.pascal_github@m4x.org>
-Date: Thu, 26 Jul 2018 14:32:52 +0200
-Subject: [PATCH] Make code php 7.3 lint-compatible
-
----
- lib/Doctrine/ORM/UnitOfWork.php | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/lib/Doctrine/ORM/UnitOfWork.php b/lib/Doctrine/ORM/UnitOfWork.php
-index 6767e7ef31..c79afd084e 100644
---- a/lib/Doctrine/ORM/UnitOfWork.php
-+++ b/lib/Doctrine/ORM/UnitOfWork.php
-@@ -2715,7 +2715,7 @@ public function createEntity($className, array $data, &$hints = [])
- $class->reflFields[$field]->setValue($entity, $data[$field]);
- $this->originalEntityData[$oid][$field] = $data[$field];
-
-- continue;
-+ break;
- }
-
- $associatedId = [];
-@@ -2744,7 +2744,7 @@ public function createEntity($className, array $data, &$hints = [])
- $class->reflFields[$field]->setValue($entity, null);
- $this->originalEntityData[$oid][$field] = null;
-
-- continue;
-+ break;
- }
-
- if ( ! isset($hints['fetchMode'][$class->name][$field])) {
diff --git a/php-doctrine-orm.spec b/php-doctrine-orm.spec
index 342f784..9836e88 100644
--- a/php-doctrine-orm.spec
+++ b/php-doctrine-orm.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name doctrine2
-%global github_version 2.6.2
-%global github_commit d2b4dd71d2a276edd65d0c170375b445f8a4a4a8
+%global github_version 2.6.3
+%global github_commit 434820973cadf2da2d66e7184be370084cc32ca8
%global composer_vendor doctrine
%global composer_project orm
@@ -66,13 +66,13 @@ Source1: %{name}-get-source.sh
# 1) Add she-bang
# 2) Auto-load using Doctrine\Common\ClassLoader
Patch0: %{name}-bin.patch
-Patch1: %{name}-php73.patch
BuildArch: noarch
# Tests
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
+# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(doctrine/annotations) >= %{annotations_min_ver} with php-composer(doctrine/annotations) < %{annotations_max_ver})
BuildRequires: (php-composer(doctrine/cache) >= %{cache_min_ver} with php-composer(doctrine/cache) < %{cache_max_ver})
@@ -82,6 +82,7 @@ BuildRequires: (php-composer(doctrine/dbal) >= %{dbal_min_ver} w
BuildRequires: (php-composer(doctrine/instantiator) >= %{instantiator_min_ver} with php-composer(doctrine/instantiator) < %{instantiator_max_ver})
BuildRequires: (php-composer(symfony/console) >= %{symfony_min_ver} with php-composer(symfony/console) < %{symfony_max_ver})
BuildRequires: (php-composer(symfony/yaml) >= %{symfony_min_ver} with php-composer(symfony/yaml) < %{symfony_max_ver})
+# remirepo:18
%else
BuildRequires: php-composer(doctrine/annotations) < %{annotations_max_ver}
BuildRequires: php-composer(doctrine/annotations) >= %{annotations_min_ver}
@@ -118,6 +119,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
+# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(doctrine/annotations) >= %{annotations_min_ver} with php-composer(doctrine/annotations) < %{annotations_max_ver})
Requires: (php-composer(doctrine/cache) >= %{cache_min_ver} with php-composer(doctrine/cache) < %{cache_max_ver})
@@ -128,6 +130,7 @@ Requires: (php-composer(doctrine/instantiator) >= %{instantiator_min_ver} w
Requires: (php-composer(symfony/console) >= %{symfony_min_ver} with php-composer(symfony/console) < %{symfony_max_ver})
# composer.json: suggest
Requires: (php-composer(symfony/yaml) >= %{symfony_min_ver} with php-composer(symfony/yaml) < %{symfony_max_ver})
+# remirepo:18
%else
Requires: php-composer(doctrine/annotations) < %{annotations_max_ver}
Requires: php-composer(doctrine/annotations) >= %{annotations_min_ver}
@@ -194,7 +197,6 @@ Autoloader: %{phpdir}/Doctrine/ORM/autoload.php
: Patch bin script
%patch0 -p1 -b .rpm
sed -i 's#__PHPDIR__#%{phpdir}#g' bin/doctrine.php
-%patch1 -p1
: Remove empty file
rm -f lib/Doctrine/ORM/README.markdown
@@ -286,6 +288,9 @@ exit $RETURN_CODE
%changelog
+* Thu Nov 22 2018 Remi Collet <remi@remirepo.net> - 2.6.3-1
+- update to 2.6.3
+
* Wed Oct 17 2018 Remi Collet <remi@remirepo.net> - 2.6.2-1
- update to 2.6.2
- raise dependency on PHP 7.1