summaryrefslogtreecommitdiffstats
path: root/php-doctrine-lexer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-lexer.spec')
-rw-r--r--php-doctrine-lexer.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/php-doctrine-lexer.spec b/php-doctrine-lexer.spec
index 748c4e5..0854402 100644
--- a/php-doctrine-lexer.spec
+++ b/php-doctrine-lexer.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-lexer
#
-# Copyright (c) 2013-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2022 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
# Github
%global github_owner doctrine
%global github_name lexer
-%global github_version 1.2.1
-%global github_commit e864bbf5904cb8f5bb334f99209b48018522f042
+%global github_version 1.2.2
+%global github_commit 9c50f840f257bbb941e6f4a0e94ccf5db5c3f76c
%global github_short %(c=%{github_commit}; echo ${c:0:7})
# Namespace
%global ns_vendor Doctrine
@@ -23,8 +23,8 @@
%global composer_vendor doctrine
%global composer_project lexer
-# "php": "^7.2 || ^8.0"
-%global php_min_ver 7.2
+# "php": "^7.1 || ^8.0"
+%global php_min_ver 7.1
%{!?phpdir: %global phpdir %{_datadir}/php}
%global with_tests 0%{!?_without_tests:1}
@@ -46,7 +46,7 @@ BuildRequires: php-fedora-autoloader-devel
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pcre
BuildRequires: php-reflection
-BuildRequires: phpunit8
+BuildRequires: phpunit9
%endif
# composer.json
@@ -103,9 +103,9 @@ EOF
: Run test suite
ret=0
-for cmd in php php72 php73 php74 php80; do
+for cmd in php php74 php80 php81; do
if which $cmd; then
- $cmd %{_bindir}/phpunit8 \
+ $cmd %{_bindir}/phpunit9 \
--bootstrap vendor/autoload.php \
--verbose || ret=1
fi
@@ -127,6 +127,10 @@ exit $ret
%changelog
+* Wed Jan 12 2022 Remi Collet <remi@remirepo.net> - 1.2.2-1
+- update to 1.2.2
+- switch to phpunit9
+
* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.2.1-1
- update to 1.2.1 (no change)