summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-13 10:42:17 +0200
committerRemi Collet <remi@php.net>2022-10-13 10:42:17 +0200
commitb989cfebc0171b3688fba8f1d739b2d4cd8d5e3b (patch)
treeb4add411121dbed79d57bd67f5b70b2dfc8f9c88
duplicate v1
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json69
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-doctrine-event-manager2.spec165
5 files changed, 275 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..deeb7e0
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,69 @@
+{
+ "name": "doctrine/event-manager",
+ "description": "The Doctrine Event Manager is a simple PHP event system that was built to be used with the various Doctrine projects.",
+ "license": "MIT",
+ "type": "library",
+ "keywords": [
+ "events",
+ "event",
+ "event dispatcher",
+ "event manager",
+ "event system"
+ ],
+ "authors": [
+ {
+ "name": "Guilherme Blanco",
+ "email": "guilhermeblanco@gmail.com"
+ },
+ {
+ "name": "Roman Borschel",
+ "email": "roman@code-factory.org"
+ },
+ {
+ "name": "Benjamin Eberlei",
+ "email": "kontakt@beberlei.de"
+ },
+ {
+ "name": "Jonathan Wage",
+ "email": "jonwage@gmail.com"
+ },
+ {
+ "name": "Johannes Schmitt",
+ "email": "schmittjoh@gmail.com"
+ },
+ {
+ "name": "Marco Pivetta",
+ "email": "ocramius@gmail.com"
+ }
+ ],
+ "homepage": "https://www.doctrine-project.org/projects/event-manager.html",
+ "require": {
+ "php": "^7.1 || ^8.0",
+ "doctrine/deprecations": "^0.5.3 || ^1"
+ },
+ "require-dev": {
+ "doctrine/coding-standard": "^9 || ^10",
+ "phpstan/phpstan": "~1.4.10 || ^1.8.8",
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.5",
+ "vimeo/psalm": "^4.24"
+ },
+ "conflict": {
+ "doctrine/common": "<2.9"
+ },
+ "autoload": {
+ "psr-4": {
+ "Doctrine\\Common\\": "src"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Doctrine\\Tests\\Common\\": "tests"
+ }
+ },
+ "config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "sort-packages": true
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..37cb6a2
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-doctrine-event-manager2.spec b/php-doctrine-event-manager2.spec
new file mode 100644
index 0000000..ce7d705
--- /dev/null
+++ b/php-doctrine-event-manager2.spec
@@ -0,0 +1,165 @@
+# remirepo/fedora spec file for php-doctrine-event-manager
+#
+# Copyright (c) 2018-2022 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%global bootstrap 0
+%global gh_commit 95aa4cb529f1e96576f3fda9f5705ada4056a520
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner doctrine
+%global gh_project event-manager
+# packagist
+%global pk_vendor %{gh_owner}
+%global pk_project %{gh_project}
+# Namespace
+%global ns_vendor Doctrine
+%global ns_project Common
+%global ns_subproj EventManager
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}
+Version: 1.2.0
+Release: 1%{?dist}
+Summary: Simple PHP event system, version 1
+
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+BuildRequires: php-fedora-autoloader-devel
+%if %{with_tests}
+BuildRequires: php(language) >= 7.1
+BuildRequires: php-reflection
+BuildRequires: php-spl
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(doctrine/deprecations) >= 0.5.3 with php-composer(doctrine/deprecations) < 2)
+# remirepo:4
+%else
+BuildRequires: php-composer(doctrine/deprecations) < 2
+BuildRequires: php-composer(doctrine/deprecations) >= 0.5.3
+%endif
+BuildRequires: phpunit9
+%endif
+
+# From composer.json
+# "php": "^7.1 || ^8.0"
+# "doctrine/deprecations": "^0.5.3 || ^1"
+Requires: php(language) >= 7.1
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(doctrine/deprecations) >= 0.5.3 with php-composer(doctrine/deprecations) < 2)
+# remirepo:4
+%else
+Requires: php-composer(doctrine/deprecations) < 2
+Requires: php-composer(doctrine/deprecations) >= 0.5.3
+%endif
+# From phpcompatinfo report for version 1.2.0
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+# Split off doctrine/common
+Conflicts: php-doctrine-common < 1:2.9
+
+
+%description
+The Doctrine Event Manager is a simple PHP event system that was built
+to be used with the various Doctrine projects.
+
+Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/%{ns_subproj}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+: Generate a simple autoloader
+mkdir src/%{ns_subproj}
+%{_bindir}/phpab \
+ --output src/%{ns_subproj}/autoload.php \
+ --template fedora \
+ src
+
+cat << 'AUTOLOAD' | tee -a src/%{ns_subproj}/autoload.php
+
+\Fedora\Autoloader\Dependencies::required([
+ '%{_datadir}/php/Doctrine/Deprecations/autoload.php',
+]);
+AUTOLOAD
+
+
+%install
+mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
+cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}
+
+
+%check
+%if %{with_tests}
+: Generate autoloader
+mkdir vendor
+%{_bindir}/phpab \
+ --output vendor/autoload.php \
+ --template fedora \
+ tests
+cat << 'EOF' | tee -a vendor/autoload.php
+require "%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/%{ns_subproj}/autoload.php";
+EOF
+
+: Run test suite
+ret=0
+for cmd in php php74 php80 php81 php82; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit9 \
+ --bootstrap vendor/autoload.php \
+ --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{_datadir}/php/%{ns_vendor}/
+ %{_datadir}/php/%{ns_vendor}/%{ns_project}/
+
+
+%changelog
+* Thu Oct 13 2022 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+- add dependency on doctrine/deprecations
+
+* Thu Jul 28 2022 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- update to 1.1.2
+- switch to phpunit9
+
+* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1 (no change)
+
+* Tue Nov 12 2019 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
+* Thu Nov 22 2018 Remi Collet <remi@remirepo.net> - 1.0.0-2
+- fix conflicts
+
+* Thu Oct 18 2018 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package, version 1.0.0