summaryrefslogtreecommitdiffstats
path: root/php-doctrine-doctrine-cache-bundle.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-doctrine-cache-bundle.spec')
-rw-r--r--php-doctrine-doctrine-cache-bundle.spec60
1 files changed, 39 insertions, 21 deletions
diff --git a/php-doctrine-doctrine-cache-bundle.spec b/php-doctrine-doctrine-cache-bundle.spec
index 3b07301..936da3d 100644
--- a/php-doctrine-doctrine-cache-bundle.spec
+++ b/php-doctrine-doctrine-cache-bundle.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-doctrine-cache-bundle
#
-# Copyright (c) 2015-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2015-2018 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name DoctrineCacheBundle
-%global github_version 1.3.2
-%global github_commit 9baecbd6bfdd1123b0cf8c1b88fee0170a84ddd1
+%global github_version 1.3.3
+%global github_commit 4c8e363f96427924e7e519c5b5119b4f54512697
%global composer_vendor doctrine
%global composer_project doctrine-cache-bundle
@@ -26,12 +26,12 @@
# "doctrine/inflector": "~1.0"
%global inflector_min_ver 1.0
%global inflector_max_ver 2.0
-# "symfony/doctrine-bridge": "~2.2|~3.0|~4.0"
-# "symfony/yaml": "~2.2|~3.0|~4.0",
-# "symfony/validator": "~2.2|~3.0|~4.0",
-# "symfony/console": "~2.2|~3.0|~4.0",
-# "symfony/finder": "~2.2|~3.0|~4.0",
-# "symfony/framework-bundle": "~2.2|~3.0|~4.0",
+# "symfony/doctrine-bridge": "~2.7|~3.3|~4.0"
+# "symfony/yaml": "~2.7|~3.3|~4.0",
+# "symfony/validator": "~2.7|~3.3|~4.0",
+# "symfony/console": "~2.7|~3.3|~4.0",
+# "symfony/finder": "~2.7|~3.3|~4.0",
+# "symfony/framework-bundle": "~2.7|~3.3|~4.0",
# NOTE: Min version not 2.3 because autoloader required
%global symfony_min_ver 2.7.1
%global symfony_max_ver 5
@@ -59,20 +59,22 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(phpunit/phpunit)
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(doctrine/cache) >= %{cache_min_ver} with php-composer(doctrine/cache) < %{cache_max_ver})
+BuildRequires: (php-composer(doctrine/inflector) >= %{inflector_min_ver} with php-composer(doctrine/inflector) < %{inflector_max_ver})
+# ensure we use same version of all components
+BuildRequires: php-symfony4-console
+BuildRequires: php-symfony4-doctrine-bridge
+BuildRequires: php-symfony4-finder
+BuildRequires: php-symfony4-framework-bundle
+BuildRequires: php-symfony4-validator
+BuildRequires: php-symfony4-yaml
+%else
BuildRequires: php-composer(doctrine/cache) < %{cache_max_ver}
BuildRequires: php-composer(doctrine/cache) >= %{cache_min_ver}
BuildRequires: php-composer(doctrine/inflector) < %{inflector_max_ver}
BuildRequires: php-composer(doctrine/inflector) >= %{inflector_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
-%if 0%{?fedora} >= 27
-# ensure we use same version of all components
-BuildRequires: php-symfony3-console
-BuildRequires: php-symfony3-doctrine-bridge
-BuildRequires: php-symfony3-finder
-BuildRequires: php-symfony3-framework-bundle
-BuildRequires: php-symfony3-validator
-BuildRequires: php-symfony3-yaml
-%else
BuildRequires: php-symfony-console
BuildRequires: php-symfony-doctrine-bridge
BuildRequires: php-symfony-finder
@@ -97,12 +99,18 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(doctrine/cache) >= %{cache_min_ver} with php-composer(doctrine/cache) < %{cache_max_ver})
+Requires: (php-composer(doctrine/inflector) >= %{inflector_min_ver} with php-composer(doctrine/inflector) < %{inflector_max_ver})
+Requires: (php-composer(symfony/doctrine-bridge) >= %{symfony_min_ver} with php-composer(symfony/doctrine-bridge) < %{symfony_max_ver})
+%else
Requires: php-composer(doctrine/cache) < %{cache_max_ver}
Requires: php-composer(doctrine/cache) >= %{cache_min_ver}
Requires: php-composer(doctrine/inflector) < %{inflector_max_ver}
Requires: php-composer(doctrine/inflector) >= %{inflector_min_ver}
Requires: php-composer(symfony/doctrine-bridge) < %{symfony_max_ver}
Requires: php-composer(symfony/doctrine-bridge) >= %{symfony_min_ver}
+%endif
# phpcompatinfo (computed from version 1.3.0)
Requires: php-hash
Requires: php-reflection
@@ -110,7 +118,7 @@ Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
# Weak dependencies
-%if 0%{?fedora} >= 21
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
Suggests: php-pecl(memcache)
Suggests: php-pecl(memcached)
Suggests: php-pecl(mongo)
@@ -176,22 +184,27 @@ require_once '%{buildroot}%{phpdir}/Doctrine/Bundle/DoctrineCacheBundle/autoload
\Fedora\Autoloader\Dependencies::required(array(
array(
+ '%{phpdir}/Symfony4/Bundle/FrameworkBundle/autoload.php',
'%{phpdir}/Symfony3/Bundle/FrameworkBundle/autoload.php',
'%{phpdir}/Symfony/Bundle/FrameworkBundle/autoload.php',
),
array(
+ '%{phpdir}/Symfony4/Component/Console/autoload.php',
'%{phpdir}/Symfony3/Component/Console/autoload.php',
'%{phpdir}/Symfony/Component/Console/autoload.php',
),
array(
+ '%{phpdir}/Symfony4/Component/Finder/autoload.php',
'%{phpdir}/Symfony3/Component/Finder/autoload.php',
'%{phpdir}/Symfony/Component/Finder/autoload.php',
),
array(
+ '%{phpdir}/Symfony4/Component/Validator/autoload.php',
'%{phpdir}/Symfony3/Component/Validator/autoload.php',
'%{phpdir}/Symfony/Component/Validator/autoload.php',
),
array(
+ '%{phpdir}/Symfony4/Component/Yaml/autoload.php',
'%{phpdir}/Symfony3/Component/Yaml/autoload.php',
'%{phpdir}/Symfony/Component/Yaml/autoload.php',
),
@@ -213,7 +226,7 @@ popd
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in "" %{?rhel:php54 php55 php56 php70} php71 php72 php73; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -236,6 +249,11 @@ exit $RETURN_CODE
%changelog
+* Wed Oct 17 2018 Remi Collet <remi@remirepo.net> - 1.3.3-1
+- update to 1.3.3
+- switch to Symfony 4 for test suite
+- use range dependencies
+
* Fri Nov 10 2017 Remi Collet <remi@remirepo.net> - 1.3.2-1
- Update to 1.3.2
- fix FTBFS from Koschei