summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json67
-rw-r--r--php-doctrine-doctrine-cache-bundle.spec67
2 files changed, 106 insertions, 28 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..82d4a40
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,67 @@
+{
+ "name": "doctrine/doctrine-cache-bundle",
+ "homepage": "http://www.doctrine-project.org",
+ "description": "Symfony Bundle for Doctrine Cache",
+ "keywords": ["cache", "caching"],
+ "type": "symfony-bundle",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Fabien Potencier",
+ "email": "fabien@symfony.com"
+ },
+ {
+ "name": "Benjamin Eberlei",
+ "email": "kontakt@beberlei.de"
+ },
+ {
+ "name": "Fabio B. Silva",
+ "email": "fabio.bat.silva@gmail.com"
+ },
+ {
+ "name": "Guilherme Blanco",
+ "email": "guilhermeblanco@hotmail.com"
+ },
+ {
+ "name": "Symfony Community",
+ "homepage": "http://symfony.com/contributors"
+ },
+ {
+ "name": "Doctrine Project",
+ "homepage": "http://www.doctrine-project.org/"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.2",
+ "symfony/doctrine-bridge": "~2.2|~3.0|~4.0",
+ "doctrine/inflector": "~1.0",
+ "doctrine/cache": "^1.4.2"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~4",
+ "symfony/phpunit-bridge": "~2.7|~3.0|~4.0",
+ "symfony/yaml": "~2.2|~3.0|~4.0",
+ "symfony/validator": "~2.2|~3.0|~4.0",
+ "symfony/console": "~2.2|~3.0|~4.0",
+ "symfony/finder": "~2.2|~3.0|~4.0",
+ "symfony/framework-bundle": "~2.2|~3.0|~4.0",
+ "symfony/security-acl": "~2.3|~3.0",
+ "instaclick/coding-standard": "~1.1",
+ "satooshi/php-coveralls": "^1.0",
+ "squizlabs/php_codesniffer": "~1.5",
+ "instaclick/object-calisthenics-sniffs": "dev-master",
+ "instaclick/symfony2-coding-standard": "dev-remaster",
+ "predis/predis": "~0.8"
+ },
+ "suggest": {
+ "symfony/security-acl": "For using this bundle to cache ACLs"
+ },
+ "autoload": {
+ "psr-4": { "Doctrine\\Bundle\\DoctrineCacheBundle\\": "" }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.3.x-dev"
+ }
+ }
+}
diff --git a/php-doctrine-doctrine-cache-bundle.spec b/php-doctrine-doctrine-cache-bundle.spec
index 8c6ff7d..3b07301 100644
--- a/php-doctrine-doctrine-cache-bundle.spec
+++ b/php-doctrine-doctrine-cache-bundle.spec
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name DoctrineCacheBundle
-%global github_version 1.3.0
-%global github_commit 18c600a9b82f6454d2e81ca4957cdd56a1cf3504
+%global github_version 1.3.2
+%global github_commit 9baecbd6bfdd1123b0cf8c1b88fee0170a84ddd1
%global composer_vendor doctrine
%global composer_project doctrine-cache-bundle
@@ -26,16 +26,18 @@
# "doctrine/inflector": "~1.0"
%global inflector_min_ver 1.0
%global inflector_max_ver 2.0
-# "symfony/doctrine-bridge": "~2.2|~3.0"
-# "symfony/yaml": "~2.2|~3.0",
-# "symfony/validator": "~2.2|~3.0",
-# "symfony/console": "~2.2|~3.0",
-# "symfony/finder": "~2.2|~3.0",
-# "symfony/framework-bundle": "~2.2|~3.0",
-# "symfony/security-acl": "~2.3|~3.0",
+# "symfony/doctrine-bridge": "~2.2|~3.0|~4.0"
+# "symfony/yaml": "~2.2|~3.0|~4.0",
+# "symfony/validator": "~2.2|~3.0|~4.0",
+# "symfony/console": "~2.2|~3.0|~4.0",
+# "symfony/finder": "~2.2|~3.0|~4.0",
+# "symfony/framework-bundle": "~2.2|~3.0|~4.0",
# NOTE: Min version not 2.3 because autoloader required
%global symfony_min_ver 2.7.1
-%global symfony_max_ver 4.0
+%global symfony_max_ver 5
+# "symfony/security-acl": "~2.3|~3.0",
+%global secacl_min_ver 2.2
+%global secacl_max_ver 4
# Build using "--without tests" to disable tests
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
@@ -44,7 +46,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 5%{?dist}
+Release: 1%{?dist}
Summary: Symfony2 Bundle for Doctrine Cache
Group: Development/Libraries
@@ -62,24 +64,28 @@ BuildRequires: php-composer(doctrine/cache) >= %{cache_min_ver}
BuildRequires: php-composer(doctrine/inflector) < %{inflector_max_ver}
BuildRequires: php-composer(doctrine/inflector) >= %{inflector_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-BuildRequires: php-composer(symfony/console) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/console) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/doctrine-bridge) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/doctrine-bridge) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/finder) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/finder) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/framework-bundle) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/framework-bundle) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/validator) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/validator) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/yaml) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/yaml) >= %{symfony_min_ver}
+%if 0%{?fedora} >= 27
+# ensure we use same version of all components
+BuildRequires: php-symfony3-console
+BuildRequires: php-symfony3-doctrine-bridge
+BuildRequires: php-symfony3-finder
+BuildRequires: php-symfony3-framework-bundle
+BuildRequires: php-symfony3-validator
+BuildRequires: php-symfony3-yaml
+%else
+BuildRequires: php-symfony-console
+BuildRequires: php-symfony-doctrine-bridge
+BuildRequires: php-symfony-finder
+BuildRequires: php-symfony-framework-bundle
+BuildRequires: php-symfony-validator
+BuildRequires: php-symfony-yaml
+%endif
%if 0
BuildRequires: php-composer(symfony/security) < %{symfony_max_ver}
BuildRequires: php-composer(symfony/security) >= %{symfony_min_ver}
%else
-BuildRequires: php-composer(symfony/security-acl) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/security-acl) >= %{symfony_min_ver}
+BuildRequires: php-composer(symfony/security-acl) < %{secacl_max_ver}
+BuildRequires: php-composer(symfony/security-acl) >= %{secacl_min_ver}
%endif
## phpcompatinfo (computed from version 1.3.0)
BuildRequires: php-hash
@@ -110,8 +116,6 @@ Suggests: php-pecl(memcached)
Suggests: php-pecl(mongo)
Suggests: php-composer(symfony/security-acl)
%endif
-Conflicts: php-symfony-security < %{symfony_min_ver}
-Conflicts: php-symfony-security >= %{symfony_max_ver}
# Composer
Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
@@ -142,7 +146,8 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
'%{phpdir}/Doctrine/Common/Cache/autoload.php',
'%{phpdir}/Doctrine/Common/Inflector/autoload.php',
array(
- (getenv('RPM_SYMFONY_TREE')?:'%{phpdir}/Symfony3') . '/Bridge/Doctrine/autoload.php',
+ (getenv('RPM_SYMFONY_TREE')?:'%{phpdir}/Symfony4') . '/Bridge/Doctrine/autoload.php',
+ '%{phpdir}/Symfony3/Bridge/Doctrine/autoload.php',
'%{phpdir}/Symfony/Bridge/Doctrine/autoload.php',
),
));
@@ -231,6 +236,12 @@ exit $RETURN_CODE
%changelog
+* Fri Nov 10 2017 Remi Collet <remi@remirepo.net> - 1.3.2-1
+- Update to 1.3.2
+- fix FTBFS from Koschei
+- ensure we use same version of all component at build time
+- allow symfony/doctrine-bridge v4
+
* Tue May 30 2017 Remi Collet <remi@remirepo.net> - 1.3.0-5
- allow to force Symfony version using RPM_SYMFONY_TREE