summaryrefslogtreecommitdiffstats
path: root/php-doctrine-doctrine-bundle2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-doctrine-bundle2.spec')
-rw-r--r--php-doctrine-doctrine-bundle2.spec24
1 files changed, 19 insertions, 5 deletions
diff --git a/php-doctrine-doctrine-bundle2.spec b/php-doctrine-doctrine-bundle2.spec
index cdc4625..d035a45 100644
--- a/php-doctrine-doctrine-bundle2.spec
+++ b/php-doctrine-doctrine-bundle2.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name DoctrineBundle
-%global github_version 2.6.0
-%global github_commit eca20633225fde77d042ecdac222bc9a5cb20f6a
+%global github_version 2.6.1
+%global github_commit b7002752b555cb61cc9ca8d4c89a5b6e8200f765
%global major 2
%global composer_vendor doctrine
@@ -25,6 +25,9 @@
# "doctrine/annotations": "^1",
%global annotations_min_ver 1
%global annotations_max_ver 2
+# "psr/log": "^1.1.4|^2.0|^3.0",
+%global psr_log_min_ver 1.1.4
+%global psr_log_max_ver 4
# "doctrine/cache": "^1.11|^2.0"
%global cache_min_ver 1.11
%global cache_max_ver 3
@@ -34,8 +37,8 @@
# "doctrine/persistence": "^2.2",
%global persistence_min_ver 2.2
%global persistence_max_ver 3
-# "doctrine/orm": "~2.9 || ^3.0"
-%global orm_min_ver 2.9
+# "doctrine/orm": "~2.10 || ^3.0"
+%global orm_min_ver 2.10
%global orm_max_ver 4
# "doctrine/sql-formatter": "^1.0.1"
%global sql_formatter_min_ver 1.0.1
@@ -101,11 +104,12 @@ BuildRequires:(php-composer(doctrine/dbal) >= %{dbal_min_ver}
BuildRequires:(php-composer(doctrine/orm) >= %{orm_min_ver} with php-composer(doctrine/orm) < %{orm_max_ver})
BuildRequires:(php-composer(doctrine/persistence) >= %{persistence_min_ver} with php-composer(doctrine/persistence) < %{persistence_max_ver})
BuildRequires:(php-composer(doctrine/sql-formatter) >= %{sql_formatter_min_ver} with php-composer(doctrine/sql-formatter) < %{sql_formatter_max_ver})
+BuildRequires:(php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
BuildRequires:(php-composer(symfony/deprecation-contracts) >= %{contracts_min_ver} with php-composer(symfony/deprecation-contracts) < %{contracts_max_ver})
BuildRequires:(php-composer(symfony/service-contracts) >= %{contracts_min_ver} with php-composer(symfony/service-contracts) < %{contracts_max_ver})
BuildRequires:(php-composer(friendsofphp/proxy-manager-lts) >= %{proxy_manager_min_ver} with php-composer(friendsofphp/proxy-manager-lts) < %{proxy_manager_max_ver})
BuildRequires:(php-composer(twig/twig) >= %{twig_min_ver} with php-composer(twig/twig) < %{twig_max_ver})
-# remirepo:22
+# remirepo:24
%else
BuildRequires: php-composer(doctrine/annotations) < %{annotations_max_ver}
BuildRequires: php-composer(doctrine/annotations) >= %{annotations_min_ver}
@@ -119,6 +123,8 @@ BuildRequires: php-composer(doctrine/orm) < %{orm_max_ver}
BuildRequires: php-composer(doctrine/orm) >= %{orm_min_ver}
BuildRequires: php-composer(doctrine/sql-formatter) < %{sql_formatter_max_ver}
BuildRequires: php-composer(doctrine/sql-formatter) >= %{sql_formatter_min_ver}
+BuildRequires: php-composer(psr/log) < %{psr_log_max_ver}
+BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
BuildRequires: php-composer(symfony/deprecation-contracts) < %{contracts_max_ver}
BuildRequires: php-composer(symfony/deprecation-contracts) >= %{contracts_min_ver}
BuildRequires: php-composer(symfony/service-contracts) < %{contracts_max_ver}
@@ -335,6 +341,11 @@ require '%{buildroot}%{phpdir}/Doctrine/Bundle/DoctrineBundle%{major}/autoload.p
'%{phpdir}/Symfony4/Bridge/ProxyManager/autoload.php',
'%{phpdir}/Symfony4/Bridge/Twig/autoload.php',
'%{phpdir}/FriendsOfPHP/ProxyManager/autoload.php',
+ [
+ '%{phpdir}/Psr/Log3/autoload.php',
+ '%{phpdir}/Psr/Log2/autoload.php',
+ '%{phpdir}/Psr/Log/autoload.php',
+ ],
]);
EOF
@@ -375,6 +386,9 @@ exit $RETURN_CODE
%changelog
+* Mon Apr 4 2022 Remi Collet <remi@remirepo.net> - 2.6.1-1
+- update to 2.6.1
+
* Wed Mar 30 2022 Remi Collet <remi@remirepo.net> - 2.6.0-1
- update to 2.6.0