summaryrefslogtreecommitdiffstats
path: root/php-doctrine-doctrine-bundle2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-doctrine-bundle2.spec')
-rw-r--r--php-doctrine-doctrine-bundle2.spec87
1 files changed, 44 insertions, 43 deletions
diff --git a/php-doctrine-doctrine-bundle2.spec b/php-doctrine-doctrine-bundle2.spec
index 63f21aa..804de82 100644
--- a/php-doctrine-doctrine-bundle2.spec
+++ b/php-doctrine-doctrine-bundle2.spec
@@ -1,8 +1,9 @@
-# remirepo spec file for php-doctrine-doctrine-bundle, from:
+# remirepo spec file for php-doctrine-doctrine-bundle2, from:
#
-# Fedora spec file for php-doctrine-doctrine-bundle
+# Fedora spec file for php-doctrine-doctrine-bundle2
#
# Copyright (c) 2015-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Remi Collet <remi@fedoraproject.org>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,41 +13,39 @@
%global github_owner doctrine
%global github_name DoctrineBundle
-%global github_version 1.12.0
-%global github_commit a374f3bc54fe7c23ddb722ef6b9ddd2d9dcb9115
+%global github_version 2.0.0
+%global github_commit 82826278bb88ae8c20aee3af3191430dcbcca63a
+%global major 2
%global composer_vendor doctrine
%global composer_project doctrine-bundle
# "php": "^7.1"
%global php_min_ver 7.1
-# "doctrine/dbal": "^2.5.12"
-%global dbal_min_ver 2.5.12
+# "doctrine/dbal": "^2.9.0"
+%global dbal_min_ver 2.9
%global dbal_max_ver 3.0
-# "doctrine/doctrine-cache-bundle": "~1.2"
-%global cache_bundle_min_ver 1.2
-%global cache_bundle_max_ver 2.0
# "doctrine/orm": "~2.6"
%global orm_min_ver 2.6
%global orm_max_ver 3.0
# "jdorn/sql-formatter": "^1.2.16"
%global sql_formatter_min_ver 1.2.16
%global sql_formatter_max_ver 2.0
-# "symfony/config": "^3.4.30|^4.3.3",
-# "symfony/console": "^3.4.30|^4.3.3"
-# "symfony/dependency-injection": "^3.4.30|^4.3.3"
-# "symfony/doctrine-bridge": "^3.4.30|^4.3.3"
-# "symfony/framework-bundle": "^3.4.30|^4.3.3"
-# "symfony/cache": "^3.4.30|^4.3.3",
-# "symfony/property-info": "^3.4.30|^4.3.3"
-# "symfony/twig-bridge": "^3.4|^4.1",
-# "symfony/validator": "^3.4.30|^4.3.3"
-# "symfony/web-profiler-bundle": "^3.4.30|^4.3.3"
-# "symfony/yaml": "^3.4.30|^4.3.3"
-%global symfony_min_ver 3.4
+# "symfony/config": "^4.3.3|^5.0",
+# "symfony/console": "^3.4.30|^4.3.3|^5.0"
+# "symfony/dependency-injection": "^^4.3.3|^5.0"
+# "symfony/doctrine-bridge": "^4.3.7|^5.0"
+# "symfony/framework-bundle": "^3.4.30|^4.3.3|^5.0"
+# "symfony/cache": "^3.4.30|^4.3.3|^5.0",
+# "symfony/property-info": "^4.3.3|^5.0"
+# "symfony/twig-bridge": "^3.4.30|^4.3.3|^5.0",
+# "symfony/validator": "^3.4.30|^4.3.3|^5.0"
+# "symfony/web-profiler-bundle": "^3.4.30|^4.3.3|^5.0"
+# "symfony/yaml": "^3.4.30|^4.3.3|^5.0"
+%global symfony_min_ver 4.3.7
%global symfony_max_ver 5
-%global symfony_br_ver 4.3.3
-# "twig/twig": "~1.34|~2.12"
+%global symfony_br_ver %{symfony_min_ver}
+# "twig/twig": "^1.34|^2.12"
%global twig_min_ver 1.34
%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
%global twig_max_ver 3
@@ -59,7 +58,7 @@
%{!?phpdir: %global phpdir %{_datadir}/php}
-Name: php-%{composer_vendor}-%{composer_project}
+Name: php-%{composer_vendor}-%{composer_project}%{major}
Version: %{github_version}
Release: 1%{?dist}
Summary: Symfony Bundle for Doctrine
@@ -80,16 +79,13 @@ BuildRequires: php-theseer-autoload
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires:(php-composer(doctrine/dbal) >= %{dbal_min_ver} with php-composer(doctrine/dbal) < %{dbal_max_ver})
-BuildRequires:(php-composer(doctrine/doctrine-cache-bundle) >= %{cache_bundle_min_ver} with php-composer(doctrine/doctrine-cache-bundle) < %{cache_bundle_max_ver})
BuildRequires:(php-composer(doctrine/orm) >= %{orm_min_ver} with php-composer(doctrine/orm) < %{orm_max_ver})
BuildRequires:(php-composer(jdorn/sql-formatter) >= %{sql_formatter_min_ver} with php-composer(jdorn/sql-formatter) < %{sql_formatter_max_ver})
BuildRequires:(php-composer(twig/twig) >= %{twig_min_ver} with php-composer(twig/twig) < %{twig_max_ver})
-# remirepo:12
+# remirepo:10
%else
BuildRequires: php-composer(doctrine/dbal) < %{dbal_max_ver}
BuildRequires: php-composer(doctrine/dbal) >= %{dbal_min_ver}
-BuildRequires: php-composer(doctrine/doctrine-cache-bundle) < %{cache_bundle_max_ver}
-BuildRequires: php-composer(doctrine/doctrine-cache-bundle) >= %{cache_bundle_min_ver}
BuildRequires: php-composer(doctrine/orm) < %{orm_max_ver}
BuildRequires: php-composer(doctrine/orm) >= %{orm_min_ver}
BuildRequires: php-composer(jdorn/sql-formatter) < %{sql_formatter_max_ver}
@@ -112,7 +108,7 @@ BuildRequires: php-symfony4-validator >= %{symfony_br_ver}
BuildRequires: php-symfony4-web-profiler-bundle >= %{symfony_br_ver}
BuildRequires: php-symfony4-yaml >= %{symfony_br_ver}
BuildRequires: phpunit7 >= 7.5
-## phpcompatinfo (computed from version 1.11.0)
+## phpcompatinfo (computed from version 2.0.0)
BuildRequires: php-dom
BuildRequires: php-pcre
BuildRequires: php-reflection
@@ -126,19 +122,16 @@ Requires: php(language) >= %{php_min_ver}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(doctrine/dbal) >= %{dbal_min_ver} with php-composer(doctrine/dbal) < %{dbal_max_ver})
-Requires: (php-composer(doctrine/doctrine-cache-bundle) >= %{cache_bundle_min_ver} with php-composer(doctrine/doctrine-cache-bundle) < %{cache_bundle_max_ver})
Requires: (php-composer(jdorn/sql-formatter) >= %{sql_formatter_min_ver} with php-composer(jdorn/sql-formatter) < %{sql_formatter_max_ver})
Requires: (php-composer(symfony/config) >= %{symfony_min_ver} with php-composer(symfony/config) < %{symfony_max_ver})
Requires: (php-composer(symfony/console) >= %{symfony_min_ver} with php-composer(symfony/console) < %{symfony_max_ver})
Requires: (php-composer(symfony/dependency-injection) >= %{symfony_min_ver} with php-composer(symfony/dependency-injection) < %{symfony_max_ver})
Requires: (php-composer(symfony/doctrine-bridge) >= %{symfony_min_ver} with php-composer(symfony/doctrine-bridge) < %{symfony_max_ver})
Requires: (php-composer(symfony/framework-bundle) >= %{symfony_min_ver} with php-composer(symfony/framework-bundle) < %{symfony_max_ver})
-# remirepo:18
+# remirepo:16
%else
Requires: php-composer(doctrine/dbal) >= %{dbal_min_ver}
Requires: php-composer(doctrine/dbal) < %{dbal_max_ver}
-Requires: php-composer(doctrine/doctrine-cache-bundle) >= %{cache_bundle_min_ver}
-Requires: php-composer(doctrine/doctrine-cache-bundle) < %{cache_bundle_max_ver}
Requires: php-composer(jdorn/sql-formatter) >= %{sql_formatter_min_ver}
Requires: php-composer(jdorn/sql-formatter) < %{sql_formatter_max_ver}
Requires: php-composer(symfony/config) >= %{symfony_min_ver}
@@ -152,7 +145,7 @@ Requires: php-composer(symfony/doctrine-bridge) < %{symfony_max_ver
Requires: php-composer(symfony/framework-bundle) >= %{symfony_min_ver}
Requires: php-composer(symfony/framework-bundle) < %{symfony_max_ver}
%endif
-# phpcompatinfo (computed from version 1.11.0)
+# phpcompatinfo (computed from version 2.0.0)
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
@@ -174,7 +167,7 @@ Suggests: php-composer(twig/twig)
%description
Doctrine DBAL & ORM Bundle for the Symfony Framework.
-Autoloader: %{phpdir}/Doctrine/Bundle/DoctrineBundle/autoload.php
+Autoloader: %{phpdir}/Doctrine/Bundle/DoctrineBundle%{major}/autoload.php
%prep
@@ -204,7 +197,6 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Bundle\\DoctrineBundle\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
- '%{phpdir}/Doctrine/Bundle/DoctrineCacheBundle/autoload.php',
'%{phpdir}/Doctrine/DBAL/autoload.php',
'%{phpdir}/jdorn-sql-formatter/autoload.php',
[
@@ -238,15 +230,15 @@ AUTOLOAD
%install
-mkdir -p %{buildroot}%{phpdir}/Doctrine/Bundle/DoctrineBundle
-cp -pr * %{buildroot}%{phpdir}/Doctrine/Bundle/DoctrineBundle/
+mkdir -p %{buildroot}%{phpdir}/Doctrine/Bundle/DoctrineBundle%{major}
+cp -pr * %{buildroot}%{phpdir}/Doctrine/Bundle/DoctrineBundle%{major}/
%check
%if %{with_tests}
phpab -o bs.php Tests/DependencyInjection
cat << 'EOF' | tee -a bs.php
-require '%{buildroot}%{phpdir}/Doctrine/Bundle/DoctrineBundle/autoload.php';
+require '%{buildroot}%{phpdir}/Doctrine/Bundle/DoctrineBundle%{major}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{phpdir}/Symfony4/Component/Cache/autoload.php',
'%{phpdir}/Symfony4/Component/PropertyInfo/autoload.php',
@@ -260,7 +252,7 @@ sed -e '/listener/d' phpunit.xml.dist >phpunit.xml
: Upstream tests with SCLs if available
RETURN_CODE=0
-for SCL in php php71 php72 php73 php74; do
+for SCL in php php72 php73 php74; do
if which $SCL; then
$SCL %{_bindir}/phpunit7 \
--filter '^((?!(testBacktraceLogged)).)*$' \
@@ -279,12 +271,21 @@ exit $RETURN_CODE
%{!?_licensedir:%global license %%doc}
%license .rpm/licenses/*
%doc .rpm/docs/*
-%{phpdir}/Doctrine/Bundle/DoctrineBundle
-%exclude %{phpdir}/Doctrine/Bundle/DoctrineBundle/phpunit.*
-%exclude %{phpdir}/Doctrine/Bundle/DoctrineBundle/Tests
+%dir %{phpdir}/Doctrine/Bundle
+ %{phpdir}/Doctrine/Bundle/DoctrineBundle%{major}
+%exclude %{phpdir}/Doctrine/Bundle/DoctrineBundle%{major}/phpunit.*
+%exclude %{phpdir}/Doctrine/Bundle/DoctrineBundle%{major}/Tests
%changelog
+* Thu Nov 21 2019 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- update to 2.0.0
+- rename to php-doctrine-doctrine-bundle2
+- move to /usr/share/php/Doctrine/Bundle/DoctrineBundle2
+- raise dependency on doctrine/dbal 2.9.0
+- raise dependency on Symfony 4.3.3
+- drop dependency on doctrine/doctrine-cache-bundle
+
* Wed Nov 20 2019 Remi Collet <remi@remirepo.net> - 1.12.0-1
- update to 1.12.0
- add dependency on symfony/config