summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json16
-rw-r--r--php-doctrine-doctrine-bundle2-vendor.patch9
-rw-r--r--php-doctrine-doctrine-bundle2.spec8
3 files changed, 18 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 31cf84f..a987346 100644
--- a/composer.json
+++ b/composer.json
@@ -33,7 +33,7 @@
"symfony/config": "^4.3.3|^5.0",
"symfony/console": "^3.4.30|^4.3.3|^5.0",
"symfony/dependency-injection": "^4.3.3|^5.0",
- "symfony/doctrine-bridge": "^4.3.7|^5.0",
+ "symfony/doctrine-bridge": "^4.4.7|^5.0",
"symfony/framework-bundle": "^3.4.30|^4.3.3|^5.0",
"symfony/service-contracts": "^1.1.1|^2.0"
},
@@ -42,14 +42,18 @@
"doctrine/orm": "^2.6",
"friendsofphp/proxy-manager-lts": "^1.0",
"phpunit/phpunit": "^7.5 || ^8.0 || ^9.3",
- "symfony/phpunit-bridge": "^4.2",
+ "psalm/plugin-phpunit": "^0.15.1",
+ "psalm/plugin-symfony": "^2.2.4",
+ "symfony/phpunit-bridge": "^5.2",
"symfony/property-info": "^4.3.3|^5.0",
"symfony/proxy-manager-bridge": "^3.4|^4.3.3|^5.0",
+ "symfony/security-bundle": "^4.4|5.0",
"symfony/twig-bridge": "^3.4.30|^4.3.3|^5.0",
"symfony/validator": "^3.4.30|^4.3.3|^5.0",
"symfony/web-profiler-bundle": "^3.4.30|^4.3.3|^5.0",
"symfony/yaml": "^3.4.30|^4.3.3|^5.0",
- "twig/twig": "^1.34|^2.12|^3.0"
+ "twig/twig": "^1.34|^2.12|^3.0",
+ "vimeo/psalm": "^4.7"
},
"config": {
"sort-packages": true
@@ -60,6 +64,7 @@
},
"suggest": {
"doctrine/orm": "The Doctrine ORM integration is optional in the bundle.",
+ "ext-pdo": "*",
"symfony/web-profiler-bundle": "To use the data collector."
},
"autoload": {
@@ -67,10 +72,5 @@
},
"autoload-dev": {
"psr-4": { "": "Tests/DependencyInjection" }
- },
- "extra": {
- "branch-alias": {
- "dev-master": "2.3.x-dev"
- }
}
}
diff --git a/php-doctrine-doctrine-bundle2-vendor.patch b/php-doctrine-doctrine-bundle2-vendor.patch
index 2452445..68906a3 100644
--- a/php-doctrine-doctrine-bundle2-vendor.patch
+++ b/php-doctrine-doctrine-bundle2-vendor.patch
@@ -1,7 +1,7 @@
diff -up ./Tests/ProfilerTest.php.rpm ./Tests/ProfilerTest.php
---- ./Tests/ProfilerTest.php.rpm 2019-11-20 15:05:37.038969160 +0100
-+++ ./Tests/ProfilerTest.php 2019-11-20 15:07:34.760380533 +0100
-@@ -41,7 +41,7 @@ class ProfilerTest extends BaseTestCase
+--- ./Tests/ProfilerTest.php.rpm 2021-04-06 09:11:38.958882731 +0200
++++ ./Tests/ProfilerTest.php 2021-04-06 09:12:58.974653590 +0200
+@@ -46,7 +46,7 @@ class ProfilerTest extends BaseTestCase
$this->collector->addLogger('foo', $this->logger);
$twigLoaderFilesystem = new FilesystemLoader(__DIR__ . '/../Resources/views/Collector');
@@ -9,5 +9,4 @@ diff -up ./Tests/ProfilerTest.php.rpm ./Tests/ProfilerTest.php
+ $twigLoaderFilesystem->addPath('/usr/share/php/Symfony4/Bundle/WebProfilerBundle/Resources/views', 'WebProfiler');
$this->twig = new Environment($twigLoaderFilesystem, ['debug' => true, 'strict_variables' => true]);
- $fragmentHandler = $this->getMockBuilder(FragmentHandler::class)->disableOriginalConstructor()->getMock();
-
+ $fragmentHandler = $this->getMockBuilder(FragmentHandler::class);
diff --git a/php-doctrine-doctrine-bundle2.spec b/php-doctrine-doctrine-bundle2.spec
index 39ffc97..2baa1c6 100644
--- a/php-doctrine-doctrine-bundle2.spec
+++ b/php-doctrine-doctrine-bundle2.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name DoctrineBundle
-%global github_version 2.3.0
-%global github_commit 8b922578bdee2243a26202b13df795e170efaef8
+%global github_version 2.3.1
+%global github_commit a08bc3b4d8567cdff05e89b272ba1e06e9d71c21
%global major 2
%global composer_vendor doctrine
@@ -197,6 +197,7 @@ Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
Suggests: php-composer(doctrine/orm)
Suggests: php-composer(symfony/web-profiler-bundle)
Suggests: php-composer(twig/twig)
+Suggests: php-pdo
# remirepo:1
%endif
@@ -326,6 +327,9 @@ exit $RETURN_CODE
%changelog
+* Tue Apr 6 2021 Remi Collet <remi@remirepo.net> - 2.3.1-1
+- update to 2.3.1
+
* Mon Mar 29 2021 Remi Collet <remi@remirepo.net> - 2.3.0-1
- update to 2.3.0