summaryrefslogtreecommitdiffstats
path: root/php-doctrine-doctrine-bundle.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-01-08 09:02:28 +0100
committerRemi Collet <remi@remirepo.net>2019-01-08 09:02:28 +0100
commitd1e307c8158328e6559fcadc493a65cfa0b59ee6 (patch)
tree8b2b3161ff19a60b069ba95ae017b1e512018ae8 /php-doctrine-doctrine-bundle.spec
parentbd17b09a6b32d6fe3554de9c2a8bc0407f2a3b2a (diff)
update to 1.10.1
prefer symfony 4
Diffstat (limited to 'php-doctrine-doctrine-bundle.spec')
-rw-r--r--php-doctrine-doctrine-bundle.spec58
1 files changed, 28 insertions, 30 deletions
diff --git a/php-doctrine-doctrine-bundle.spec b/php-doctrine-doctrine-bundle.spec
index c04e9df..57abcfb 100644
--- a/php-doctrine-doctrine-bundle.spec
+++ b/php-doctrine-doctrine-bundle.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-doctrine-bundle
#
-# Copyright (c) 2015-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2015-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name DoctrineBundle
-%global github_version 1.9.1
-%global github_commit 703fad32e4c8cbe609caf45a71a1d4266c830f0f
+%global github_version 1.10.1
+%global github_commit 82d2c63cd09acbde2332f55d9aa7b28aefe4983d
%global composer_vendor doctrine
%global composer_project doctrine-bundle
@@ -80,36 +80,28 @@ BuildRequires:(php-composer(doctrine/doctrine-cache-bundle) >= %{cache_bundle_mi
BuildRequires:(php-composer(doctrine/orm) >= %{orm_min_ver} with php-composer(doctrine/orm) < %{orm_max_ver})
BuildRequires:(php-composer(jdorn/sql-formatter) >= %{sql_formatter_min_ver} with php-composer(jdorn/sql-formatter) < %{sql_formatter_max_ver})
BuildRequires:(php-composer(twig/twig) >= %{twig_min_ver} with php-composer(twig/twig) < %{twig_max_ver})
-# ensure same version of all components is used
-BuildRequires: php-symfony3-console
-BuildRequires: php-symfony3-dependency-injection
-BuildRequires: php-symfony3-doctrine-bridge
-BuildRequires: php-symfony3-framework-bundle
-BuildRequires: php-symfony3-property-info
-BuildRequires: php-symfony3-validator
-BuildRequires: php-symfony3-yaml
-BuildRequires: php-symfony3-web-profiler-bundle
%else
-BuildRequires: php-composer(doctrine/dbal) < %{dbal_min_ver}
+BuildRequires: php-composer(doctrine/dbal) < %{dbal_max_ver}
BuildRequires: php-composer(doctrine/dbal) >= %{dbal_min_ver}
-BuildRequires: php-composer(doctrine/doctrine-cache-bundle) < %{cache_bundle_min_ver}
+BuildRequires: php-composer(doctrine/doctrine-cache-bundle) < %{cache_bundle_max_ver}
BuildRequires: php-composer(doctrine/doctrine-cache-bundle) >= %{cache_bundle_min_ver}
-BuildRequires: php-composer(doctrine/orm) < %{orm_min_ver}
+BuildRequires: php-composer(doctrine/orm) < %{orm_max_ver}
BuildRequires: php-composer(doctrine/orm) >= %{orm_min_ver}
-BuildRequires: php-composer(jdorn/sql-formatter) < %{sql_formatter_min_ver}
+BuildRequires: php-composer(jdorn/sql-formatter) < %{sql_formatter_max_ver}
BuildRequires: php-composer(jdorn/sql-formatter) >= %{sql_formatter_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-BuildRequires: php-symfony-console
-BuildRequires: php-symfony-dependency-injection
-BuildRequires: php-symfony-doctrine-bridge
-BuildRequires: php-symfony-framework-bundle
-BuildRequires: php-symfony-property-info
-BuildRequires: php-symfony-validator
-BuildRequires: php-symfony-yaml
-BuildRequires: php-symfony-web-profiler-bundle
BuildRequires: php-composer(twig/twig) < %{twig_max_ver}
BuildRequires: php-composer(twig/twig) >= %{twig_min_ver}
%endif
+# ensure same version of all components is used
+BuildRequires: php-symfony4-console
+BuildRequires: php-symfony4-dependency-injection
+BuildRequires: php-symfony4-doctrine-bridge
+BuildRequires: php-symfony4-framework-bundle
+BuildRequires: php-symfony4-property-info
+BuildRequires: php-symfony4-validator
+BuildRequires: php-symfony4-yaml
+BuildRequires: php-symfony4-web-profiler-bundle
BuildRequires: php-composer(phpunit/phpunit)
## phpcompatinfo (computed from version 1.6.7)
BuildRequires: php-dom
@@ -161,7 +153,9 @@ Autoloader: %{phpdir}/Doctrine/Bundle/DoctrineBundle/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
-%patch0 -p0
+%patch0 -p1 -b .rpm
+
+find . -name \*.rpm -delete -print
: Licenses and docs
mkdir -p .rpm/{docs,licenses}
@@ -188,28 +182,28 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
'%{phpdir}/Doctrine/DBAL/autoload.php',
'%{phpdir}/jdorn-sql-formatter/autoload.php',
[
- '%{phpdir}/Symfony3/Bridge/Doctrine/autoload.php',
'%{phpdir}/Symfony4/Bridge/Doctrine/autoload.php',
+ '%{phpdir}/Symfony3/Bridge/Doctrine/autoload.php',
'%{phpdir}/Symfony/Bridge/Doctrine/autoload.php',
], [
- '%{phpdir}/Symfony3/Bundle/FrameworkBundle/autoload.php',
'%{phpdir}/Symfony4/Bundle/FrameworkBundle/autoload.php',
+ '%{phpdir}/Symfony3/Bundle/FrameworkBundle/autoload.php',
'%{phpdir}/Symfony/Bundle/FrameworkBundle/autoload.php',
], [
- '%{phpdir}/Symfony3/Component/Console/autoload.php',
'%{phpdir}/Symfony4/Component/Console/autoload.php',
+ '%{phpdir}/Symfony3/Component/Console/autoload.php',
'%{phpdir}/Symfony/Component/Console/autoload.php',
], [
- '%{phpdir}/Symfony3/Component/DependencyInjection/autoload.php',
'%{phpdir}/Symfony4/Component/DependencyInjection/autoload.php',
+ '%{phpdir}/Symfony3/Component/DependencyInjection/autoload.php',
'%{phpdir}/Symfony/Component/DependencyInjection/autoload.php',
]]);
\Fedora\Autoloader\Dependencies::optional([
'%{phpdir}/Doctrine/ORM/autoload.php',
[
- '%{phpdir}/Symfony3/Bundle/WebProfilerBundle/autoload.php',
'%{phpdir}/Symfony4/Bundle/WebProfilerBundle/autoload.php',
+ '%{phpdir}/Symfony3/Bundle/WebProfilerBundle/autoload.php',
'%{phpdir}/Symfony/Bundle/WebProfilerBundle/autoload.php',
], [
'%{phpdir}/Twig2/autoload.php',
@@ -254,6 +248,10 @@ exit $RETURN_CODE
%changelog
+* Tue Jan 8 2019 Remi Collet <remi@remirepo.net> - 1.10.1-1
+- update to 1.10.1
+- prefer symfony 4
+
* Wed Oct 17 2018 Remi Collet <remi@remirepo.net> - 1.9.1-1
- update to 1.9.1
- raise dependency on doctrine/dbal 2.5.12