summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-05-03 08:12:27 +0200
committerRemi Collet <remi@php.net>2022-05-03 08:12:27 +0200
commitd634b1f8ecadd66d38186010fb179e6a398d4ac8 (patch)
tree66c7f312ffba7acbfd07a03f6ebae9e4cdbd3456
parent2899d204c64f36fbc2131c4bab3d556dcd969b9e (diff)
update to 3.3.6
allow doctrine/deprecations 1
-rw-r--r--composer.json12
-rw-r--r--php-doctrine-dbal3.spec10
2 files changed, 13 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 81016de..17b1240 100644
--- a/composer.json
+++ b/composer.json
@@ -34,22 +34,22 @@
"php": "^7.3 || ^8.0",
"composer-runtime-api": "^2",
"doctrine/cache": "^1.11|^2.0",
- "doctrine/deprecations": "^0.5.3",
+ "doctrine/deprecations": "^0.5.3|^1",
"doctrine/event-manager": "^1.0",
"psr/cache": "^1|^2|^3",
"psr/log": "^1|^2|^3"
},
"require-dev": {
"doctrine/coding-standard": "9.0.0",
- "jetbrains/phpstorm-stubs": "2021.1",
- "phpstan/phpstan": "1.5.3",
- "phpstan/phpstan-strict-rules": "^1.1",
- "phpunit/phpunit": "9.5.16",
+ "jetbrains/phpstorm-stubs": "2022.1",
+ "phpstan/phpstan": "1.6.3",
+ "phpstan/phpstan-strict-rules": "^1.2",
+ "phpunit/phpunit": "9.5.20",
"psalm/plugin-phpunit": "0.16.1",
"squizlabs/php_codesniffer": "3.6.2",
"symfony/cache": "^5.2|^6.0",
"symfony/console": "^2.7|^3.0|^4.0|^5.0|^6.0",
- "vimeo/psalm": "4.22.0"
+ "vimeo/psalm": "4.23.0"
},
"suggest": {
"symfony/console": "For helpful console commands such as SQL execution and import of files."
diff --git a/php-doctrine-dbal3.spec b/php-doctrine-dbal3.spec
index 3c9723a..9633901 100644
--- a/php-doctrine-dbal3.spec
+++ b/php-doctrine-dbal3.spec
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name dbal
-%global github_version 3.3.5
-%global github_commit 719663b15983278227669c8595151586a2ff3327
+%global github_version 3.3.6
+%global github_commit 9e7f76dd1cde81c62574fdffa5a9c655c847ad21
%global major 3
%global composer_vendor doctrine
@@ -27,7 +27,7 @@
# "doctrine/event-manager": "^1.0"
%global doctrine_event_min_ver 1.0
%global doctrine_event_max_ver 2
-# "doctrine/deprecations": "^0.5.3",
+# "doctrine/deprecations": "^0.5.3|^1",
%global doctrine_deprecations_min_ver 0.5.3
%global doctrine_deprecations_max_ver 2
# "symfony/console": "^2.7|^3.0|^4.0|^5.0|^6.0"
@@ -290,6 +290,10 @@ exit $RETURN_CODE
%changelog
+* Tue May 3 2022 Remi Collet <remi@remirepo.net> - 3.3.6-1
+- update to 3.3.6
+- allow doctrine/deprecations 1
+
* Tue Apr 5 2022 Remi Collet <remi@remirepo.net> - 3.3.5-1
- update to 3.3.5