summaryrefslogtreecommitdiffstats
path: root/php-doctrine-dbal.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-dbal.spec')
-rw-r--r--php-doctrine-dbal.spec21
1 files changed, 14 insertions, 7 deletions
diff --git a/php-doctrine-dbal.spec b/php-doctrine-dbal.spec
index e320113..5d93176 100644
--- a/php-doctrine-dbal.spec
+++ b/php-doctrine-dbal.spec
@@ -13,13 +13,13 @@
%global github_owner doctrine
%global github_name dbal
-%global github_version 2.11.3
-%global github_commit fb5d5f2f26babf8dce217b1eb88300c22bb703a4
+%global github_version 2.12.1
+%global github_commit adce7a954a1c2f14f85e94aed90c8489af204086
%global composer_vendor doctrine
%global composer_project dbal
-# "php": "^7.3"
+# "php": "^7.3 || ^8"
%global php_min_ver 7.3
# "doctrine/cache": "^1.0"
%global doctrine_cache_min_ver 1.0
@@ -75,9 +75,10 @@ BuildRequires: php-composer(doctrine/event-manager) < %{doctrine_event_max_ver}
BuildRequires: php-composer(symfony/console) >= %{symfony_console_min_ver}
BuildRequires: php-composer(symfony/console) < %{symfony_console_max_ver}
%endif
-## phpcompatinfo (computed from version 2.5.12)
+## phpcompatinfo (computed from version 2.12)
BuildRequires: php-date
BuildRequires: php-json
+BuildRequires: php-hash
BuildRequires: php-pcre
BuildRequires: php-pdo
BuildRequires: php-reflection
@@ -105,9 +106,10 @@ Requires: php-composer(symfony/console) >= %{symfony_console_min_ver}
Requires: php-composer(symfony/console) < %{symfony_console_max_ver}
%endif
Requires: php-pdo
-# phpcompatinfo (computed from version 2.5.12)
+# phpcompatinfo (computed from version 2.12)
Requires: php-date
Requires: php-json
+Requires: php-hash
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
@@ -193,9 +195,8 @@ require_once '%{buildroot}/%{phpdir}/Doctrine/DBAL/autoload.php';
BOOTSTRAP
: Upstream tests
-# TODO php 8 (Doctrine\DBAL\Driver\PDOConnection::query() must be compatible with PDO::query)
RETURN_CODE=0
-for PHP_EXEC in php php73 php74; do
+for PHP_EXEC in php php73 php74 php80; do
rm -f /tmp/test_nesting.sqlite
if which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit9 \
@@ -219,6 +220,12 @@ exit $RETURN_CODE
%changelog
+* Mon Nov 16 2020 Remi Collet <remi@remirepo.net> - 2.12.1-1
+- update to 2.12.1
+
+* Fri Oct 23 2020 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+
* Wed Oct 21 2020 Remi Collet <remi@remirepo.net> - 2.11.3-1
- update to 2.11.3