summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-doctrine-datafixtures.spec15
2 files changed, 39 insertions, 4 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..97be9f6
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global github_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global github_name/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^%global github_version/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global github_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-doctrine-datafixtures.spec b/php-doctrine-datafixtures.spec
index c48811a..0d7918d 100644
--- a/php-doctrine-datafixtures.spec
+++ b/php-doctrine-datafixtures.spec
@@ -12,8 +12,9 @@
%global github_owner doctrine
%global github_name data-fixtures
-%global github_version 1.3.1
-%global github_commit 3a1e2c3c600e615a2dffe56d4ca0875cc5233e0a
+%global github_version 1.3.2
+%global github_commit 09b16943b27f3d80d63988d100ff256148c2f78b
+%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor doctrine
%global composer_project data-fixtures
@@ -44,7 +45,9 @@ Summary: Data Fixtures for all Doctrine Object Managers
Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+# Use git snapshot with tests
+Source0: %{name}-%{github_version}-%{github_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
# Tests
@@ -148,7 +151,7 @@ rm tests/Doctrine/Tests/Common/DataFixtures/Executor/PHPCRExecutorTest.php
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in "" php71 php72 php73; do
+for PHP_EXEC in "" php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit7 --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -170,6 +173,10 @@ exit $RETURN_CODE
%changelog
+* Thu Jul 11 2019 Remi Collet <remi@remirepo.net> - 1.3.2-1
+- update to 1.3.2
+- sources from git snapshot because of .gitattributes
+
* Wed Oct 17 2018 Remi Collet <remi@remirepo.net> - 1.3.1-1
- update to 1.3.1
- raise dependencies on PHP 7.1