summaryrefslogtreecommitdiffstats
path: root/php-doctrine-common.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-common.spec')
-rw-r--r--php-doctrine-common.spec16
1 files changed, 12 insertions, 4 deletions
diff --git a/php-doctrine-common.spec b/php-doctrine-common.spec
index 201fb05..c7d6dc9 100644
--- a/php-doctrine-common.spec
+++ b/php-doctrine-common.spec
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name common
-%global github_version 2.9.0
-%global github_commit a210246d286c77d2b89040f8691ba7b3a713d2c1
+%global github_version 2.10.0
+%global github_commit 30e33f60f64deec87df728c02b107f82cdafad9d
%global composer_vendor doctrine
%global composer_project common
@@ -46,8 +46,8 @@
# "doctrine/reflection": "^1.0"
%global doctrine_refl_min_ver 1.0
%global doctrine_refl_max_ver 2
-# "doctrine/persistence": "^1.0"
-%global doctrine_pers_min_ver 1.0
+# "doctrine/persistence": "^1.1"
+%global doctrine_pers_min_ver 1.1
%global doctrine_pers_max_ver 2
# Build using "--without tests" to disable tests
@@ -77,6 +77,7 @@ BuildRequires: php-cli
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
+# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(doctrine/annotations) >= %{doctrine_annotations_min_ver} with php-composer(doctrine/annotations) < %{doctrine_annotations_max_ver})
BuildRequires: (php-composer(doctrine/cache) >= %{doctrine_cache_min_ver} with php-composer(doctrine/cache) < %{doctrine_cache_max_ver})
@@ -86,6 +87,7 @@ BuildRequires: (php-composer(doctrine/lexer) >= %{doctrine_lexer_min_ver} with p
BuildRequires: (php-composer(doctrine/event-manager) >= %{doctrine_event_min_ver} with php-composer(doctrine/event-manager) < %{doctrine_event_max_ver})
BuildRequires: (php-composer(doctrine/reflection) >= %{doctrine_refl_min_ver} with php-composer(doctrine/reflection) < %{doctrine_refl_max_ver})
BuildRequires: (php-composer(doctrine/persistence) >= %{doctrine_pers_min_ver} with php-composer(doctrine/persistence) < %{doctrine_pers_max_ver})
+# remirepo:18
%else
BuildRequires: php-composer(doctrine/annotations) < %{doctrine_annotations_max_ver}
BuildRequires: php-composer(doctrine/annotations) >= %{doctrine_annotations_min_ver}
@@ -117,6 +119,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
+# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(doctrine/annotations) >= %{doctrine_annotations_min_ver} with php-composer(doctrine/annotations) < %{doctrine_annotations_max_ver})
Requires: (php-composer(doctrine/cache) >= %{doctrine_cache_min_ver} with php-composer(doctrine/cache) < %{doctrine_cache_max_ver})
@@ -126,6 +129,7 @@ Requires: (php-composer(doctrine/lexer) >= %{doctrine_lexer_min_ver} with p
Requires: (php-composer(doctrine/event-manager) >= %{doctrine_event_min_ver} with php-composer(doctrine/event-manager) < %{doctrine_event_max_ver})
Requires: (php-composer(doctrine/reflection) >= %{doctrine_refl_min_ver} with php-composer(doctrine/reflection) < %{doctrine_refl_max_ver})
Requires: (php-composer(doctrine/persistence) >= %{doctrine_pers_min_ver} with php-composer(doctrine/persistence) < %{doctrine_pers_max_ver})
+# remirepo:18
%else
Requires: php-composer(doctrine/annotations) >= %{doctrine_annotations_min_ver}
Requires: php-composer(doctrine/annotations) < %{doctrine_annotations_max_ver}
@@ -241,6 +245,10 @@ exit $RETURN_CODE
%changelog
+* Thu Nov 22 2018 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- update to 2.10.0
+- raise dependency on doctrine/persistence 1.1
+
* Thu Oct 18 2018 Remi Collet <remi@remirepo.net> - 2.9.0-1
- update to 2.9.0
- switch to phpunit6