summaryrefslogtreecommitdiffstats
path: root/php-doctrine-common.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-common.spec')
-rw-r--r--php-doctrine-common.spec13
1 files changed, 10 insertions, 3 deletions
diff --git a/php-doctrine-common.spec b/php-doctrine-common.spec
index ed566f6..347e48d 100644
--- a/php-doctrine-common.spec
+++ b/php-doctrine-common.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-doctrine-common
#
-# Copyright (c) 2013-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2021 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -58,7 +58,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Epoch: 1
Version: %{github_version}
-Release: 1%{?dist}
+Release: 4%{?dist}
Summary: Common library for Doctrine projects
License: MIT
@@ -69,6 +69,9 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
+# Minimal fix for PHP 8
+Patch0: %{name}-php8.patch
+
BuildArch: noarch
# Library version value check
BuildRequires: php-cli
@@ -172,6 +175,7 @@ Autoloader: %{phpdir}/Doctrine/Common/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
+%patch0 -p1 -b .php8
sed -e 's/2.12.0-DEV/%{version}/' -i lib/Doctrine/Common/Version.php
@@ -223,7 +227,7 @@ sed "s#require.*autoload.*#require_once '%{buildroot}%{phpdir}/Doctrine/Common/a
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in "" php71 php72 php73 php74; do
+for PHP_EXEC in "" php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit7 --verbose || RETURN_CODE=1
fi
@@ -247,6 +251,9 @@ exit $RETURN_CODE
%changelog
+* Wed Mar 31 2021 Remi Collet <remi@remirepo.net> - 2.13.3-4
+- add minimal patch to fix test suite for PHP 8
+
* Mon Jun 8 2020 Remi Collet <remi@remirepo.net> - 2.13.3-1
- update to 2.13.3