summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-30 12:12:59 +0200
committerRemi Collet <remi@php.net>2022-09-30 12:12:59 +0200
commit4ee777c353973f38cb1fb69742b83f1b4f107bed (patch)
tree20502ca31f45036642af28d1f9af6d8356ce6bb1
duplicate v1
-rw-r--r--composer.json61
l---------makesrc.sh1
-rwxr-xr-xphp-doctrine-collections2-get-source.sh71
-rw-r--r--php-doctrine-collections2.spec228
4 files changed, 361 insertions, 0 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..d9422dd
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,61 @@
+{
+ "name": "doctrine/collections",
+ "description": "PHP Doctrine Collections library that adds additional functionality on top of PHP arrays.",
+ "license": "MIT",
+ "type": "library",
+ "keywords": [
+ "php",
+ "collections",
+ "array",
+ "iterators"
+ ],
+ "authors": [
+ {
+ "name": "Guilherme Blanco",
+ "email": "guilhermeblanco@gmail.com"
+ },
+ {
+ "name": "Roman Borschel",
+ "email": "roman@code-factory.org"
+ },
+ {
+ "name": "Benjamin Eberlei",
+ "email": "kontakt@beberlei.de"
+ },
+ {
+ "name": "Jonathan Wage",
+ "email": "jonwage@gmail.com"
+ },
+ {
+ "name": "Johannes Schmitt",
+ "email": "schmittjoh@gmail.com"
+ }
+ ],
+ "homepage": "https://www.doctrine-project.org/projects/collections.html",
+ "require": {
+ "php": "^7.1.3 || ^8.0",
+ "doctrine/deprecations": "^0.5.3 || ^1"
+ },
+ "require-dev": {
+ "doctrine/coding-standard": "^9.0 || ^10.0",
+ "phpstan/phpstan": "^1.4.8",
+ "phpunit/phpunit": "^7.5 || ^8.5 || ^9.1.5",
+ "vimeo/psalm": "^4.22"
+ },
+ "autoload": {
+ "psr-4": {
+ "Doctrine\\Common\\Collections\\": "lib/Doctrine/Common/Collections"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Doctrine\\Tests\\": "tests/Doctrine/Tests"
+ }
+ },
+ "config": {
+ "allow-plugins": {
+ "composer/package-versions-deprecated": true,
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..5fb8127
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-doctrine-collections2-get-source.sh \ No newline at end of file
diff --git a/php-doctrine-collections2-get-source.sh b/php-doctrine-collections2-get-source.sh
new file mode 100755
index 0000000..4ad1051
--- /dev/null
+++ b/php-doctrine-collections2-get-source.sh
@@ -0,0 +1,71 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+CMP_FILE=$PWD/composer.json
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ cp composer.json $CMP_FILE
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-doctrine-collections2.spec b/php-doctrine-collections2.spec
new file mode 100644
index 0000000..71a8507
--- /dev/null
+++ b/php-doctrine-collections2.spec
@@ -0,0 +1,228 @@
+# remirepo spec file for php-doctrine-collections, from:
+#
+# Fedora spec file for php-doctrine-collections
+#
+# Copyright (c) 2013-2022 Shawn Iwinski, Remi Collet
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner doctrine
+%global github_name collections
+%global github_version 1.8.0
+%global github_commit 2b44dd4cbca8b5744327de78bafef5945c7e7b5e
+
+%global composer_vendor doctrine
+%global composer_project collections
+
+# "php": "^7.1.3 || ^8.0"
+%global php_min_ver 7.1.3
+# "doctrine/deprecations": "^0.5.3 || ^1"
+%global doctrine_depr_min_ver 1
+%global doctrine_depr_max_ver 2
+
+# Build using "--without tests" to disable tests
+%bcond_without tests
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: Collections abstraction library
+
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+
+# GitHub export does not include tests.
+# Run php-doctrine-collections-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildArch: noarch
+# Tests
+%if %{with tests}
+## composer.json
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: %{phpunit}
+BuildRequires: php(language) >= %{php_min_ver}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(doctrine/deprecations) >= %{doctrine_depr_min_ver} with php-composer(doctrine/deprecations) < %{doctrine_depr_max_ver})
+# remirepo:3
+%else
+BuildRequires: php-doctrine-deprecations
+%endif
+## phpcompatinfo (computed from version 1.6.0)
+BuildRequires: php-pcre
+BuildRequires: php-spl
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(doctrine/deprecations) >= %{doctrine_depr_min_ver} with php-composer(doctrine/deprecations) < %{doctrine_depr_max_ver})
+# remirepo:3
+%else
+Requires: php-doctrine-deprecations
+%endif
+# phpcompatinfo (computed from version 1.6.0)
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+# Extracted from Doctrine Common as of version 2.4
+Conflicts: php-pear(pear.doctrine-project.org/DoctrineCommon) < 2.4
+
+%description
+%{summary}.
+
+Autoloader: %{phpdir}/Doctrine/Common/Collections/autoload.php
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+: Create autoloader
+phpab --template fedora \
+ --output lib/Doctrine/Common/Collections/autoload.php \
+ lib/Doctrine/Common/Collections
+
+cat <<'AUTOLOAD' | tee -a lib/Doctrine/Common/Collections/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{phpdir}/Doctrine/Deprecations/autoload.php',
+]);
+AUTOLOAD
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}
+cp -rp lib/* %{buildroot}%{phpdir}/
+
+
+%check
+%if %{with tests}
+: Create tests bootstrap
+cat <<'BOOTSTRAP' | tee bootstrap.php
+<?php
+require_once '%{buildroot}%{phpdir}/Doctrine/Common/Collections/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Tests\\', __DIR__.'/tests/Doctrine/Tests');
+BOOTSTRAP
+
+: Upstream tests
+SCL_RETURN_CODE=0
+for CMD in "php %{phpunit}" php74 php80 php81 php82; do
+ if which $CMD; then
+ set $CMD
+ $1 ${2:-%{_bindir}/phpunit9} --verbose --bootstrap bootstrap.php \
+ || SCL_RETURN_CODE=1
+ fi
+done
+exit $SCL_RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{phpdir}/Doctrine
+%dir %{phpdir}/Doctrine/Common
+ %{phpdir}/Doctrine/Common/Collections
+
+
+%changelog
+* Fri Sep 30 2022 Remi Collet <remi@remirepo.net> - 1.8.0-1
+- update to 1.8.0
+
+* Mon Sep 26 2022 Remi Collet <remi@remirepo.net> - 1.7.3-1
+- update to 1.7.3
+
+* Fri Sep 9 2022 Remi Collet <remi@remirepo.net> - 1.7.2-1
+- update to 1.7.2
+- switch to classmap autoloader
+- add dependency on doctrine/deprecations
+
+* Fri Sep 9 2022 Remi Collet <remi@remirepo.net> - 1.6.9-1
+- update to 1.6.9
+
+* Wed Aug 11 2021 Remi Collet <remi@remirepo.net> - 1.6.8-1
+- update to 1.6.8
+
+* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 1.6.7-1
+- update to 1.6.7
+- add upstream patch for recent PHPUnit
+
+* Mon Jul 20 2020 Remi Collet <remi@remirepo.net> - 1.6.6-1
+- update to 1.6.6
+
+* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.6.5-1
+- update to 1.6.5
+
+* Wed Nov 13 2019 Remi Collet <remi@remirepo.net> - 1.6.4-1
+- update to 1.6.4
+
+* Tue Jun 11 2019 Remi Collet <remi@remirepo.net> - 1.6.2-1
+- update to 1.6.2
+
+* Tue Mar 26 2019 Remi Collet <remi@remirepo.net> - 1.6.1-1
+- update to 1.6.1
+
+* Mon Mar 25 2019 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+- raise dependency on PHP 7.1.3
+- use PHPUnit 7 for test suite
+
+* Sat Mar 04 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.4.0-1
+- Updated to 1.4.0 (RHBZ #1415530)
+- Switched autoloader to php-composer(fedora/autoloader)
+
+* Sat Jun 27 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.0-3
+- Updated autoloader with trailing separator
+
+* Wed Jun 24 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.0-2
+- Added autoloader dependencies
+
+* Wed Jun 24 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.0-1
+- Updated to 1.3.0 (RHBZ #1211818)
+- Added autoloader
+- %%license usage
+
+* Fri Jun 20 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2-3
+- Added php-composer(%%{composer_vendor}/%%{composer_project}) virtual provide
+- Added option to build without tests ("--without tests")
+
+* Mon Feb 17 2014 Remi Collet <rpms@famillecollet.com> 1.2-1
+- backport 1.2 for remi repo
+
+* Wed Feb 12 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 1.2-1
+- Updated to 1.2 (BZ #1061117)
+
+* Sat Jan 11 2014 Remi Collet <rpms@famillecollet.com> 1.1-3.20131221git8198717
+- backport for remi repo
+
+* Mon Jan 06 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1-3.20131221git8198717
+- Minor syntax changes
+
+* Fri Jan 03 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1-2.20131221git8198717
+- Conditional %%{?dist}
+- Added conflict w/ PEAR-based DoctrineCommon pkg (version < 2.4)
+
+* Mon Dec 23 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1-1.20131221git8198717
+- Initial package