summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json8
-rw-r--r--php-doctrine-cache2.spec19
2 files changed, 16 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index c38d062..ddad5f4 100644
--- a/composer.json
+++ b/composer.json
@@ -31,16 +31,16 @@
"phpunit/phpunit": "^7.0 || ^8.0 || ^9.0",
"predis/predis": "~1.0",
"doctrine/coding-standard": "^8.0",
- "psr/cache": "^1.0 || ^2.0",
+ "psr/cache": "^1.0 || ^2.0 || ^3.0",
"cache/integration-tests": "dev-master",
- "symfony/cache": "^4.4 || ^5.2"
+ "symfony/cache": "^4.4 || ^5.2 || ^6.0@dev",
+ "symfony/var-exporter": "^4.4 || ^5.2 || ^6.0@dev"
},
"suggest": {
"alcaeus/mongo-php-adapter": "Required to use legacy MongoDB driver"
},
"conflict": {
- "doctrine/common": ">2.2,<2.4",
- "psr/cache": ">=3"
+ "doctrine/common": ">2.2,<2.4"
},
"autoload": {
"psr-4": { "Doctrine\\Common\\Cache\\": "lib/Doctrine/Common/Cache" }
diff --git a/php-doctrine-cache2.spec b/php-doctrine-cache2.spec
index 3daa0ad..e494d36 100644
--- a/php-doctrine-cache2.spec
+++ b/php-doctrine-cache2.spec
@@ -11,8 +11,8 @@
%global github_owner doctrine
%global github_name cache
-%global github_version 2.0.3
-%global github_commit c9622c6820d3ede1e2315a6a377ea1076e421d88
+%global github_version 2.1.1
+%global github_commit 331b4d5dbaeab3827976273e9356b3b453c300ce
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global major 2
@@ -22,13 +22,13 @@
# "cache/integration-tests": "dev-master",
%global cache_integration_tests_min_ver 0.17
-# "symfony/cache": "^4.4 || ^5.2"
+# "symfony/cache": "^4.4 || ^5.2 || ^6.0@dev"
%global symfony_min_ver 4.4
-%global symfony_max_ver 5.2
+%global symfony_max_ver 7
-# "psr/cache": "^1.0 || ^2.0"
+# "psr/cache": "^1.0 || ^2.0 || ^3.0"
%global psr_cache_min_ver 1.0
-%global psr_cache_max_ver 3.0
+%global psr_cache_max_ver 4
# "php": "~7.1 || ^8.0"
%global php_min_ver 7.1
@@ -40,7 +40,7 @@
Name: php-%{composer_vendor}-%{composer_project}%{major}
Version: %{github_version}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: Doctrine Cache version %{major}
License: MIT
@@ -120,6 +120,7 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Doctrine\\Common\\Cache\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
[
+ '%{phpdir}/Symfony6/Component/Cache/autoload.php',
'%{phpdir}/Symfony5/Component/Cache/autoload.php',
'%{phpdir}/Symfony4/Component/Cache/autoload.php',
],
@@ -154,6 +155,7 @@ require_once '%{buildroot}%{phpdir}/Doctrine/Common/Cache%{major}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{phpdir}/Cache/IntegrationTests/autoload.php',
[
+ '%{phpdir}/Psr/Cache3/autoload.php',
'%{phpdir}/Psr/Cache2/autoload.php',
'%{phpdir}/Psr/Cache/autoload.php',
],
@@ -188,6 +190,9 @@ exit $RETURN_CODE
%changelog
+* Mon Jul 19 2021 Remi Collet <remi@remirepo.net> - 2.1.1-1
+- update to 2.1.1
+
* Mon Jul 5 2021 Remi Collet <remi@remirepo.net> - 2.0.3-2
- add mandatory dependency on symfony/cache