summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json21
-rw-r--r--php-doctrine-cache.spec10
2 files changed, 22 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 2ee5d25..e8e4a8d 100644
--- a/composer.json
+++ b/composer.json
@@ -1,9 +1,20 @@
{
"name": "doctrine/cache",
"type": "library",
- "description": "Caching library offering an object-oriented API for many cache backends",
- "keywords": ["cache", "caching"],
- "homepage": "https://www.doctrine-project.org",
+ "description": "PHP Doctrine Cache library is a popular cache implementation that supports many different drivers such as redis, memcache, apc, mongodb and others.",
+ "keywords": [
+ "php",
+ "cache",
+ "caching",
+ "abstraction",
+ "redis",
+ "memcached",
+ "couchdb",
+ "xcache",
+ "apcu",
+ "riak"
+ ],
+ "homepage": "https://www.doctrine-project.org/projects/cache.html",
"license": "MIT",
"authors": [
{"name": "Guilherme Blanco", "email": "guilhermeblanco@gmail.com"},
@@ -20,7 +31,7 @@
"mongodb/mongodb": "^1.1",
"phpunit/phpunit": "^7.0",
"predis/predis": "~1.0",
- "doctrine/coding-standard": "^4.0"
+ "doctrine/coding-standard": "^6.0"
},
"suggest": {
"alcaeus/mongo-php-adapter": "Required to use legacy MongoDB driver"
@@ -36,7 +47,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.8.x-dev"
+ "dev-master": "1.9.x-dev"
}
}
}
diff --git a/php-doctrine-cache.spec b/php-doctrine-cache.spec
index a787d7d..fc1b1e2 100644
--- a/php-doctrine-cache.spec
+++ b/php-doctrine-cache.spec
@@ -12,8 +12,8 @@
%global github_owner doctrine
%global github_name cache
-%global github_version 1.8.1
-%global github_commit d4374ae95b36062d02ef310100ed33d78738d76c
+%global github_version 1.9.0
+%global github_commit c15dcd24b756f9e52ea7c3ae8227354f3628f11a
%global composer_vendor doctrine
%global composer_project cache
@@ -31,7 +31,6 @@ Version: %{github_version}
Release: 1%{?dist}
Summary: Doctrine Cache
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
@@ -153,7 +152,7 @@ rm -f \
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in "" php71 php72 php73; do
+for PHP_EXEC in "" php71 php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit7 --bootstrap bootstrap.php \
--verbose || RETURN_CODE=1
@@ -176,6 +175,9 @@ exit $RETURN_CODE
%changelog
+* Tue Nov 12 2019 Remi Collet <remi@remirepo.net> - 1.9.0-1
+- update to 1.9.0
+
* Mon Oct 28 2019 Remi Collet <remi@remirepo.net> - 1.8.1-1
- update to 1.8.1