summaryrefslogtreecommitdiffstats
path: root/php-di.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-di.spec')
-rw-r--r--php-di.spec14
1 files changed, 8 insertions, 6 deletions
diff --git a/php-di.spec b/php-di.spec
index 03d4af7..85a6613 100644
--- a/php-di.spec
+++ b/php-di.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-di
#
-# Copyright (c) 2016-2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner PHP-DI
%global github_name PHP-DI
-%global github_version 5.4.3
-%global github_commit 8ecded470bb0255c93f2996f78bb3b644c06599a
+%global github_version 5.4.6
+%global github_commit 3f9255659595f3e289f473778bb6c51aa72abbbd
%global composer_vendor php-di
%global composer_project php-di
@@ -52,10 +52,9 @@
Name: %{composer_project}
Version: %{github_version}
-Release: 3%{?github_release}%{?dist}
+Release: 6%{?github_release}%{?dist}
Summary: The dependency injection container for humans
-Group: Development/Libraries
License: MIT
URL: http://php-di.org/
@@ -210,7 +209,7 @@ sed -e '/@test/d' \
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php70 php71 php72; do
+for PHP_EXEC in php php71 php72 php73; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
for PHPUNIT in phpunit; do
PHPUNIT=$(which $PHPUNIT) || :
@@ -236,6 +235,9 @@ exit $RETURN_CODE
%changelog
+* Fri May 10 2019 Shawn Iwinski <shawn@iwin.ski> - 5.4.6-1
+- Update to 5.4.6
+
* Tue Oct 31 2017 Remi Collet <remi@remirepo.net> - 5.4.3-2
- fix FTBFS from Koschei, add upstream patch for PHP 7.2