summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-di.spec30
2 files changed, 18 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index 693d3ff..0874f2d 100644
--- a/composer.json
+++ b/composer.json
@@ -32,10 +32,10 @@
"opis/closure": "^3.5.5"
},
"require-dev": {
- "phpunit/phpunit": "^8.5",
+ "phpunit/phpunit": "^8.5|^9.0",
"mnapoli/phpunit-easymock": "^1.2",
"doctrine/annotations": "~1.2",
- "ocramius/proxy-manager": "~2.0.2",
+ "ocramius/proxy-manager": "^2.0.2",
"friendsofphp/php-cs-fixer": "^2.4",
"phpstan/phpstan": "^0.12"
},
diff --git a/php-di.spec b/php-di.spec
index 6afe352..36f8e3c 100644
--- a/php-di.spec
+++ b/php-di.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-di
#
-# Copyright (c) 2016-2020 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2021 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -10,10 +10,12 @@
# Please preserve changelog entries
#
+%bcond_without tests
+
%global github_owner PHP-DI
%global github_name PHP-DI
-%global github_version 6.2.2
-%global github_commit 40140b5bca07c5fed6919a0f1029ff67617faccd
+%global github_version 6.3.1
+%global github_commit 78278800b18e7c5582fd4d4e629715f5eebbfcc0
%global composer_vendor php-di
%global composer_project php-di
@@ -26,7 +28,7 @@
# "mnapoli/phpunit-easymock": "^1.2"
%global phpunit_easymock_min_ver 1.2
%global phpunit_easymock_max_ver 2.0
-# "ocramius/proxy-manager": "~2.0.2"
+# "ocramius/proxy-manager": "^2.0.2"
%global proxy_manager_min_ver 2.0.2
%global proxy_manager_max_ver 3.0
# "opis/closure": "^3.5.5"
@@ -38,15 +40,12 @@
# "php-di/phpdoc-reader": "^2.0.1"
%global di_phpdoc_reader_min_ver 2.0.1
%global di_phpdoc_reader_max_ver 3.0
-# "phpunit/phpunit": "^8.5"
-%global phpunit_min_ver 8.5
+# "phpunit/phpunit": "^8.5|^9.0"
+%global phpunit_min_ver 9.0
# "psr/container": "^1.0"
%global psr_container_min_ver 1.0
%global psr_container_max_ver 2.0
-# Build using "--without tests" to disable tests
-%global with_tests 0%{!?_without_tests:1}
-
# Range dependencies supported?
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%global with_range_dependencies 1
@@ -78,10 +77,10 @@ Source1: %{name}-get-source.sh
BuildArch: noarch
# Tests
-%if %{with_tests}
+%if %{with tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: phpunit8 >= %{phpunit_min_ver}
+BuildRequires: phpunit9 >= %{phpunit_min_ver}
%if %{with_range_dependencies}
BuildRequires: (php-composer(doctrine/annotations) >= %{doctrine_annotations_min_ver} with php-composer(doctrine/annotations) < %{doctrine_annotations_max_ver})
BuildRequires: (php-composer(mnapoli/phpunit-easymock) >= %{phpunit_easymock_min_ver} with php-composer(mnapoli/phpunit-easymock) < %{phpunit_easymock_max_ver})
@@ -197,7 +196,7 @@ cp -rp src %{buildroot}%{phpdir}/DI
%check
-%if %{with_tests}
+%if %{with tests}
: Create tests bootstrap
cat <<'BOOTSTRAP' | tee bootstrap.php
<?php
@@ -211,8 +210,8 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit8)
-for PHP_EXEC in "" php73 php74; do
+PHPUNIT=$(which phpunit9)
+for PHP_EXEC in "" php73 php74 php80; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
@@ -234,6 +233,9 @@ exit $RETURN_CODE
%changelog
+* Wed Mar 31 2021 Remi Collet <remi@remirepo.net> - 6.3.1-1
+- update to 6.3.1
+
* Sun Sep 06 2020 Shawn Iwinski <shawn@iwin.ski> - 6.2.2-1
- Update to 6.2.2 (RHBZ #1871668)