summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rwxr-xr-xphp-di-phpdoc-reader-get-source.sh2
-rw-r--r--php-di-phpdoc-reader.spec15
3 files changed, 20 insertions, 1 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-di-phpdoc-reader-get-source.sh b/php-di-phpdoc-reader-get-source.sh
index ba71f5d..48b8385 100755
--- a/php-di-phpdoc-reader-get-source.sh
+++ b/php-di-phpdoc-reader-get-source.sh
@@ -43,6 +43,7 @@ print "GIT_REPO = $GIT_REPO"
print "GIT_DIR = $GIT_DIR"
TEMP_DIR=$(mktemp --dir)
+TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
pushd $TEMP_DIR
print "Cloning git repo..."
@@ -58,7 +59,6 @@ pushd $TEMP_DIR
mv $GIT_DIR $TAR_DIR
- TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
print "TAR_FILE = $TAR_FILE"
[ -e $TAR_FILE ] && rm -f $TAR_FILE
diff --git a/php-di-phpdoc-reader.spec b/php-di-phpdoc-reader.spec
index a2cf70b..a795dde 100644
--- a/php-di-phpdoc-reader.spec
+++ b/php-di-phpdoc-reader.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-di-phpdoc-reader, from:
#
# Fedora spec file for php-di-phpdoc-reader
#
@@ -39,6 +40,7 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -107,6 +109,7 @@ AUTOLOAD
%install
+rm -rf %{buildroot}
mkdir -p %{buildroot}%{phpdir}
cp -rp src/* %{buildroot}%{phpdir}/
@@ -126,12 +129,21 @@ BOOTSTRAP
: Run tests
%{_bindir}/phpunit --verbose --bootstrap bootstrap.php
+
+if which php70; then
+ php70 %{_bindir}/phpunit --verbose --bootstrap bootstrap.php
+fi
%else
: Tests skipped
%endif
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -140,5 +152,8 @@ BOOTSTRAP
%changelog
+* Mon Jan 04 2016 Remi Collet <remi@remirepo.net> - 2.0.1-1
+- backport for #remirepo
+
* Sun Jan 03 2016 Shawn Iwinski <shawn@iwin.ski> - 2.0.1-1
- Initial package