summaryrefslogtreecommitdiffstats
path: root/php-di-invoker.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-di-invoker.spec')
-rw-r--r--php-di-invoker.spec22
1 files changed, 16 insertions, 6 deletions
diff --git a/php-di-invoker.spec b/php-di-invoker.spec
index 8c59649..e9bcef2 100644
--- a/php-di-invoker.spec
+++ b/php-di-invoker.spec
@@ -14,16 +14,17 @@
%global github_owner PHP-DI
%global github_name Invoker
-%global github_version 2.3.0
-%global github_commit 992fec6c56f2d1ad1ad5fee28267867c85bfb8f9
+%global github_version 2.3.2
+%global github_commit 5214cbe5aad066022cd845dbf313f0e47aed928f
%global composer_vendor php-di
%global composer_project invoker
# "php": "^7.1 || ^8.0"
%global php_min_ver 7.3
-# "psr/container": "~1.0"
+# "psr/container": "^1.0|^2.0"
%global psr_container_min_ver 1.0
+# version 2 is not yet available
%global psr_container_max_ver 2.0
%{!?phpdir: %global phpdir %{_datadir}/php}
@@ -124,9 +125,15 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit9)
-for PHP_EXEC in "" php73 php74 php80; do
- if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
+for PHP_EXEC in php php73 php74 php80 php81; do
+ if which $PHP_EXEC; then
+ VER=$($PHP_EXEC -r 'echo PHP_VERSION_ID;')
+ if [ $VER -ge 80100 ]; then
+ FILTER="--filter '^((?!(should_invoke_callable_with_optional_parameter_before_required_parameter)).)*$'"
+ else
+ FILTER=""
+ fi
+ $PHP_EXEC $PHPUNIT $FILTER --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -146,6 +153,9 @@ exit $RETURN_CODE
%changelog
+* Tue Aug 3 2021 Remi Collet <remi@remirepo.net> - 2.3.2-1
+- update to 2.3.2
+
* Wed Mar 31 2021 Remi Collet <remi@remirepo.net> - 2.3.0-1
- update to 2.3.0
- raise dependency on PHP 7.3