summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json35
-rw-r--r--php-consolidation-log.spec109
2 files changed, 107 insertions, 37 deletions
diff --git a/composer.json b/composer.json
index b6ba001..1edc4c5 100644
--- a/composer.json
+++ b/composer.json
@@ -19,17 +19,40 @@
}
},
"require": {
- "php": ">=5.5.0",
- "psr/log": "~1.0",
- "symfony/console": "~2.5|~3.0"
+ "php": ">=7.1.3",
+ "psr/log": "^1.0",
+ "symfony/console": "^4|^5"
},
"require-dev": {
- "phpunit/phpunit": "4.*",
- "squizlabs/php_codesniffer": "2.*"
+ "phpunit/phpunit": ">=7.5.20",
+ "squizlabs/php_codesniffer": "^3",
+ "yoast/phpunit-polyfills": "^0.2.0"
+ },
+ "minimum-stability": "stable",
+ "scripts": {
+ "cs": "phpcs -n --standard=PSR2 src",
+ "cbf": "phpcbf -n --standard=PSR2 src",
+ "unit": "phpunit --colors=always",
+ "lint": [
+ "find src -name '*.php' -print0 | xargs -0 -n1 php -l",
+ "find tests/src -name '*.php' -print0 | xargs -0 -n1 php -l"
+ ],
+ "test": [
+ "@lint",
+ "@unit",
+ "@cs"
+ ]
},
"extra": {
"branch-alias": {
- "dev-master": "1.x-dev"
+ "dev-main": "2.x-dev"
+ }
+ },
+ "config": {
+ "optimize-autoloader": true,
+ "sort-packages": true,
+ "platform": {
+ "php": "7.2.28"
}
}
}
diff --git a/php-consolidation-log.spec b/php-consolidation-log.spec
index 995534b..b78bb30 100644
--- a/php-consolidation-log.spec
+++ b/php-consolidation-log.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-consolidation-log
#
-# Copyright (c) 2016-2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2021 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -10,36 +10,49 @@
# Please preserve changelog entries
#
-%global github_owner consolidation-org
+%global github_owner consolidation
%global github_name log
-%global github_version 1.0.3
-%global github_commit 74ba81b4edc585616747cc5c5309ce56fec41254
+%global github_version 2.0.2
+%global github_commit 82a2aaaa621a7b976e50a745a8d249d5085ee2b1
%global composer_vendor consolidation
%global composer_project log
-# "php": ">=5.5.0"
-%global php_min_ver 5.5.0
-# "psr/log": "~1.0"
+# "php": ">=7.1.3"
+%global php_min_ver 7.1.3
+# "psr/log": "^1.0"
# NOTE: Min version not 1.0 because autoloader required
%global psr_log_min_ver 1.0.1
%global psr_log_max_ver 2.0
-# "symfony/console": "~2.5|~3.0"
-# NOTE: Min version not 2.5 because autoloader required
-%global symfony_min_ver 2.7.1
-%global symfony_max_ver 4.0
+# "symfony/console": "^4|^5"
+%global symfony_min_ver 4.0
+%global symfony_max_ver 6.0
+
+# "phpunit/phpunit": ">=7.5.20"
+%global phpunit_require phpunit9
+%global phpunit_min_ver 9
+%global phpunit_exec phpunit9
+# "yoast/phpunit-polyfills": "^0.2.0"
+%global polyfills_min_ver 0.2
+%global polyfills_max_ver 2
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
+# Range dependencies supported?
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%global with_range_dependencies 1
+%else
+%global with_range_dependencies 0
+%endif
+
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
Release: 2%{?github_release}%{?dist}
-Summary: Improved Psr-3 / Psr\\Log logger based on Symfony Console components
+Summary: Improved PSR-3 / Psr\\Log logger based on Symfony Console components
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -49,25 +62,36 @@ BuildArch: noarch
%if %{with_tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: %{phpunit_require} >= %{phpunit_min_ver}
+%if %{with_range_dependencies}
+BuildRequires: (php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
+BuildRequires: (php-composer(symfony/console) >= %{symfony_min_ver} with php-composer(symfony/console) < %{symfony_max_ver})
+BuildRequires: (php-composer(yoast/phpunit-polyfills) >= %{polyfills_min_ver} with php-composer(yoast/phpunit-polyfills) < %{polyfills_max_ver})
+%else
BuildRequires: php-composer(psr/log) < %{psr_log_max_ver}
BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
-BuildRequires: php-composer(symfony/console) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/console) >= %{symfony_min_ver}
-## phpcompatinfo (computed from version 1.0.3)
-### <none>
+BuildRequires: php-symfony4-console >= %{symfony_min_ver}
+BuildRequires: php-composer(yoast/phpunit-polyfills) < %{polyfills_max_ver}
+BuildRequires: php-composer(yoast/phpunit-polyfills) >= %{polyfills_min_ver}
+%endif
+## phpcompatinfo (computed from version 2.0.1)
+BuildRequires: php-pcre
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
# composer.json
Requires: php(language) >= %{php_min_ver}
-Requires: php-composer(psr/log) >= %{psr_log_min_ver}
+%if %{with_range_dependencies}
+Requires: (php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
+Requires: (php-composer(symfony/console) >= %{symfony_min_ver} with php-composer(symfony/console) < %{symfony_max_ver})
+%else
Requires: php-composer(psr/log) < %{psr_log_max_ver}
-Requires: php-composer(symfony/console) >= %{symfony_min_ver}
-Requires: php-composer(symfony/console) < %{symfony_max_ver}
-# phpcompatinfo (computed from version 1.0.3)
-## <none>
+Requires: php-composer(psr/log) >= %{psr_log_min_ver}
+Requires: php-symfony4-console >= %{symfony_min_ver}
+%endif
+# phpcompatinfo (computed from version 2.0.1)
+## none
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -102,8 +126,8 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{phpdir}/Psr/Log/autoload.php',
[
- '%{phpdir}/Symfony3/Component/Console/autoload.php',
- '%{phpdir}/Symfony/Component/Console/autoload.php',
+ '%{phpdir}/Symfony5/Component/Console/autoload.php',
+ '%{phpdir}/Symfony4/Component/Console/autoload.php',
],
]);
AUTOLOAD
@@ -117,18 +141,23 @@ cp -rp src %{buildroot}%{phpdir}/Consolidation/Log
%check
%if %{with_tests}
: Create tests bootstrap
-cat <<'BOOTSTRAP' | tee bootstrap.php
+mkdir vendor
+cat <<'BOOTSTRAP' | tee vendor/autoload.php
<?php
require '%{buildroot}%{phpdir}/Consolidation/Log/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('Consolidation\\TestUtils\\', __DIR__.'/tests/src');
+\Fedora\Autoloader\Autoload::addPsr4('Consolidation\\TestUtils\\', dirname(__DIR__).'/tests/src');
+
+\Fedora\Autoloader\Dependencies::required([
+ '%{phpdir}/Yoast/PHPUnitPolyfills/autoload.php',
+]);
BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in php php56 php70 php71 php72; do
- if [ "php" = "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php \
+PHPUNIT=$(which %{phpunit_exec})
+for PHP_EXEC in "" php73 php74 php80; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose --no-coverage \
|| RETURN_CODE=1
fi
done
@@ -148,6 +177,24 @@ exit $RETURN_CODE
%changelog
+* Mon Jun 21 2021 Remi Collet <remi@remirepo.net> - 2.0.2-2
+- allow yoast/phpunit-polyfills version 1
+
+* Tue Mar 23 2021 Remi Collet <remi@remirepo.net> - 2.0.2-1
+- update to 2.0.2
+- switch to phpunit9 with yoast/phpunit-polyfills
+
+* Mon Sep 07 2020 Shawn Iwinski <shawn@iwin.ski> - 2.0.1-1
+- Update to 2.0.1 (RHBZ #1850810)
+
+* Mon Feb 24 2020 Shawn Iwinski <shawn@iwin.ski> - 2.0.0-1
+- Update to 2.0.0
+- Use PHPUnit 6
+
+* Sat Jun 01 2019 Shawn Iwinski <shawn@iwin.ski> - 1.1.1-1
+- Update to 1.1.1 (RHBZ #1582690)
+- Add range version dependencies for Fedora >= 27 || RHEL >= 8
+
* Sun Aug 20 2017 Shawn Iwinski <shawn@iwin.ski> - 1.0.3-2
- Add max versions to BuildRequires
- Switch autoloader to fedora/autoloader