summaryrefslogtreecommitdiffstats
path: root/php-composer-xdebug-handler.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-composer-xdebug-handler.spec')
-rw-r--r--php-composer-xdebug-handler.spec11
1 files changed, 7 insertions, 4 deletions
diff --git a/php-composer-xdebug-handler.spec b/php-composer-xdebug-handler.spec
index 4823c6b..ca0a1b6 100644
--- a/php-composer-xdebug-handler.spec
+++ b/php-composer-xdebug-handler.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 1ab9842d69e64fb3a01be6b656501032d1b78cb7
+%global gh_commit fa2aaf99e2087f013a14f7432c1cd2dd7d8f1f51
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner composer
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.4.1
+Version: 1.4.2
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: Restarts a process without Xdebug
@@ -43,7 +43,7 @@ BuildRequires: php-spl
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
BuildRequires: phpunit8
-%global phpunit %{_bindir}/phpunit6
+%global phpunit %{_bindir}/phpunit8
%else
BuildRequires: php-PsrLog
BuildRequires: php-phpunit-PHPUnit >= 4.8.35
@@ -116,7 +116,7 @@ EOF
%if %{with_tests}
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" "php71 %{_bindir}/phpunit7" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit8} --verbose|| ret=1
@@ -138,6 +138,9 @@ exit $ret
%changelog
+* Thu Jun 4 2020 Remi Collet <remi@remirepo.net> - 1.4.2-1
+- update to 1.4.2
+
* Mon Mar 2 2020 Remi Collet <remi@remirepo.net> - 1.4.1-1
- update to 1.4.1