summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json6
-rw-r--r--php-composer-xdebug-handler.spec20
2 files changed, 15 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index b93de4d..ea40a2f 100644
--- a/composer.json
+++ b/composer.json
@@ -1,6 +1,6 @@
{
"name": "composer/xdebug-handler",
- "description": "Restarts a process without xdebug.",
+ "description": "Restarts a process without Xdebug.",
"type": "library",
"license": "MIT",
"keywords": [
@@ -18,11 +18,11 @@
"issues": "https://github.com/composer/xdebug-handler/issues"
},
"require": {
- "php": "^5.3.2 || ^7.0",
+ "php": "^5.3.2 || ^7.0 || ^8.0",
"psr/log": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5"
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || 6.5 - 8"
},
"autoload": {
"psr-4": {
diff --git a/php-composer-xdebug-handler.spec b/php-composer-xdebug-handler.spec
index c1edb2a..968bfc3 100644
--- a/php-composer-xdebug-handler.spec
+++ b/php-composer-xdebug-handler.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 46867cbf8ca9fb8d60c506895449eb799db1184f
+%global gh_commit cbe23383749496fe0f373345208b79568e4bc248
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner composer
@@ -19,9 +19,9 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.3.3
+Version: 1.4.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
-Summary: Restarts a process without xdebug
+Summary: Restarts a process without Xdebug
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -39,10 +39,10 @@ BuildRequires: php-pcre
BuildRequires: php-posix
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5"
+# "phpunit/phpunit": "^4.8.35 || ^5.7 || 6.5 - 8"
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
-BuildRequires: phpunit6 >= 6.5
+BuildRequires: phpunit8
%global phpunit %{_bindir}/phpunit6
%else
BuildRequires: php-PsrLog
@@ -54,7 +54,7 @@ BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": "^5.3.2 || ^7.0",
+# "php": "^5.3.2 || ^7.0 || ^8.0",
# "psr/log": "^1.0"
Requires: php(language) >= 5.3.2
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -116,10 +116,10 @@ EOF
%if %{with_tests}
ret=0
-for cmdarg in "php %{phpunit}" php70 php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" "php71 %{_bindir}/phpunit7" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose|| ret=1
+ $1 ${2:-%{_bindir}/phpunit8} --verbose|| ret=1
fi
done
exit $ret
@@ -138,6 +138,10 @@ exit $ret
%changelog
+* Thu Nov 7 2019 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+- switch to phpunit8
+
* Tue May 28 2019 Remi Collet <remi@remirepo.net> - 1.3.3-1
- update to 1.3.3