summaryrefslogtreecommitdiffstats
path: root/php-composer-ca-bundle.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-composer-ca-bundle.spec')
-rw-r--r--php-composer-ca-bundle.spec95
1 files changed, 61 insertions, 34 deletions
diff --git a/php-composer-ca-bundle.spec b/php-composer-ca-bundle.spec
index 58edb0d..5b39d42 100644
--- a/php-composer-ca-bundle.spec
+++ b/php-composer-ca-bundle.spec
@@ -1,7 +1,7 @@
# remirepo/fedora spec file for php-composer-ca-bundle
#
-# Copyright (c) 2016-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2016-2024 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -9,14 +9,14 @@
%bcond_without tests
-%global gh_commit 78a0e288fdcebf92aa2318a8d3656168da6ac1a5
+%global gh_commit 0c5ccfcfea312b5c5a190a21ac5cef93f74baf99
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner composer
%global gh_project ca-bundle
%global php_home %{_datadir}/php
Name: php-composer-ca-bundle
-Version: 1.2.9
+Version: 1.5.0
Release: 1%{?dist}
Summary: Lets you find a path to the system CA
@@ -31,26 +31,16 @@ Patch0: %{name}-rpm.patch
BuildArch: noarch
%if %{with tests}
-BuildRequires: php(language) >= 5.3.2
+BuildRequires: php(language) >= 7.2
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-cli
# From composer.json, "require": {
# "symfony/phpunit-bridge": "^4.2 || ^5",
-# "phpstan/phpstan": "^0.12.55",
+# "phpstan/phpstan": "^1.10",
# "psr/log": "^1.0",
-# "symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0"
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: phpunit8
-%global phpunit %{_bindir}/phpunit8
-BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
-BuildRequires: (php-composer(symfony/process) >= 2.5 with php-composer(symfony/process) < 6)
-%else
-BuildRequires: phpunit
-%global phpunit %{_bindir}/phpunit
-BuildRequires: php-PsrLog
-BuildRequires: php-symfony-process
-%endif
+# "symfony/process": "^4.0 || ^5.0 || ^6.0 || ^7.0"
+BuildRequires: phpunit10
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
# ca-certificates
@@ -60,8 +50,8 @@ BuildRequires: %{_sysconfdir}/pki/tls/certs/ca-bundle.crt
# From composer.json, "require": {
# "ext-openssl": "*",
# "ext-pcre": "*",
-# "php": "^5.3.2 || ^7.0 || ^8.0"
-Requires: php(language) >= 5.3.2
+# "php": "^7.2 || ^8.0"
+Requires: php(language) >= 7.2
Requires: php-openssl
Requires: php-pcre
# From phpcompatinfo report for version 1.0.3
@@ -83,7 +73,7 @@ Autoloader: %{php_home}/Composer/CaBundle/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p0 -b .rpm
+%patch -P0 -p0 -b .rpm
find src -name \*.rpm -exec rm {} \;
cat << 'EOF' | tee src/autoload.php
@@ -112,22 +102,14 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/Composer/CaBundle/autoload.php';
-\Fedora\Autoloader\Dependencies::required(array(
- array(
- '%{php_home}/Symfony5/Component/Process/autoload.php',
- '%{php_home}/Symfony4/Component/Process/autoload.php',
- '%{php_home}/Symfony3/Component/Process/autoload.php',
- '%{php_home}/Symfony/Component/Process/autoload.php',
- ),
- '%{php_home}/Psr/Log/autoload.php',
-));
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
- if which $cmdarg; then
- set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
+%{_bindir}/phpunit10 --migrate-configuration
+
+for cmd in php php81 php82 php83; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit10 --no-coverage || ret=1
fi
done
exit $ret
@@ -146,6 +128,51 @@ exit $ret
%changelog
+* Fri Mar 15 2024 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+- raise dependency on PHP 7.2
+
+* Thu Mar 14 2024 Remi Collet <remi@remirepo.net> - 1.4.2-1
+- update to 1.4.2 (no change)
+
+* Mon Feb 26 2024 Remi Collet <remi@remirepo.net> - 1.4.1-1
+- update to 1.4.1
+
+* Mon Dec 18 2023 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0 (no change)
+- drop build dependencies on symfony/process and psr/log
+
+* Thu Aug 31 2023 Remi Collet <remi@remirepo.net> - 1.3.7-1
+- update to 1.3.7 (no change)
+
+* Thu Jun 8 2023 Remi Collet <remi@remirepo.net> - 1.3.6-1
+- update to 1.3.6 (no change)
+
+* Wed Jan 11 2023 Remi Collet <remi@remirepo.net> - 1.3.5-1
+- update to 1.3.5 (no change)
+
+* Wed Oct 12 2022 Remi Collet <remi@remirepo.net> - 1.3.4-1
+- update to 1.3.4 (no change)
+
+* Wed Jul 20 2022 Remi Collet <remi@remirepo.net> - 1.3.3-1
+- update to 1.3.3 (no change)
+
+* Wed May 25 2022 Remi Collet <remi@remirepo.net> - 1.3.2-1
+- update to 1.3.2 (no change)
+
+* Sat Oct 30 2021 Remi Collet <remi@remirepo.net> - 1.3.1-1
+- update to 1.3.1
+
+* Wed Oct 27 2021 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+
+* Fri Oct 1 2021 Remi Collet <remi@remirepo.net> - 1.2.11-1
+- update to 1.2.11 (no change)
+- allow Symfony 6
+
+* Tue Jun 8 2021 Remi Collet <remi@remirepo.net> - 1.2.10-1
+- update to 1.2.10 (no change)
+
* Tue Jan 12 2021 Remi Collet <remi@remirepo.net> - 1.2.9-1
- update to 1.2.9