summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-composer-ca-bundle.spec18
2 files changed, 13 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index ca2a0d3..faeeb7b 100644
--- a/composer.json
+++ b/composer.json
@@ -24,10 +24,10 @@
"require": {
"ext-openssl": "*",
"ext-pcre": "*",
- "php": "^5.3.2 || ^7.0"
+ "php": "^5.3.2 || ^7.0 || ^8.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5",
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || 6.5 - 8",
"psr/log": "^1.0",
"symfony/process": "^2.5 || ^3.0 || ^4.0"
},
diff --git a/php-composer-ca-bundle.spec b/php-composer-ca-bundle.spec
index 4fc9b22..596e047 100644
--- a/php-composer-ca-bundle.spec
+++ b/php-composer-ca-bundle.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 558f321c52faeb4828c03e7dc0cfe39a09e09a2d
+%global gh_commit 33810d865dd06a674130fceb729b2f279dc79e8c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner composer
%global gh_project ca-bundle
@@ -14,7 +14,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-composer-ca-bundle
-Version: 1.1.4
+Version: 1.2.1
Release: 1%{?dist}
Summary: Lets you find a path to the system CA
@@ -34,12 +34,12 @@ BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-cli
# From composer.json, "require": {
-# "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5",
+# "phpunit/phpunit": "^4.8.35 || ^5.7 || 6.5 - 8",
# "psr/log": "^1.0",
# "symfony/process": "^2.5 || ^3.0 || ^4.0"
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: phpunit6
-%global phpunit %{_bindir}/phpunit6
+%global phpunit %{_bindir}/phpunit8
BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
BuildRequires: (php-composer(symfony/process) >= 2.5 with php-composer(symfony/process) < 5)
%else
@@ -57,7 +57,7 @@ BuildRequires: %{_sysconfdir}/pki/tls/certs/ca-bundle.crt
# From composer.json, "require": {
# "ext-openssl": "*",
# "ext-pcre": "*",
-# "php": "^5.3.2 || ^7.0"
+# "php": "^5.3.2 || ^7.0 || ^8.0"
Requires: php(language) >= 5.3.2
Requires: php-openssl
Requires: php-pcre
@@ -120,10 +120,10 @@ require_once '%{buildroot}%{php_home}/Composer/CaBundle/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72 php73; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" "php71 %{_bindir}/phpunit7" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit8} --verbose || ret=1
fi
done
exit $ret
@@ -142,6 +142,10 @@ exit $ret
%changelog
+* Thu Aug 1 2019 Remi Collet <remi@remirepo.net> - 1.2.1-1
+- update to 1.2.1
+- use PHPUnit 8
+
* Tue Jan 29 2019 Remi Collet <remi@remirepo.net> - 1.1.4-1
- update to 1.1.4 (no change)