summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json12
-rw-r--r--php-composer-ca-bundle-rpm.patch22
-rw-r--r--php-composer-ca-bundle.spec16
3 files changed, 27 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index 22de0a8..5213e97 100644
--- a/composer.json
+++ b/composer.json
@@ -27,7 +27,8 @@
"php": "^5.3.2 || ^7.0 || ^8.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.35 || ^5.7 || 6.5 - 8",
+ "symfony/phpunit-bridge": "^4.2 || ^5",
+ "phpstan/phpstan": "^0.12.55",
"psr/log": "^1.0",
"symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0"
},
@@ -43,12 +44,11 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.x-dev"
+ "dev-main": "1.x-dev"
}
},
- "config": {
- "platform": {
- "php": "5.3.9"
- }
+ "scripts": {
+ "test": "SYMFONY_PHPUNIT_REMOVE_RETURN_TYPEHINT=1 vendor/bin/simple-phpunit",
+ "phpstan": "vendor/bin/phpstan analyse"
}
}
diff --git a/php-composer-ca-bundle-rpm.patch b/php-composer-ca-bundle-rpm.patch
index 7ae8760..9ff37d0 100644
--- a/php-composer-ca-bundle-rpm.patch
+++ b/php-composer-ca-bundle-rpm.patch
@@ -1,7 +1,7 @@
-diff -up src/CaBundle.php.rpm src/CaBundle.php
---- src/CaBundle.php.rpm 2017-11-30 07:12:46.773928987 +0100
-+++ src/CaBundle.php 2017-11-30 07:15:28.549820032 +0100
-@@ -130,7 +130,7 @@ class CaBundle
+diff -up ./src/CaBundle.php.rpm ./src/CaBundle.php
+--- ./src/CaBundle.php.rpm 2021-01-12 13:54:38.000000000 +0100
++++ ./src/CaBundle.php 2021-01-12 13:55:35.957422992 +0100
+@@ -125,7 +125,7 @@ class CaBundle
*/
public static function getBundledCaBundlePath()
{
@@ -10,15 +10,15 @@ diff -up src/CaBundle.php.rpm src/CaBundle.php
// cURL does not understand 'phar://' paths
// see https://github.com/composer/ca-bundle/issues/10
-diff -up tests/CaBundleTest.php.rpm tests/CaBundleTest.php
---- tests/CaBundleTest.php.rpm 2019-08-01 11:14:21.577672699 +0200
-+++ tests/CaBundleTest.php 2019-08-01 11:14:31.322744408 +0200
-@@ -104,7 +104,7 @@ class CaBundleTest extends TestCase
+diff -up ./tests/CaBundleTest.php.rpm ./tests/CaBundleTest.php
+--- ./tests/CaBundleTest.php.rpm 2021-01-12 13:55:35.957422992 +0100
++++ ./tests/CaBundleTest.php 2021-01-12 13:56:54.872069486 +0100
+@@ -124,7 +124,7 @@ class CaBundleTest extends TestCase
public function testOpenBaseDir()
{
- $oldValue = ini_get('open_basedir');
-- ini_set('open_basedir', realpath(__DIR__ . '/../'));
-+ ini_set('open_basedir', '/usr/share/php:' . realpath(__DIR__ . '/../'));
+ $oldValue = ini_get('open_basedir') ?: '';
+- ini_set('open_basedir', dirname(__DIR__));
++ ini_set('open_basedir', '/usr/share/php:' . dirname(__DIR__));
$certFilePath = CaBundle::getSystemCaRootBundlePath();
$validResult = CaBundle::validateCaFile($certFilePath, null);
$this->assertTrue($validResult);
diff --git a/php-composer-ca-bundle.spec b/php-composer-ca-bundle.spec
index ed5bebf..58edb0d 100644
--- a/php-composer-ca-bundle.spec
+++ b/php-composer-ca-bundle.spec
@@ -9,14 +9,14 @@
%bcond_without tests
-%global gh_commit 8a7ecad675253e4654ea05505233285377405215
+%global gh_commit 78a0e288fdcebf92aa2318a8d3656168da6ac1a5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner composer
%global gh_project ca-bundle
%global php_home %{_datadir}/php
Name: php-composer-ca-bundle
-Version: 1.2.8
+Version: 1.2.9
Release: 1%{?dist}
Summary: Lets you find a path to the system CA
@@ -36,11 +36,12 @@ BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-cli
# From composer.json, "require": {
-# "phpunit/phpunit": "^4.8.35 || ^5.7 || 6.5 - 8",
+# "symfony/phpunit-bridge": "^4.2 || ^5",
+# "phpstan/phpstan": "^0.12.55",
# "psr/log": "^1.0",
# "symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0"
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: phpunit6
+BuildRequires: phpunit8
%global phpunit %{_bindir}/phpunit8
BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
BuildRequires: (php-composer(symfony/process) >= 2.5 with php-composer(symfony/process) < 6)
@@ -123,10 +124,10 @@ require_once '%{buildroot}%{php_home}/Composer/CaBundle/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 "php74 %{_bindir}/phpunit8"; do
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit8} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -145,6 +146,9 @@ exit $ret
%changelog
+* Tue Jan 12 2021 Remi Collet <remi@remirepo.net> - 1.2.9-1
+- update to 1.2.9
+
* Mon Aug 24 2020 Remi Collet <remi@remirepo.net> - 1.2.8-1
- update to 1.2.8 (no change)