summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-composer-ca-bundle.spec12
3 files changed, 12 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index efed1d2..a29d7f1 100644
--- a/composer.json
+++ b/composer.json
@@ -22,6 +22,8 @@
"issues": "https://github.com/composer/ca-bundle/issues"
},
"require": {
+ "ext-openssl": "*",
+ "ext-pcre": "*",
"php": "^5.3.2 || ^7.0"
},
"require-dev": {
diff --git a/makesrc.sh b/makesrc.sh
index bde65fc..c047df5 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -15,7 +15,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
-cp composer.json ../composer-$VERSION.json
+cp composer.json ../composer.json
popd
echo "Archiving..."
diff --git a/php-composer-ca-bundle.spec b/php-composer-ca-bundle.spec
index 95516d2..951bf37 100644
--- a/php-composer-ca-bundle.spec
+++ b/php-composer-ca-bundle.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit a2995e5fe351055f2c7630166af12ce8fd03edfc
+%global gh_commit 5df9ed0ed0c9506ea6404a23450854e5df15cc12
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner composer
%global gh_project ca-bundle
@@ -14,7 +14,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-composer-ca-bundle
-Version: 1.0.2
+Version: 1.0.3
Release: 1%{?dist}
Summary: Lets you find a path to the system CA
@@ -44,11 +44,14 @@ BuildRequires: %{_sysconfdir}/pki/tls/certs/ca-bundle.crt
%endif
# From composer.json, "require": {
+# "ext-openssl": "*",
+# "ext-pcre": "*",
# "php": "^5.3.2 || ^7.0"
Requires: php(language) >= 5.3.2
-# From phpcompatinfo report for version 1.0.2
Requires: php-openssl
Requires: php-pcre
+# From phpcompatinfo report for version 1.0.3
+#nothing
# Autoloader
Requires: php-composer(symfony/class-loader)
# ca-certificates
@@ -117,6 +120,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jul 19 2016 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
+- update to 1.0.3
+
* Sat Apr 30 2016 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
- initial package, version 1.0.2