summaryrefslogtreecommitdiffstats
path: root/php-composer-ca-bundle.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-30 06:14:03 +0200
committerRemi Collet <remi@remirepo.net>2018-03-30 06:14:03 +0200
commitb6e39381eb39b06f8166833a15762486d8518a33 (patch)
treec0330e8dced332bdee61247917159ea465097b15 /php-composer-ca-bundle.spec
parent84827b1ee80b94702e0bb1936d6f52fa481ba6cd (diff)
update to 1.1.1 (no change)
use range dependencies on F27+ use phpunit6 on F27+
Diffstat (limited to 'php-composer-ca-bundle.spec')
-rw-r--r--php-composer-ca-bundle.spec35
1 files changed, 23 insertions, 12 deletions
diff --git a/php-composer-ca-bundle.spec b/php-composer-ca-bundle.spec
index c8727b2..47dd009 100644
--- a/php-composer-ca-bundle.spec
+++ b/php-composer-ca-bundle.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-composer-ca-bundle
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 943b2c4fcad1ef178d16a713c2468bf7e579c288
+%global gh_commit d2c0a83b7533d6912e8d516756ebd34f893e9169
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner composer
%global gh_project ca-bundle
@@ -14,11 +14,10 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-composer-ca-bundle
-Version: 1.1.0
+Version: 1.1.1
Release: 1%{?dist}
Summary: Lets you find a path to the system CA
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
# git snapshot to get everything, despite .gitattributes
@@ -35,14 +34,20 @@ BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-cli
# From composer.json, "require": {
-# "phpunit/phpunit": "^4.8.35",
+# "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5",
# "psr/log": "^1.0",
# "symfony/process": "^2.5 || ^3.0 || ^4.0"
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: phpunit6
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: (php-composer(psr/log) >= 1.0 with php-composer(psr/log) < 2)
+BuildRequires: (php-composer(symfony/process) >= 2.5 with php-composer(symfony/process) < 5)
+%else
BuildRequires: phpunit
-BuildRequires: php-composer(psr/log) < 2
-BuildRequires: php-composer(psr/log) >= 1.0
-BuildRequires: php-composer(symfony/process) < 5
-BuildRequires: php-composer(symfony/process) >= 2.5
+%global phpunit %{_bindir}/phpunit
+BuildRequires: php-PsrLog
+BuildRequires: php-symfony-process
+%endif
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
# ca-certificates
@@ -115,9 +120,10 @@ require_once '%{buildroot}%{php_home}/Composer/CaBundle/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
fi
done
exit $ret
@@ -136,6 +142,11 @@ exit $ret
%changelog
+* Fri Mar 30 2018 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1 (no change)
+- use range dependencies on F27+
+- use phpunit6 on F27+
+
* Thu Nov 30 2017 Remi Collet <remi@remirepo.net> - 1.1.0-1
- Update to 1.1.0
- allow Symfony 2, 3 and 4