summaryrefslogtreecommitdiffstats
path: root/php-codeception-verify.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-12 15:38:20 +0200
committerRemi Collet <remi@remirepo.net>2019-06-12 15:38:20 +0200
commitfd22c1906fa4a74bfbda8680b476a070ebe93548 (patch)
tree6c7a09ad7d7f111347ec2e1066d00c18af415b3c /php-codeception-verify.spec
parent086d1f05c3f1649bf54596e57683f5c92c4ea0f0 (diff)
sync with fedoraHEADmaster
Diffstat (limited to 'php-codeception-verify.spec')
-rw-r--r--php-codeception-verify.spec46
1 files changed, 29 insertions, 17 deletions
diff --git a/php-codeception-verify.spec b/php-codeception-verify.spec
index 2ea0680..4c07ff6 100644
--- a/php-codeception-verify.spec
+++ b/php-codeception-verify.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-codeception-verify
#
-# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,12 +12,16 @@
%global github_owner Codeception
%global github_name Verify
-%global github_version 0.4.0
-%global github_commit 8a17273017e23a866df3fa2ad2b4182b7ce354f0
+%global github_version 1.0.0
+%global github_commit f45b39025b3f5cfd9a9d8fb992432885ff5380c1
%global composer_vendor codeception
%global composer_project verify
+# "php": ">= 7.0"
+%global php_min_ver 7.0
+# "phpunit/phpunit": "> 6.0"
+
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -28,7 +32,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: BDD assertion library for PHPUnit
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -39,19 +42,23 @@ BuildRequires: php-fedora-autoloader-devel
# Tests
%if %{with_tests}
## composer.json
-BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 0.4.0)
-BuildRequires: php(language) >= 5.3.0
-BuildRequires: php-date
-BuildRequires: php-dom
-BuildRequires: php-reflection
+BuildRequires: php(language) >= %{php_min_ver}
+# "phpunit/phpunit": "> 6.0"
+# NOTE: Using PHPUnit 7 to be compatible with php-codeception-specify 1.1.0 ("phpunit/phpunit": "^7.0")
+BuildRequires: phpunit7
+## phpcompatinfo (computed from version 1.0.0)
+## <none>
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
-# phpcompatinfo (computed from version 0.4.0)
-Requires: php(language) >= 5.3.0
-Requires: php-reflection
+#composer.json
+Requires: php(language) >= %{php_min_ver}
+# "phpunit/phpunit": "> 6.0"
+# NOTE: Using PHPUnit 7 to be compatible with php-codeception-specify 1.1.0 ("phpunit/phpunit": "^7.0")
+Requires: phpunit7
+# phpcompatinfo (computed from version 1.0.0)
+# <none>
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -77,9 +84,10 @@ Autoloader: %{phpdir}/Codeception/autoload-verify.php
%{_bindir}/phpab --template fedora --output src/Codeception/autoload-verify.php src/
cat <<'AUTOLOAD' | tee -a src/Codeception/autoload-verify.php
-\Fedora\Autoloader\Dependencies::required(array(
+\Fedora\Autoloader\Dependencies::required([
__DIR__.'/function.php',
-));
+ '%{phpdir}/PHPUnit7/autoload.php',
+]);
AUTOLOAD
@@ -92,8 +100,8 @@ cp -rp src/Codeception/* %{buildroot}%{phpdir}/Codeception/
%if %{with_tests}
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
+PHPUNIT=$(which phpunit7)
+for PHP_EXEC in php php71 php72 php73 php74; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose \
--bootstrap %{buildroot}%{phpdir}/Codeception/autoload-verify.php \
@@ -118,5 +126,9 @@ exit $RETURN_CODE
%changelog
+* Mon May 27 2019 Shawn Iwinski <shawn@iwin.ski> - 1.0.0-1
+- Update to 1.0.0 (RHBZ #1512283)
+- Add range version dependencies for Fedora >= 27 || RHEL >= 8
+
* Sun Aug 20 2017 Shawn Iwinski <shawn@iwin.ski> - 0.4.0-1
- Initial package