summaryrefslogtreecommitdiffstats
path: root/php-channel-theseer.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-11 20:41:51 +0200
committerRemi Collet <fedora@famillecollet.com>2012-10-11 20:41:51 +0200
commit7a3b1ce0deda14c6a905ba36507657483bc82ebd (patch)
treebbe230dce28a83750a940a899c70ff2eb8e0adac /php-channel-theseer.spec
php-channel-theseer: new packageHEADmaster
Diffstat (limited to 'php-channel-theseer.spec')
-rw-r--r--php-channel-theseer.spec70
1 files changed, 70 insertions, 0 deletions
diff --git a/php-channel-theseer.spec b/php-channel-theseer.spec
new file mode 100644
index 0000000..ec36eb4
--- /dev/null
+++ b/php-channel-theseer.spec
@@ -0,0 +1,70 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+
+%global channel pear.netpirates.net
+
+Name: php-channel-theseer
+# Use REST version
+Version: 1.3
+Release: 1%{?dist}
+Summary: Adds theseer channel to PEAR
+
+Group: Development/Languages
+License: BSD
+URL: http://%{channel}/
+Source0: http://%{channel}/channel.xml
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+
+Requires: php-pear(PEAR)
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Provides: php-channel(%{channel})
+
+%description
+This package adds the pear.netpirates.net (theseer) channel which allows
+PEAR packages from this channel to be installed.
+
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{SOURCE0} %{buildroot}%{pear_xmldir}/%{name}.xml
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/%{name}.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/%{name}.xml > /dev/null ||:
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete %{channel} > /dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%{pear_xmldir}/%{name}.xml
+
+
+%changelog
+* Wed Feb 25 2011 Remi Collet <remi@fedoraproject.org> - 1.3-1
+- Initial Release
+