From a3278ca84e77b58e870669cc3d61348d5a565837 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Fri, 3 Jun 2022 14:02:08 +0200
Subject: update to 4.3.10

switch to phpunit9
---
 composer.json     |  2 +-
 php-cakephp4.spec | 22 ++++++++++++----------
 2 files changed, 13 insertions(+), 11 deletions(-)

diff --git a/composer.json b/composer.json
index ba3abe7..2ed1cad 100644
--- a/composer.json
+++ b/composer.json
@@ -115,7 +115,7 @@
         ],
         "stan-tests": "phpstan.phar analyze -c tests/phpstan.neon",
         "stan-baseline": "phpstan.phar --generate-baseline",
-        "stan-setup": "cp composer.json composer.backup && composer require --dev symfony/polyfill-php81 phpstan/phpstan:~1.6.0 psalm/phar:~4.22.0 && mv composer.backup composer.json",
+        "stan-setup": "cp composer.json composer.backup && composer require --dev symfony/polyfill-php81 phpstan/phpstan:~1.7.0 psalm/phar:~4.23.0 && mv composer.backup composer.json",
         "lowest": "validate-prefer-lowest",
         "lowest-setup": "composer update --prefer-lowest --prefer-stable --prefer-dist --no-interaction && cp composer.json composer.backup && composer require --dev dereuromark/composer-prefer-lowest && mv composer.backup composer.json",
         "test": "phpunit",
diff --git a/php-cakephp4.spec b/php-cakephp4.spec
index 5a9c72f..b36dcc0 100644
--- a/php-cakephp4.spec
+++ b/php-cakephp4.spec
@@ -7,12 +7,9 @@
 # Please, preserve the changelog entries
 #
 
-# TODO:
-# phpunit9.... seems a mess
-
 
 # https://github.com/cakephp/cakephp/releases
-%global gh_commit    6548d1141fc8311d0fd4d6acdd18446d4279fe32
+%global gh_commit    c73d4428b6bd9d8e4481b5030319432b51191257
 %global gh_short     %(c=%{gh_commit}; echo ${c:0:7})
 %global gh_owner     cakephp
 %global gh_project   cakephp
@@ -28,7 +25,7 @@
 %global chronos_version 2.3.0
 
 Name:           php-%{pk_vendor}%{major}
-Version:        4.3.9
+Version:        4.3.10
 Release:        1%{?dist}
 Summary:        The CakePHP framework
 
@@ -61,7 +58,7 @@ BuildRequires:  php-spl
 #        "mikey179/vfsstream": "^1.6.10",
 #        "paragonie/csp-builder": "^2.3",
 #        "phpunit/phpunit": "^8.5 || ^9.3"
-BuildRequires:  phpunit8 >= 8.5
+BuildRequires:  phpunit9 >= 9.3
 %if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
 BuildRequires: (php-composer(mikey179/vfsstream)  >= 1.6.10 with php-composer(mikey179/vfsstream)  < 2)
 BuildRequires:  glibc-langpack-en
@@ -970,7 +967,7 @@ sed -e 's/3.25.0/3.28.0/' -i tests/TestCase/Database/Driver/SqliteTest.php
 export LANG=en_GB.UTF-8
 ret=0
 : Run chronos test suite
-%{_bindir}/phpunit8 tests2 \
+%{_bindir}/phpunit9 tests2 \
     --verbose || ret=1
 
 : Run cakephp test suite
@@ -978,9 +975,10 @@ ret=0
 # testCurrency|testConfig issue with ICU version
 # CspMiddlewareTest  paragonie/csp-builder not packaged
 # testReplaceLinkBinaryUuid need investigation
-# testRsa* broekn with OpenSSL 3.0
-%{_bindir}/phpunit8 tests/TestCase \
-    --filter '^((?!(CspMiddlewareTest|testEmailDeep|testConfigContext|testDataAvailable|testAddresses|testHost|testCurrency|testConfig|testReplaceLinkBinaryUuid|testRsaSigningWithPassphraseString|testRsaSigningStringWithPassphraseString|testRsaSigningWithPassphraseFile|testRsaSigningStringWithPassphraseFile)).)*$' \
+# testRsa* broken with OpenSSL 3.0
+# testSQLFunctions broken with 8.1 (date format)
+%{_bindir}/phpunit9 tests/TestCase \
+    --filter '^((?!(CspMiddlewareTest|testEmailDeep|testConfigContext|testDataAvailable|testAddresses|testHost|testCurrency|testConfig|testReplaceLinkBinaryUuid|testRsaSigningWithPassphraseString|testRsaSigningStringWithPassphraseString|testRsaSigningWithPassphraseFile|testRsaSigningStringWithPassphraseFile|testSQLFunctions)).)*$' \
     --verbose || ret=1
 
 exit $ret
@@ -1150,6 +1148,10 @@ exit $ret
 
 
 %changelog
+* Fri Jun  3 2022 Remi Collet <remi@remirepo.net> - 4.3.10-1
+- update to 4.3.10
+- switch to phpunit9
+
 * Mon May 16 2022 Remi Collet <remi@remirepo.net> - 4.3.9-1
 - update to 4.3.9
 
-- 
cgit