From 1e863b284dc0df48421c1e6b4a988f0c62e4da82 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Mon, 6 Jul 2020 08:34:03 +0200
Subject: update to 4.1.0

---
 composer.json     |  1 +
 php-cakephp4.spec | 15 ++++++++++-----
 2 files changed, 11 insertions(+), 5 deletions(-)

diff --git a/composer.json b/composer.json
index e89f5c6..22a70a6 100644
--- a/composer.json
+++ b/composer.json
@@ -63,6 +63,7 @@
             "src/Core/functions.php",
             "src/Collection/functions.php",
             "src/I18n/functions.php",
+            "src/Routing/functions.php",
             "src/Utility/bootstrap.php"
         ]
     },
diff --git a/php-cakephp4.spec b/php-cakephp4.spec
index 5ec24e5..a9e09a7 100644
--- a/php-cakephp4.spec
+++ b/php-cakephp4.spec
@@ -11,14 +11,14 @@
 # Auth, Command, Controller, Error, Mailer, Network, Routing, Shell, TestSuite, View
 
 # https://github.com/cakephp/cakephp/releases
-%global gh_commit    9cb11c941566cae80a825889a2c007e1860abbd3
+%global gh_commit    8e997951f90769ac104193cfe275d091bddcc99b
 %global gh_short     %(c=%{gh_commit}; echo ${c:0:7})
 %global gh_owner     cakephp
 %global gh_project   cakephp
 %global pk_vendor   cakephp
 %global ns_vendor    Cake
 %global php_home     %{_datadir}/php
-%global with_tests   0%{!?_without_tests:1}
+%bcond_without       tests
 %global major        4
 
 # https://github.com/cakephp/chronos/releases
@@ -27,7 +27,7 @@
 %global chronos_version 2.0.5
 
 Name:           php-%{pk_vendor}%{major}
-Version:        4.0.9
+Version:        4.1.0
 Release:        1%{?dist}
 Summary:        The CakePHP framework
 
@@ -40,7 +40,7 @@ Source3:        makesrc2.sh
 
 BuildArch:      noarch
 BuildRequires:  php-cli
-%if %{with_tests}
+%if %{with tests}
 # For tests
 BuildRequires:  php(language) >= 7.2
 BuildRequires:  php-ctype
@@ -622,6 +622,7 @@ require_once '%{php_home}/Fedora/Autoloader/autoload.php';
     __DIR__ . '/Core/functions.php',
     __DIR__ . '/Collection/functions.php',
     __DIR__ . '/I18n/functions.php',
+    __DIR__ . '/Routing/functions.php',
     __DIR__ . '/Utility/bootstrap.php',
     '%{php_home}/Aura/Intl/autoload.php',
     '%{php_home}/Psr/Log/autoload.php',
@@ -715,6 +716,7 @@ require_once '%{php_home}/Fedora/Autoloader/autoload.php';
     '%{php_home}/Psr/Http/Server/autoload.php',
     dirname(__DIR__) . '/Utility/autoload.php',
     __DIR__ . '/functions.php',
+    dirname(__DIR__) . '/Routing/functions.php',
 ]);
 EOF
 
@@ -943,7 +945,7 @@ require "%{buildroot}%{php_home}/%{ns_vendor}%{major}/Validation/autoload.php";
 exit (class_exists("Cake\\Validation\\Validator") ? 0 : 1);
 '
 
-%if %{with_tests}
+%if %{with tests}
 : Fix path
 sed -e 's:vendor/phpunit/phpunit/src/::' -i \
   tests/TestCase/Error/Middleware/ErrorHandlerMiddlewareTest.php \
@@ -1134,6 +1136,9 @@ exit $ret
 
 
 %changelog
+* Mon Jul  6 2020 Remi Collet <remi@remirepo.net> - 4.1.0-1
+- update to 4.1.0
+
 * Tue Jun 23 2020 Remi Collet <remi@remirepo.net> - 4.0.9-1
 - update to 4.0.9
 
-- 
cgit