summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-brumann-polyfill-unserialize.spec16
1 files changed, 12 insertions, 4 deletions
diff --git a/php-brumann-polyfill-unserialize.spec b/php-brumann-polyfill-unserialize.spec
index 1eebb71..ef70875 100644
--- a/php-brumann-polyfill-unserialize.spec
+++ b/php-brumann-polyfill-unserialize.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-brumann-polyfill-unserialize
#
-# Copyright (c) 2019-2020 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2019-2021 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -28,7 +28,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 4%{?github_release}%{?dist}
Summary: Backports unserialize options introduced in PHP 7.0
License: MIT
@@ -114,12 +114,17 @@ require '%{buildroot}%{phpdir}/Brumann/Polyfill/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Tests\\Brumann\\Polyfill\\', __DIR__.'/tests');
BOOTSTRAP
+# SKIP test_with_parent_not_allowed_serialized_class_is_not_accessible: notice promoted to warning
+
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php php72 php73 php74; do
+for PHP_EXEC in php php73 php74 php80; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
+ $PHP_EXEC $PHPUNIT \
+ --bootstrap bootstrap.php \
+ --filter '^((?!(test_with_parent_not_allowed_serialized_class_is_not_accessible)).)*$' \
+ --verbose || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -138,6 +143,9 @@ exit $RETURN_CODE
%changelog
+* Tue Apr 6 2021 Remi Collet <remi@remirepo.net> - 1.0.4-4
+- skip 1 test failing with PHP 8
+
* Sun Apr 05 2020 Shawn Iwinski <shawn@iwin.ski> - 1.0.4-1
- Update to 1.0.4 (RHBZ #1742087)