summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json7
-rw-r--r--php-brick-varexporter.spec36
2 files changed, 28 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 2da21f6..cab60c4 100644
--- a/composer.json
+++ b/composer.json
@@ -7,12 +7,13 @@
],
"license": "MIT",
"require": {
- "php": ">=7.2",
+ "php": "^7.2 || ^8.0",
"nikic/php-parser": "^4.0"
},
"require-dev": {
- "phpunit/phpunit": "^7.0",
- "php-coveralls/php-coveralls": "^2.0"
+ "phpunit/phpunit": "^8.5 || ^9.0",
+ "php-coveralls/php-coveralls": "^2.2",
+ "vimeo/psalm": "^4.3"
},
"autoload": {
"psr-4": {
diff --git a/php-brick-varexporter.spec b/php-brick-varexporter.spec
index 10f3be0..93475d6 100644
--- a/php-brick-varexporter.spec
+++ b/php-brick-varexporter.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-brick-varexporter
#
-# Copyright (c) 2020 Remi Collet
+# Copyright (c) 2020-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
# Github
-%global gh_commit 411110b797c6b1ecf947a0eec17ffaa59284f5a0
+%global gh_commit 736378d357a189a692390bbc9e0eed835b079805
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner brick
%global gh_project varexporter
@@ -19,7 +19,7 @@
%global ns_project VarExporter
Name: php-%{pk_vendor}-%{pk_name}
-Version: 0.3.2
+Version: 0.3.3
Release: 1%{?dist}
Summary: A powerful alternative to var_export
@@ -44,14 +44,21 @@ BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^7.0",
-# "php-coveralls/php-coveralls": "^2.0"
-BuildRequires: phpunit7
+# "phpunit/phpunit": "^8.5 || ^9.0",
+# "php-coveralls/php-coveralls": "^2.2",
+# "vimeo/psalm": "^4.3"
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+BuildRequires: phpunit9
+%global phpunit %{_bindir}/phpunit9
+%else
+BuildRequires: phpunit8 >= 8.5
+%global phpunit %{_bindir}/phpunit8
+%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=7.2",
+# "php": "^7.2 || ^8.0",
# "nikic/php-parser": "^4.0"
Requires: php(language) >= 7.2
# remirepo:1
@@ -116,11 +123,12 @@ EOF
: Run upstream test suite
ret=0
-for cmd in php php72 php73 php74 php80; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit7 \
- --no-coverage \
- --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit9} \
+ --no-coverage \
+ --verbose || ret=1
fi
done
exit $ret
@@ -136,5 +144,9 @@ exit $ret
%changelog
+* Mon Jan 4 2021 Remi Collet <remi@remirepo.net> - 0.3.3-1
+- update to 0.3.3
+- switch to phpunit9
+
* Tue Aug 25 2020 Remi Collet <remi@remirepo.net> - 0.3.2-1
- initial package