summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-05 17:08:36 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-05 17:08:36 +0100
commitdd8d81e41d41f66ce0d437f4bcb1d2c02963f7f5 (patch)
tree0c4050e0f4458621508a6b6b1cd4ad6eeaeed5b8
parentd97856ff91ba8d82c91f6bd4ae1e28bbc2f6ba5a (diff)
php-bartlett-php-compatinfo-db: 1.2.0
-rw-r--r--php-bartlett-php-compatinfo-db-1.2.0-autoload.php (renamed from php-bartlett-php-compatinfo-db-autoload.php)2
-rw-r--r--php-bartlett-php-compatinfo-db-1.2.0-rpm.patch (renamed from php-bartlett-php-compatinfo-db-1.0.0-rpm.patch)16
-rw-r--r--php-bartlett-php-compatinfo-db.spec22
3 files changed, 25 insertions, 15 deletions
diff --git a/php-bartlett-php-compatinfo-db-autoload.php b/php-bartlett-php-compatinfo-db-1.2.0-autoload.php
index 05f0921..85623cb 100644
--- a/php-bartlett-php-compatinfo-db-autoload.php
+++ b/php-bartlett-php-compatinfo-db-1.2.0-autoload.php
@@ -15,3 +15,5 @@ if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Compo
$fedoraClassLoader->register();
}
$fedoraClassLoader->addPrefix('Bartlett\\CompatInfoDb\\', dirname(dirname(__DIR__)));
+
+require_once $vendorDir . '/Composer/Semver/autoload.php';
diff --git a/php-bartlett-php-compatinfo-db-1.0.0-rpm.patch b/php-bartlett-php-compatinfo-db-1.2.0-rpm.patch
index 23f300c..33b801b 100644
--- a/php-bartlett-php-compatinfo-db-1.0.0-rpm.patch
+++ b/php-bartlett-php-compatinfo-db-1.2.0-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./data/handleDB.php.rpm ./data/handleDB.php
---- ./data/handleDB.php.rpm 2015-11-04 09:31:27.320112762 +0100
-+++ ./data/handleDB.php 2015-11-04 09:32:05.209285133 +0100
+--- ./data/handleDB.php.rpm 2015-12-04 21:15:12.000000000 +0100
++++ ./data/handleDB.php 2015-12-05 16:55:03.461056102 +0100
@@ -12,7 +12,8 @@
* @since Release 1.0.0alpha1 of PHP_CompatInfo_Db
*/
@@ -12,8 +12,8 @@ diff -up ./data/handleDB.php.rpm ./data/handleDB.php
use Bartlett\CompatInfoDb\ExtensionFactory;
diff -up ./src/Bartlett/CompatInfoDb/Environment.php.rpm ./src/Bartlett/CompatInfoDb/Environment.php
---- ./src/Bartlett/CompatInfoDb/Environment.php.rpm 2015-11-04 09:38:03.048913082 +0100
-+++ ./src/Bartlett/CompatInfoDb/Environment.php 2015-11-04 09:39:39.974354034 +0100
+--- ./src/Bartlett/CompatInfoDb/Environment.php.rpm 2015-12-04 21:15:12.000000000 +0100
++++ ./src/Bartlett/CompatInfoDb/Environment.php 2015-12-05 16:55:03.461056102 +0100
@@ -37,6 +37,12 @@ class Environment
*/
public static function initRefDb()
@@ -28,9 +28,9 @@ diff -up ./src/Bartlett/CompatInfoDb/Environment.php.rpm ./src/Bartlett/CompatIn
$tempDir = sys_get_temp_dir() . '/bartlett';
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2015-11-04 09:34:12.089862363 +0100
-+++ ./tests/bootstrap.php 2015-11-04 09:34:49.361031923 +0100
-@@ -1,7 +1,7 @@
+--- ./tests/bootstrap.php.rpm 2015-12-05 16:55:03.461056102 +0100
++++ ./tests/bootstrap.php 2015-12-05 16:56:06.693323039 +0100
+@@ -1,6 +1,7 @@
<?php
$baseDir = dirname(__DIR__);
@@ -38,4 +38,4 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
+$vendorDir = 'Bartlett/CompatInfoDb'; // tests use include_path
require_once $vendorDir . '/autoload.php';
-
++require_once __DIR__ . '/Reference/GenericTest.php';
diff --git a/php-bartlett-php-compatinfo-db.spec b/php-bartlett-php-compatinfo-db.spec
index 55a8bbd..0aa23b9 100644
--- a/php-bartlett-php-compatinfo-db.spec
+++ b/php-bartlett-php-compatinfo-db.spec
@@ -6,13 +6,13 @@
#
# Please, preserve the changelog entries
#
-# Github
-%global gh_commit b65b06ba30abba8e85c6afc40c8c9ea7921dc434
+# See https://github.com/llaville/php-compatinfo-db/releases
+%global gh_commit 5b30bfeff39cc87b3ea75289b63a6ba8608dda6f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20151031
+#global gh_date 20151031
%global gh_owner llaville
%global gh_project php-compatinfo-db
-%global prever alpha1
+#global prever alpha1
# Namespace
%global ns_vendor Bartlett
%global ns_project CompatInfoDb
@@ -23,7 +23,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{c_vendor}-%{c_project}
-Version: 1.0.0
+Version: 1.2.0
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Reference Database to be used with php-compatinfo library
@@ -34,14 +34,15 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
# Autoloader for RPM
-Source1: %{name}-autoload.php
+Source1: %{name}-1.2.0-autoload.php
# Autoload and sqlite database path
-Patch0: %{name}-1.0.0-rpm.patch
+Patch0: %{name}-1.2.0-rpm.patch
BuildArch: noarch
# Needed to build the database from sources
BuildRequires: php(language) >= 5.4.0
+BuildRequires: php-composer(composer/semver) >= 1.0
BuildRequires: php-curl
BuildRequires: php-intl
BuildRequires: php-libxml
@@ -65,6 +66,7 @@ BuildRequires: php-composer(phpunit/phpunit)
# From composer.json, "require"
# "php": ">=5.4.0",
+# "composer/semver": "~1.0",
# "ext-curl": "*",
# "ext-intl": "*",
# "ext-libxml": "*",
@@ -74,6 +76,8 @@ BuildRequires: php-composer(phpunit/phpunit)
# "ext-json": "*",
# "ext-pdo_sqlite": "*"
Requires: php(language) >= 5.4.0
+Requires: php-composer(composer/semver) >= 1.0
+Requires: php-composer(composer/semver) < 2
Requires: php-curl
Requires: php-intl
Requires: php-libxml
@@ -137,5 +141,9 @@ export BARTLETT_COMPATINFO_DB=%{buildroot}%{_datadir}/%{name}/compatinfo.sqlite
%changelog
+* Sat Dec 5 2015 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
+- update to 1.2.0
+- add dependency on composer/semver
+
* Wed Nov 4 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.1.alpha1
- Initial package \ No newline at end of file