summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-12 11:59:42 +0200
committerRemi Collet <remi@remirepo.net>2018-10-12 11:59:42 +0200
commit713d30d24359862d74e4d06be4782ee059b499d4 (patch)
tree5129eff36d39b7f00f6623688426308645147f71
parent0f7d173833a4e430d075df412eb088c9068ca93d (diff)
update to 1.37.0
use symfony3 ignore test failing because of symfony/polyfill
-rw-r--r--php-bartlett-php-compatinfo-db-1.19.0-rpm.patch2
-rw-r--r--php-bartlett-php-compatinfo-db.spec23
2 files changed, 19 insertions, 6 deletions
diff --git a/php-bartlett-php-compatinfo-db-1.19.0-rpm.patch b/php-bartlett-php-compatinfo-db-1.19.0-rpm.patch
index 4a256a8..4aca8b8 100644
--- a/php-bartlett-php-compatinfo-db-1.19.0-rpm.patch
+++ b/php-bartlett-php-compatinfo-db-1.19.0-rpm.patch
@@ -6,7 +6,7 @@ diff -up ./data/handleDB.php.rpm ./data/handleDB.php
*/
-require_once dirname(__DIR__) . '/vendor/autoload.php';
-+require_once '/usr/share/php/Symfony/Component/autoload.php';
++require_once '/usr/share/php/Symfony3/Component/autoload.php';
+require_once dirname(__DIR__) . '/src/Bartlett/CompatInfoDb/autoload.php';
require_once __DIR__ . '/ReferenceCollection.php';
diff --git a/php-bartlett-php-compatinfo-db.spec b/php-bartlett-php-compatinfo-db.spec
index 60cea34..693f69d 100644
--- a/php-bartlett-php-compatinfo-db.spec
+++ b/php-bartlett-php-compatinfo-db.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# See https://github.com/llaville/php-compatinfo-db/releases
-%global gh_commit 95ccc9a99f5ba907ed2d10bd193c82d04a23675d
+%global gh_commit a233f6e6299e3e52c7d67d6bb2c71d22a0eb44cf
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151031
%global gh_owner llaville
@@ -27,8 +27,8 @@
%endif
Name: php-%{c_vendor}-%{c_project}
-Version: 1.36.0
-%global specrel 2
+Version: 1.37.0
+%global specrel 1
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Reference Database to be used with php-compatinfo library
@@ -70,8 +70,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "bartlett/phpunit-loggertestlistener": "^1.5"
# "phpunit/php-timer": "^2.0"
BuildRequires: php-cli
-# Keep symfony v2 because v3 pull some bad dependencies (php-symfony-polyfill)
-BuildRequires: php-symfony-console
+BuildRequires: php-symfony3-console
%if %{with_tests}
BuildRequires: php-composer(phpunit/phpunit)
%endif
@@ -150,6 +149,9 @@ OPT=$(php -r '
case "71":
$max = Bartlett\CompatInfoDb\ExtensionFactory::LATEST_PHP_7_1;
break;
+ case "72":
+ $max = Bartlett\CompatInfoDb\ExtensionFactory::LATEST_PHP_7_2;
+ break;
default:
exit(0);
}
@@ -184,6 +186,12 @@ install -D -p -m 644 data/compatinfo.sqlite %{buildroot}%{_datadir}/%{name}
%check
export BARTLETT_COMPATINFO_DB=%{buildroot}%{_datadir}/%{name}/compatinfo.sqlite
+VER=$(php -r "echo PHP_MAJOR_VERSION . PHP_MINOR_VERSION;")
+if [ $VER -lt 72 ]; then
+ # because of polyfill
+ rm tests/Reference/Extension/CoreExtensionTest.php
+ rm tests/Reference/Extension/StandardExtensionTest.php
+fi
%{_bindir}/phpunit \
--include-path %{buildroot}%{_datadir}/php \
-d memory_limit=1G
@@ -201,6 +209,11 @@ export BARTLETT_COMPATINFO_DB=%{buildroot}%{_datadir}/%{name}/compatinfo.sqlite
%changelog
+* Fri Oct 12 2018 Remi Collet <remi@remirepo.net> - 1.37.0-1
+- update to 1.37.0
+- use symfony3
+- ignore test failing because of symfony/polyfill
+
* Sun Oct 7 2018 Remi Collet <remi@remirepo.net> - 1.36.0-2
- update to 1.36.0
- raise dependency on PHP 5.5