summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-09 15:23:00 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-09 15:23:00 +0100
commit67c14e09fb1719d464779fa6da3e3739eb38187e (patch)
tree217fab566effcf8be2ef47fa07d45a006b1bd391
parentf1139a9b8fd106e4bcd4fd956083f44d10fdff54 (diff)
php-bartlett-php-compatinfo-db: 1.4.0
-rw-r--r--php-bartlett-php-compatinfo-db-curltls.patch73
-rw-r--r--php-bartlett-php-compatinfo-db.spec11
2 files changed, 82 insertions, 2 deletions
diff --git a/php-bartlett-php-compatinfo-db-curltls.patch b/php-bartlett-php-compatinfo-db-curltls.patch
new file mode 100644
index 0000000..c05ac0f
--- /dev/null
+++ b/php-bartlett-php-compatinfo-db-curltls.patch
@@ -0,0 +1,73 @@
+diff -up data/references/Curl.constants.json.old data/references/Curl.constants.json
+--- data/references/Curl.constants.json.old 2016-01-09 15:10:57.792505666 +0100
++++ data/references/Curl.constants.json 2016-01-09 15:12:39.665949126 +0100
+@@ -3874,7 +3874,8 @@
+ "ext_max": "",
+ "php_min": "5.5.0",
+ "php_max": "",
+- "php_excludes": ""
++ "php_excludes": "",
++ "optional": true
+ },
+ {
+ "ext_name_fk": 9,
+@@ -3883,7 +3884,8 @@
+ "ext_max": "",
+ "php_min": "5.5.0",
+ "php_max": "",
+- "php_excludes": ""
++ "php_excludes": "",
++ "optional": true
+ },
+ {
+ "ext_name_fk": 9,
+@@ -3892,7 +3894,8 @@
+ "ext_max": "",
+ "php_min": "5.5.0",
+ "php_max": "",
+- "php_excludes": ""
++ "php_excludes": "",
++ "optional": true
+ },
+ {
+ "ext_name_fk": 9,
+@@ -3901,7 +3904,8 @@
+ "ext_max": "",
+ "php_min": "5.5.0",
+ "php_max": "",
+- "php_excludes": ""
++ "php_excludes": "",
++ "optional": true
+ },
+ {
+ "ext_name_fk": 9,
+@@ -3911,7 +3915,8 @@
+ "php_min": "5.5.19RC1",
+ "php_max": "",
+ "php_excludes": "5.6.0, 5.6.0RC1, 5.6.0RC2, 5.6.0RC3, 5.6.0RC4, 5.6.1, 5.6.1RC1, 5.6.2",
+- "lib_curl": "~7.34"
++ "lib_curl": "~7.34",
++ "optional": true
+ },
+ {
+ "ext_name_fk": 9,
+@@ -3921,7 +3926,8 @@
+ "php_min": "5.5.19RC1",
+ "php_max": "",
+ "php_excludes": "5.6.0, 5.6.0RC1, 5.6.0RC2, 5.6.0RC3, 5.6.0RC4, 5.6.1, 5.6.1RC1, 5.6.2",
+- "lib_curl": "~7.34"
++ "lib_curl": "~7.34",
++ "optional": true
+ },
+ {
+ "ext_name_fk": 9,
+@@ -3931,7 +3937,8 @@
+ "php_min": "5.5.19RC1",
+ "php_max": "",
+ "php_excludes": "5.6.0, 5.6.0RC1, 5.6.0RC2, 5.6.0RC3, 5.6.0RC4, 5.6.1, 5.6.1RC1, 5.6.2",
+- "lib_curl": "~7.34"
++ "lib_curl": "~7.34",
++ "optional": true
+ },
+ {
+ "ext_name_fk": 9,
diff --git a/php-bartlett-php-compatinfo-db.spec b/php-bartlett-php-compatinfo-db.spec
index c7a40b0..dc64351 100644
--- a/php-bartlett-php-compatinfo-db.spec
+++ b/php-bartlett-php-compatinfo-db.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# See https://github.com/llaville/php-compatinfo-db/releases
-%global gh_commit 0a8fdbb697c5296c6ddb35316a739318e8569cd3
+%global gh_commit c0bd579699ac3059547492e3745b859a72670de7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151031
%global gh_owner llaville
@@ -23,7 +23,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{c_vendor}-%{c_project}
-Version: 1.3.0
+Version: 1.4.0
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Reference Database to be used with php-compatinfo library
@@ -38,6 +38,8 @@ Source1: %{name}-1.2.0-autoload.php
# Autoload and sqlite database path
Patch0: %{name}-1.2.0-rpm.patch
+# CURL_SSLVERSION constants have been backported
+Patch1: %{name}-curltls.patch
BuildArch: noarch
# Needed to build the database from sources
@@ -102,6 +104,8 @@ Conflicts: php-bartlett-PHP-CompatInfo < 5
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
+%patch1 -p0 -b .old
+
cp %{SOURCE1} src/%{ns_vendor}/%{ns_project}/autoload.php
# Cleanup patched files
@@ -177,6 +181,9 @@ export BARTLETT_COMPATINFO_DB=%{buildroot}%{_datadir}/%{name}/compatinfo.sqlite
%changelog
+* Sat Jan 9 2016 Remi Collet <remi@fedoraproject.org> - 1.4.0-1
+- update to 1.4.0
+
* Tue Dec 29 2015 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
- update to 1.3.0