summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-12 08:28:11 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-12 08:28:11 +0200
commit57d96d121d89290e6fb5e47fe9c5f7e041f33ac5 (patch)
treede810b1b96478ac0d61d86b1d333b6e2610549bc
parent61376add1c61da3930445c6b5beafd217f52917f (diff)
php-bartlett-php-compatinfo-db: 1.7.0
-rw-r--r--composer.json59
-rw-r--r--php-bartlett-php-compatinfo-db.spec7
2 files changed, 64 insertions, 2 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..529dd29
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,59 @@
+{
+ "name": "bartlett/php-compatinfo-db",
+ "description": "Reference Database to be used with php-compatinfo library",
+ "keywords": ["compatibility", "database", "reference"],
+ "type": "library",
+ "license": "BSD-3-Clause",
+ "homepage": "http://php5.laurent-laville.org/compatinfo/",
+ "support": {
+ "source": "https://github.com/llaville/php-compatinfo-db",
+ "issues": "https://github.com/llaville/php-compatinfo-db/issues"
+ },
+ "require": {
+ "php": ">=5.4.0",
+ "composer/semver": "~1.0",
+ "ext-curl": "*",
+ "ext-intl": "*",
+ "ext-libxml": "*",
+ "ext-openssl": "*",
+ "ext-pcre": "*",
+ "ext-spl": "*",
+ "ext-json": "*",
+ "ext-pdo_sqlite": "*"
+ },
+ "require-dev": {
+ "symfony/console": "~2.5",
+ "psr/log": "~1.0",
+ "monolog/monolog": "~1.10",
+ "bartlett/phpunit-loggertestlistener": "~1.5"
+ },
+ "suggest": {
+ "symfony/console": "Allow to rebuild the Reference CompatInfo Database",
+ "psr/log": "Allow logging events with the LogPlugin",
+ "monolog/monolog": "Allow logging events with the LogPlugin",
+ "bartlett/phpunit-loggertestlistener": "Allow logging unit tests to your favorite PSR-3 logger interface"
+ },
+ "authors": [
+ {
+ "name": "Laurent Laville",
+ "email": "pear@laurent-laville.org",
+ "homepage": "https://github.com/llaville",
+ "role": "Lead"
+ },
+ {
+ "name": "Remi Collet",
+ "homepage": "https://github.com/remicollet",
+ "role": "Contributor"
+ }
+ ],
+ "autoload": {
+ "psr-4": {
+ "Bartlett\\CompatInfoDb\\": "src/Bartlett/CompatInfoDb"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Bartlett\\Tests\\CompatInfoDb\\": "tests/"
+ }
+ }
+}
diff --git a/php-bartlett-php-compatinfo-db.spec b/php-bartlett-php-compatinfo-db.spec
index 7b8ae8f..9c174f5 100644
--- a/php-bartlett-php-compatinfo-db.spec
+++ b/php-bartlett-php-compatinfo-db.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# See https://github.com/llaville/php-compatinfo-db/releases
-%global gh_commit 4dab0fc3da69f0077826b3aced38e04ae81105da
+%global gh_commit 92937c4c1b794ae657f384ade75411f6343f86a7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151031
%global gh_owner llaville
@@ -23,7 +23,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{c_vendor}-%{c_project}
-Version: 1.6.0
+Version: 1.7.0
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Reference Database to be used with php-compatinfo library
@@ -184,6 +184,9 @@ export BARTLETT_COMPATINFO_DB=%{buildroot}%{_datadir}/%{name}/compatinfo.sqlite
%changelog
+* Tue Apr 12 2016 Remi Collet <remi@fedoraproject.org> - 1.7.0-1
+- update to 1.7.0
+
* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 1.6.0-1
- update to 1.6.0
- use package version as version in database instead of date