summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-26 11:31:43 +0100
committerRemi Collet <remi@remirepo.net>2020-02-26 11:31:43 +0100
commit89eee77a5ca75e7fe6063213061e431260731e74 (patch)
tree5d4fa964547e5ad28d66f66dc1421bab5c87e47f
parent1e3ec07288735e4ff9af6c3132564cba38225fcb (diff)
update to 4.3.1
drop patch merged upstream
-rw-r--r--37.patch25
-rw-r--r--php-bartlett-PHP-Reflect.spec13
2 files changed, 7 insertions, 31 deletions
diff --git a/37.patch b/37.patch
deleted file mode 100644
index f3d3927..0000000
--- a/37.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From a628d02885fa031c82fd820b536c5eddbbbdb96e Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 25 Feb 2020 16:46:46 +0100
-Subject: [PATCH] Fix #36 Fatal error: Uncaught TypeError
-
----
- src/Bartlett/Reflect/Console/Application.php | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/Bartlett/Reflect/Console/Application.php b/src/Bartlett/Reflect/Console/Application.php
-index abbd088..b618197 100644
---- a/src/Bartlett/Reflect/Console/Application.php
-+++ b/src/Bartlett/Reflect/Console/Application.php
-@@ -223,9 +223,9 @@ public function run(InputInterface $input = null, OutputInterface $output = null
- if (isset($url['scheme']) && $url['scheme'] == 'ftp') {
- $options = array($url['scheme'] => array('overwrite' => true));
- $context = stream_context_create($options);
-- $output = new StreamOutput(fopen($target, $mode, false, $context), null, false);
-+ $output = new StreamOutput(fopen($target, $mode, false, $context), StreamOutput::VERBOSITY_NORMAL, false);
- } else {
-- $output = new StreamOutput(fopen($target, $mode), null, false);
-+ $output = new StreamOutput(fopen($target, $mode), StreamOutput::VERBOSITY_NORMAL, false);
- }
- }
- $output->getFormatter()->setStyle('diagpass', new OutputFormatterStyle('green', null, ['reverse']));
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index 71f7776..a3aa2ae 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 6609c40a1695ce5bcbaa814214cf4e8d88e21569
+%global gh_commit 5010b4de0540a711f329a26c72bd48280a3d755a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150331
%global gh_owner llaville
@@ -28,8 +28,8 @@
%endif
Name: php-bartlett-PHP-Reflect
-Version: 4.3.0
-%global specrel 3
+Version: 4.3.1
+%global specrel 1
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Adds the ability to reverse-engineer PHP
@@ -42,8 +42,6 @@ Source1: %{name}-autoload.php
# Enable cache plugin
Patch0: %{name}-4.3.0-rpm.patch
-# Fix compatibility with Symfony 4
-Patch1: https://patch-diff.githubusercontent.com/raw/llaville/php-reflect/pull/37.patch
BuildArch: noarch
BuildRequires: php(language) >= 5.5
@@ -186,7 +184,6 @@ Documentation: http://php5.laurent-laville.org/reflect/manual/current/en/
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
-%patch1 -p1 -b .rpm
find . -name \*.rpm -delete -print
cp %{SOURCE1} src/Bartlett/Reflect/autoload.php
@@ -243,6 +240,10 @@ fi
%changelog
+* Wed Feb 26 2020 Remi Collet <remi@remirepo.net> - 4.3.1-1
+- update to 4.3.1
+- drop patch merged upstream
+
* Tue Feb 25 2020 Remi Collet <remi@remirepo.net> - 4.3.0-3
- fix compatibility with Symfony 4 using patch from
https://github.com/llaville/php-reflect/pull/37