summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-07 08:52:18 +0200
committerRemi Collet <remi@remirepo.net>2020-07-07 08:52:18 +0200
commit68cb4c87a84ee9b815d6ecd45f337aa3de116f7e (patch)
tree83544be7e02fc7dc10561b6ebb41b8e95af00a30
parenta3ee1787b0af9fda6d273a9fdec1698ebde64e04 (diff)
v4.4.0
-rw-r--r--php-bartlett-PHP-Reflect-4.4.0-rpm.patch2
-rw-r--r--php-bartlett-PHP-Reflect.spec13
2 files changed, 9 insertions, 6 deletions
diff --git a/php-bartlett-PHP-Reflect-4.4.0-rpm.patch b/php-bartlett-PHP-Reflect-4.4.0-rpm.patch
index 313cfad..cb17986 100644
--- a/php-bartlett-PHP-Reflect-4.4.0-rpm.patch
+++ b/php-bartlett-PHP-Reflect-4.4.0-rpm.patch
@@ -60,7 +60,7 @@ diff -up ./bin/phpreflect.rpm ./bin/phpreflect
Environment::setScanDir();
--$application = new Application($appName, '4.4');
+-$application = new Application($appName, '4.4.0');
+$application = new Application($appName, '@package_version@');
$application->run();
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index a7a154e..5833e55 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -7,16 +7,16 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 23697aa21ff84194d96727f4b0ed4f11895e0a16
+%global gh_commit 6e571b0f6fcc90325b30f155d7ef0959cf114897
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150331
%global gh_owner llaville
%global gh_project php-reflect
#global prever RC2
%if %{bootstrap}
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%bcond_with tests
%else
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%bcond_without tests
%endif
%global sym_prefix php-symfony4
@@ -40,7 +40,7 @@ Patch0: %{name}-4.4.0-rpm.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.1.3
-%if %{with_tests}
+%if %{with tests}
# to run test suite
BuildRequires: %{phpunit}
# remirepo:1
@@ -192,7 +192,7 @@ install -D -p -m 644 bin/phpreflect.1 %{buildroot}%{_mandir}/man1/phpref
%check
-%if %{with_tests}
+%if %{with tests}
ret=0
for cmdarg in "php %{phpunit}" php72 php73 php74 php80; do
if which $cmdarg; then
@@ -226,6 +226,9 @@ fi
%changelog
+* Tue Jul 7 2020 Remi Collet <remi@remirepo.net> - 4.4.0-1
+- update to 4.4.0
+
* Mon Jul 6 2020 Remi Collet <remi@remirepo.net> - 4.4.0-0
- test build for upcoming 4.4.0
- raise dependency on PHP 7.1.3