summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-25 16:56:58 +0100
committerRemi Collet <remi@remirepo.net>2020-02-25 16:56:58 +0100
commit1e3ec07288735e4ff9af6c3132564cba38225fcb (patch)
treed9b87240ec7fd4ad0cdb61d8422df08ef56f3654
parentf84d244f85849f50ba132df5e279ec37e1c40c61 (diff)
fix compatibility with Symfony 4 using patch from https://github.com/llaville/php-reflect/pull/37
-rw-r--r--37.patch25
-rw-r--r--php-bartlett-PHP-Reflect.spec13
2 files changed, 35 insertions, 3 deletions
diff --git a/37.patch b/37.patch
new file mode 100644
index 0000000..f3d3927
--- /dev/null
+++ b/37.patch
@@ -0,0 +1,25 @@
+From a628d02885fa031c82fd820b536c5eddbbbdb96e Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 25 Feb 2020 16:46:46 +0100
+Subject: [PATCH] Fix #36 Fatal error: Uncaught TypeError
+
+---
+ src/Bartlett/Reflect/Console/Application.php | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Bartlett/Reflect/Console/Application.php b/src/Bartlett/Reflect/Console/Application.php
+index abbd088..b618197 100644
+--- a/src/Bartlett/Reflect/Console/Application.php
++++ b/src/Bartlett/Reflect/Console/Application.php
+@@ -223,9 +223,9 @@ public function run(InputInterface $input = null, OutputInterface $output = null
+ if (isset($url['scheme']) && $url['scheme'] == 'ftp') {
+ $options = array($url['scheme'] => array('overwrite' => true));
+ $context = stream_context_create($options);
+- $output = new StreamOutput(fopen($target, $mode, false, $context), null, false);
++ $output = new StreamOutput(fopen($target, $mode, false, $context), StreamOutput::VERBOSITY_NORMAL, false);
+ } else {
+- $output = new StreamOutput(fopen($target, $mode), null, false);
++ $output = new StreamOutput(fopen($target, $mode), StreamOutput::VERBOSITY_NORMAL, false);
+ }
+ }
+ $output->getFormatter()->setStyle('diagpass', new OutputFormatterStyle('green', null, ['reverse']));
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index 63e06b5..71f7776 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-bartlett-PHP-Reflect
#
-# Copyright (c) 2011-2017 Remi Collet
+# Copyright (c) 2011-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -29,7 +29,7 @@
Name: php-bartlett-PHP-Reflect
Version: 4.3.0
-%global specrel 2
+%global specrel 3
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Adds the ability to reverse-engineer PHP
@@ -42,6 +42,8 @@ Source1: %{name}-autoload.php
# Enable cache plugin
Patch0: %{name}-4.3.0-rpm.patch
+# Fix compatibility with Symfony 4
+Patch1: https://patch-diff.githubusercontent.com/raw/llaville/php-reflect/pull/37.patch
BuildArch: noarch
BuildRequires: php(language) >= 5.5
@@ -184,6 +186,7 @@ Documentation: http://php5.laurent-laville.org/reflect/manual/current/en/
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
+%patch1 -p1 -b .rpm
find . -name \*.rpm -delete -print
cp %{SOURCE1} src/Bartlett/Reflect/autoload.php
@@ -208,7 +211,7 @@ install -D -p -m 644 bin/phpreflect.1 %{buildroot}%{_mandir}/man1/phpref
%check
%if %{with_tests}
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit" php71 php72 php73; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} \
@@ -240,6 +243,10 @@ fi
%changelog
+* Tue Feb 25 2020 Remi Collet <remi@remirepo.net> - 4.3.0-3
+- fix compatibility with Symfony 4 using patch from
+ https://github.com/llaville/php-reflect/pull/37
+
* Sun Dec 9 2018 Remi Collet <remi@remirepo.net> - 4.3.0-2
- Fedora: switch to symfony4 only, see #1657328