From f207de38d4ec2acdbbc165e191b2839cd33f5884 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Mon, 6 Jul 2020 15:25:00 +0200
Subject: test build for upcoming 5.3.0 raise dependency on PHP 7.1.3 raise
 dependency on bartlett/php-reflect 4.4 raise dependency on
 bartlett/php-compatinfo-db 2.0 switch to phpunit8

---
 composer.json                                  | 21 ++++----
 php-bartlett-PHP-CompatInfo-5.1.0-autoload.php |  1 -
 php-bartlett-PHP-CompatInfo-5.2.3-rpm.patch    | 75 --------------------------
 php-bartlett-PHP-CompatInfo-5.3.0-rpm.patch    | 62 +++++++++++++++++++++
 php-bartlett-PHP-CompatInfo.spec               | 69 ++++++++++--------------
 5 files changed, 99 insertions(+), 129 deletions(-)
 delete mode 100644 php-bartlett-PHP-CompatInfo-5.2.3-rpm.patch
 create mode 100644 php-bartlett-PHP-CompatInfo-5.3.0-rpm.patch

diff --git a/composer.json b/composer.json
index a8cdab5..21f4b32 100644
--- a/composer.json
+++ b/composer.json
@@ -10,29 +10,22 @@
         "issues": "https://github.com/llaville/php-compat-info/issues"
     },
     "require": {
-        "php": "^5.5|^7.0",
+        "php": "^7.1.3",
         "ext-libxml": "*",
         "ext-pcre": "*",
         "ext-spl": "*",
         "ext-json": "*",
         "ext-pdo": "*",
         "ext-pdo_sqlite": "*",
-        "bartlett/php-reflect": "^4.3",
-        "nikic/php-parser": "^3.1",
-        "bartlett/php-compatinfo-db": "^1.23|^2.0",
+        "bartlett/php-reflect": "4.4.x-dev as 4.4.0",
+        "bartlett/php-compatinfo-db": "^2.0",
         "psr/log": "^1.0"
     },
     "require-dev": {
-        "doctrine/cache": "^1.3",
         "monolog/monolog": "^1.10"
     },
     "suggest": {
-        "doctrine/cache": "Allow caching results, since bartlett/php-reflect 2.2",
-        "monolog/monolog": "Allow logging events with the LogPlugin",
-        "bartlett/monolog-callbackfilterhandler": "Advanced filtering strategies for Monolog",
-        "bartlett/monolog-growlhandler": "Sends notifications to Growl for Monolog",
-        "bartlett/phpunit-loggertestlistener": "Allow logging unit tests to your favorite PSR-3 logger interface",
-        "bartlett/umlwriter": "Allow writing UML class diagrams (Graphviz or PlantUML)"
+        "doctrine/cache": "Allow caching results, since bartlett/php-reflect 2.2"
     },
     "authors": [
         {
@@ -60,6 +53,12 @@
             "Bartlett\\Tests\\CompatInfo\\": "tests/"
         }
     },
+    "repositories": [
+        {
+            "type": "vcs",
+            "url": "https://github.com/llaville/php-reflect"
+        }
+    ],
     "config": {
         "optimize-autoloader": true
     }
diff --git a/php-bartlett-PHP-CompatInfo-5.1.0-autoload.php b/php-bartlett-PHP-CompatInfo-5.1.0-autoload.php
index 61e455b..9d05d9f 100644
--- a/php-bartlett-PHP-CompatInfo-5.1.0-autoload.php
+++ b/php-bartlett-PHP-CompatInfo-5.1.0-autoload.php
@@ -9,7 +9,6 @@ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
 \Fedora\Autoloader\Dependencies::required(array(
     '/usr/share/php/Bartlett/Reflect/autoload.php',
     '/usr/share/php/Bartlett/CompatInfoDb/autoload.php',
-    '/usr/share/php/PhpParser3/autoload.php',
     '/usr/share/php/Psr/Log/autoload.php',
     '/usr/share/php/Doctrine/Common/Cache/autoload.php',
 ));
diff --git a/php-bartlett-PHP-CompatInfo-5.2.3-rpm.patch b/php-bartlett-PHP-CompatInfo-5.2.3-rpm.patch
deleted file mode 100644
index 5b6798e..0000000
--- a/php-bartlett-PHP-CompatInfo-5.2.3-rpm.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-diff -up ./bin/phpcompatinfo.json.dist.rpm ./bin/phpcompatinfo.json.dist
---- ./bin/phpcompatinfo.json.dist.rpm	2018-11-27 22:03:39.000000000 +0100
-+++ ./bin/phpcompatinfo.json.dist	2018-11-28 08:53:47.258278539 +0100
-@@ -6,6 +6,19 @@
-         }
-     ],
-     "plugins": [
-+        {
-+            "name": "Cache",
-+            "class": "Bartlett\\Reflect\\Plugin\\CachePlugin",
-+            "options": {
-+                "adapter": "DoctrineCacheAdapter",
-+                "backend": {
-+                    "class": "Doctrine\\Common\\Cache\\FilesystemCache",
-+                    "args": [
-+                        "%{HOME}/.cache/php-reflect"
-+                    ]
-+                }
-+            }
-+        }
-     ],
-     "analysers" : [
-     ],
-diff -up ./bin/phpcompatinfo.rpm ./bin/phpcompatinfo
---- ./bin/phpcompatinfo.rpm	2018-11-28 08:53:47.258278539 +0100
-+++ ./bin/phpcompatinfo	2018-11-28 08:55:38.807878501 +0100
-@@ -1,42 +1,22 @@
- #!/usr/bin/env php
- <?php
- $appName = 'phpCompatInfo';
-+$vendorDir = '/usr/share/php';
- 
--if (\Phar::running()) {
--    $vendorDir = 'phar://' . strtolower($appName) . '.phar/vendor';
--} else {
--    $baseDir   = dirname(__DIR__);
--    $vendorDir = $baseDir . '/vendor';
--
--    if (!file_exists($vendorDir . '/autoload.php')) {
--        $vendorDir = dirname(dirname($baseDir));
--    }
--
--    if (!getenv("BARTLETTRC")) {
--        putenv("BARTLETTRC=" . strtolower($appName) . '.json');
--    }
-+require_once $vendorDir . '/Bartlett/CompatInfo/autoload.php';
-+
-+if (!getenv("BARTLETTRC")) {
-+     putenv("BARTLETTRC=" . strtolower($appName) . '.json');
- }
--$loader = require_once $vendorDir . '/autoload.php';
--$loader->setUseIncludePath(true);
- 
- if (PHP_SAPI !== 'cli') {
-     return;
- }
- 
--$compatInfoDbV1 = class_exists(Bartlett\CompatInfoDb\Environment::class);
--
--if (\Phar::running() && $compatInfoDbV1) {
--    try {
--        Bartlett\CompatInfoDb\Environment::checkRequirements();
--    } catch (\RuntimeException $e) {
--        die ($e->getMessage());
--    }
--}
--
- use Bartlett\Reflect\Environment;
- use Bartlett\CompatInfo\Console\Application;
- 
- Environment::setScanDir();
- 
--$application = new Application($appName, '5.2.3');
-+$application = new Application($appName, '@package_version@');
- $application->run();
diff --git a/php-bartlett-PHP-CompatInfo-5.3.0-rpm.patch b/php-bartlett-PHP-CompatInfo-5.3.0-rpm.patch
new file mode 100644
index 0000000..74e4a1c
--- /dev/null
+++ b/php-bartlett-PHP-CompatInfo-5.3.0-rpm.patch
@@ -0,0 +1,62 @@
+diff -up ./bin/phpcompatinfo.json.dist.rpm ./bin/phpcompatinfo.json.dist
+--- ./bin/phpcompatinfo.json.dist.rpm	2020-07-06 10:54:23.000000000 +0200
++++ ./bin/phpcompatinfo.json.dist	2020-07-06 15:17:00.620618627 +0200
+@@ -6,6 +6,19 @@
+         }
+     ],
+     "plugins": [
++        {
++            "name": "Cache",
++            "class": "Bartlett\\Reflect\\Plugin\\CachePlugin",
++            "options": {
++                "adapter": "DoctrineCacheAdapter",
++                "backend": {
++                    "class": "Doctrine\\Common\\Cache\\FilesystemCache",
++                    "args": [
++                        "%{HOME}/.cache/php-reflect"
++                    ]
++                }
++            }
++        }
+     ],
+     "analysers" : [
+     ],
+diff -up ./bin/phpcompatinfo.rpm ./bin/phpcompatinfo
+--- ./bin/phpcompatinfo.rpm	2020-07-06 15:17:00.620618627 +0200
++++ ./bin/phpcompatinfo	2020-07-06 15:20:53.977038529 +0200
+@@ -1,23 +1,13 @@
+ #!/usr/bin/env php
+ <?php
+ $appName = 'phpCompatInfo';
++$vendorDir = '/usr/share/php';
+ 
+-if (\Phar::running()) {
+-    $vendorDir = 'phar://' . strtolower($appName) . '.phar/vendor';
+-} else {
+-    $baseDir   = dirname(__DIR__);
+-    $vendorDir = $baseDir . '/vendor';
+-
+-    if (!file_exists($vendorDir . '/autoload.php')) {
+-        $vendorDir = dirname(dirname($baseDir));
+-    }
+-
+-    if (!getenv("BARTLETTRC")) {
+-        putenv("BARTLETTRC=" . strtolower($appName) . '.json');
+-    }
++require_once $vendorDir . '/Bartlett/CompatInfo/autoload.php';
++
++if (!getenv("BARTLETTRC")) {
++     putenv("BARTLETTRC=" . strtolower($appName) . '.json');
+ }
+-$loader = require_once $vendorDir . '/autoload.php';
+-$loader->setUseIncludePath(true);
+ 
+ if (PHP_SAPI !== 'cli') {
+     return;
+@@ -28,5 +18,5 @@ use Bartlett\CompatInfo\Console\Applicat
+ 
+ Environment::setScanDir();
+ 
+-$application = new Application($appName, '5.2.3');
++$application = new Application($appName, '@package_version@');
+ $application->run();
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index fbfd82e..e648e01 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -11,7 +11,7 @@
 %undefine __brp_mangle_shebangs
 
 %{!?php_version:  %global php_version  %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit    ec29a4eea541d3bfdbf00b6ff85700dd926bf6b6
+%global gh_commit    4c4da0eacb582c15dd6a696eb9123786e3b2de25
 %global gh_short     %(c=%{gh_commit}; echo ${c:0:7})
 #global gh_date      20151005
 %global gh_owner     llaville
@@ -26,8 +26,8 @@
 %endif
 
 Name:           php-bartlett-PHP-CompatInfo
-Version:        5.2.3
-%global specrel 1
+Version:        5.3.0
+%global specrel 0
 Release:        %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
 Summary:        Find out version and the extensions required for a piece of code to run
 
@@ -42,52 +42,48 @@ Source1:        fedora-review-check
 Source2:        %{name}-5.1.0-autoload.php
 
 # Autoload and sqlite database path
-Patch0:         %{name}-5.2.3-rpm.patch
+Patch0:         %{name}-5.3.0-rpm.patch
 
 BuildArch:      noarch
-BuildRequires:  php(language) >= 5.5
+BuildRequires:  php(language) >= 7.1.3
 %if %{with_tests}
 # to run test suite
 BuildRequires:  php-pdo_sqlite
 # remirepo:1
 %if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit7
-BuildRequires:  (php-composer(bartlett/php-reflect)       >= 4.3  with php-composer(bartlett/php-reflect)       < 5)
-BuildRequires:  (php-composer(nikic/php-parser)           >= 3.1  with php-composer(nikic/php-parser)           < 4)
-BuildRequires:  (php-composer(bartlett/php-compatinfo-db) >= 1.23 with php-composer(bartlett/php-compatinfo-db) < 3)
+BuildRequires:  (php-composer(bartlett/php-reflect)       >= 4.4  with php-composer(bartlett/php-reflect)       < 5)
+BuildRequires:  (php-composer(bartlett/php-compatinfo-db) >= 2.0  with php-composer(bartlett/php-compatinfo-db) < 3)
 BuildRequires:  (php-composer(psr/log)                    >= 1.0  with php-composer(psr/log)                    < 2)
-Requires:       (php-composer(doctrine/cache)             >= 1.3  with php-composer(doctrine/cache)             < 2)
-# remirepo:12
+BuildRequires:  (php-composer(doctrine/cache)             >= 1.3  with php-composer(doctrine/cache)             < 2)
+# remirepo:10
 %else
-%global phpunit %{_bindir}/phpunit
 BuildRequires:  php-composer(bartlett/php-reflect)        <  5
-BuildRequires:  php-composer(bartlett/php-reflect)        >= 4.2
-BuildRequires:  php-nikic-php-parser3                     >= 3.1
+BuildRequires:  php-composer(bartlett/php-reflect)        >= 4.4
 BuildRequires:  php-composer(bartlett/php-compatinfo-db)  <  3
-BuildRequires:  php-composer(bartlett/php-compatinfo-db)  >= 1.23
+BuildRequires:  php-composer(bartlett/php-compatinfo-db)  >= 2.0
 BuildRequires:  php-composer(psr/log)                     <  2
 BuildRequires:  php-composer(psr/log)                     >= 1.0
 BuildRequires:  php-composer(doctrine/cache)              <  2
 BuildRequires:  php-composer(doctrine/cache)              >= 1.3
 %endif
+%global phpunit %{_bindir}/phpunit8
 BuildRequires:  %{phpunit}
 # For our patch / autoloader
 BuildRequires:  php-composer(fedora/autoloader)
 %endif
 
 # From composer.json, "require"
-#        "php": "^5.5|^7.0",
+#        "php": "^7.1.3",
 #        "ext-libxml": "*",
 #        "ext-pcre": "*",
 #        "ext-spl": "*",
 #        "ext-json": "*",
 #        "ext-pdo": "*",
 #        "ext-pdo_sqlite": "*",
-#        "bartlett/php-reflect": "^4.3",
-#        "nikic/php-parser": "^3.1",
-#        "bartlett/php-compatinfo-db": "^1.23|^2.0",
+#        "bartlett/php-reflect": "4.4.x-dev as 4.4.0",
+#        "bartlett/php-compatinfo-db": "^2.0",
 #        "psr/log": "^1.0"
-Requires:       php(language) >= 5.5
+Requires:       php(language) >= 7.1.3
 Requires:       php-cli
 Requires:       php-json
 Requires:       php-libxml
@@ -97,17 +93,15 @@ Requires:       php-pdo_sqlite
 Requires:       php-spl
 # remirepo:1
 %if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires:       (php-composer(bartlett/php-reflect)       >= 4.3  with php-composer(bartlett/php-reflect)       < 5)
-Requires:       (php-composer(nikic/php-parser)           >= 3.1  with php-composer(nikic/php-parser)           < 4)
-Requires:       (php-composer(bartlett/php-compatinfo-db) >= 1.23 with php-composer(bartlett/php-compatinfo-db) < 3)
+Requires:       (php-composer(bartlett/php-reflect)       >= 4.4  with php-composer(bartlett/php-reflect)       < 5)
+Requires:       (php-composer(bartlett/php-compatinfo-db) >= 2.0  with php-composer(bartlett/php-compatinfo-db) < 3)
 Requires:       (php-composer(psr/log)                    >= 1.0  with php-composer(psr/log)                    < 2)
 # Mandatory for our patch
 Requires:       (php-composer(doctrine/cache)             >= 1.3  with php-composer(doctrine/cache)             < 2)
 # remirepo:12
 %else
 Requires:       php-composer(bartlett/php-reflect)       <  5
-Requires:       php-composer(bartlett/php-reflect)       >= 4.2
-Requires:       php-nikic-php-parser3                    >= 3.1
+Requires:       php-composer(bartlett/php-reflect)       >= 4.4
 Requires:       php-composer(bartlett/php-compatinfo-db) <  3
 Requires:       php-composer(bartlett/php-compatinfo-db) >= 1.23
 Requires:       php-composer(psr/log)                    <  2
@@ -116,22 +110,6 @@ Requires:       php-composer(psr/log)                    >= 1.0
 Requires:       php-composer(doctrine/cache)              <  2
 Requires:       php-composer(doctrine/cache)              >= 1.3
 %endif
-# From composer.json, "require-dev": {
-#        "monolog/monolog": "^1.10",
-# From composer.json, "suggest"
-#        "doctrine/cache": "Allow caching results, since bartlett/php-reflect 2.2",
-#        "monolog/monolog": "Allow logging events with the LogPlugin",
-#        "bartlett/monolog-callbackfilterhandler": "Advanced filtering strategies for Monolog",
-#        "bartlett/monolog-growlhandler": "Sends notifications to Growl for Monolog",
-#        "bartlett/phpunit-loggertestlistener": "Allow logging unit tests to your favorite PSR-3 logger interface",
-#        "bartlett/umlwriter": "Allow writing UML class diagrams (Graphviz or PlantUML)"
-#        "doctrine/cache": "Allow caching results, since bartlett/php-reflect 2.2"
-#        "bartlett/umlwriter": "Allow writing UML class diagrams (Graphviz or PlantUML)"
-# remirepo:1
-%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
-Suggests:       php-composer(monolog/monolog)
-# remirepo:1
-%endif
 # Required by autoloader
 Requires:       php-composer(fedora/autoloader)
 
@@ -187,7 +165,7 @@ ret=0
 for cmdarg in "php %{phpunit}" php72 php73 php74 php80; do
   if which $cmdarg; then
     set $cmdarg
-    $1 ${2:-%{_bindir}/phpunit7} \
+    $1 ${2:-%{_bindir}/phpunit8} \
        --include-path %{buildroot}%{_datadir}/php --verbose || ret=1
   fi
 done
@@ -215,6 +193,13 @@ fi
 
 
 %changelog
+* Mon Jul  6 2020 Remi Collet <remi@remirepo.net> - 5.3.0-0
+- test build for upcoming 5.3.0
+- raise dependency on PHP 7.1.3
+- raise dependency on bartlett/php-reflect 4.4
+- raise dependency on bartlett/php-compatinfo-db 2.0
+- switch to phpunit8
+
 * Wed Apr 29 2020 Remi Collet <remi@remirepo.net> - 5.2.3-1
 - update to 5.2.3
 - drop patch merged upstream
-- 
cgit