summaryrefslogtreecommitdiffstats
path: root/php-bartlett-PHP-CompatInfo-dev.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-bartlett-PHP-CompatInfo-dev.spec')
-rw-r--r--php-bartlett-PHP-CompatInfo-dev.spec34
1 files changed, 23 insertions, 11 deletions
diff --git a/php-bartlett-PHP-CompatInfo-dev.spec b/php-bartlett-PHP-CompatInfo-dev.spec
index 320fa67..1c0a397 100644
--- a/php-bartlett-PHP-CompatInfo-dev.spec
+++ b/php-bartlett-PHP-CompatInfo-dev.spec
@@ -6,15 +6,16 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit bbf5bf1cbc1c7ea481f315a084e5d341c24e283a
-#global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_commit d900ea4b174dd302b36ce0709f46b79d2da27e00
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_date 20150116
%global gh_owner llaville
%global gh_project php-compat-info
Name: php-bartlett-PHP-CompatInfo
-Version: 3.7.2
+Version: 4.0.0
%global specrel 1
-Release: %{?gh_short:0.%{specrel}.git%{gh_short}}%{!?gh_short:%{specrel}}%{?dist}
+Release: %{?gh_short:0.%{specrel}.%{?gh_date}git%{gh_short}}%{!?gh_short:%{specrel}}%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
Group: Development/Libraries
@@ -23,14 +24,15 @@ URL: http://php5.laurent-laville.org/compatinfo/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?gh_short:-%{gh_short}}.tar.gz
# Autoloader for RPM - die composer !
-Patch0: %{name}-rpm.patch
+Patch0: %{name}-4.0.0-rpm.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pdo_sqlite
# to run test suite
BuildRequires: %{_bindir}/phpunit
-BuildRequires: php-composer(bartlett/php-reflect) >= 2.6.2
+BuildRequires: php-composer(bartlett/php-reflect) >= 3.0.0
# From composer.json, "require"
# "php": ">=5.3.0",
@@ -39,25 +41,29 @@ BuildRequires: php-composer(bartlett/php-reflect) >= 2.6.2
# "ext-spl": "*",
# "ext-json": "*",
# "symfony/console": "~2.5",
-# "bartlett/php-reflect": "~2.6",
+# "bartlett/php-reflect": "3.0.*@dev",
Requires: php(language) >= 5.3.0
Requires: php-json
Requires: php-libxml
Requires: php-pcre
+Requires: php-pdo_sqlite
Requires: php-spl
-Requires: php-composer(bartlett/php-reflect) >= 2.6.2
-Requires: php-composer(bartlett/php-reflect) < 3
+Requires: php-composer(bartlett/php-reflect) >= 3.0.0
+Requires: php-composer(bartlett/php-reflect) < 4
Requires: php-composer(symfony/console) >= 2.5
Requires: php-composer(symfony/console) < 3
# From composer.json, "suggest"
# "doctrine/cache": "Allow caching results, since bartlett/php-reflect 2.2"
Requires: php-composer(doctrine/cache)
# Required by autoloader
-Requires: php-composer(phpunit/php-timer)
Requires: php-composer(nikic/php-parser)
+BuildRequires: php-composer(doctrine/collections)
Requires: php-composer(symfony/class-loader)
Requires: php-composer(symfony/event-dispatcher)
Requires: php-composer(symfony/finder)
+BuildRequires: php-composer(symfony/stopwatch)
+BuildRequires: php-composer(symfony/dependency-injection)
+BuildRequires: php-composer(phpdocumentor/reflection-docblock)
Requires: php-composer(seld/jsonlint)
Requires: php-composer(sebastian/version)
Requires: php-composer(justinrainbow/json-schema)
@@ -84,9 +90,12 @@ Documentation: http://php5.laurent-laville.org/compatinfo/manual/current/en/
sed -e 's/@package_version@/%{version}/' \
-i $(find src -name \*.php)
+#rm data/compatinfo.sqlite
+
%build
-# Nothing
+: Generate the references database
+#{_bindir}/php data/handleDB.php db:init
%install
@@ -127,6 +136,9 @@ fi
%changelog
+* Mon Jan 19 2015 Remi Collet <remi@fedoraproject.org> - 4.0.0-0.1.20150116gitd900ea4
+- 4.0.0 snapshot
+
* Mon Jan 5 2015 Remi Collet <remi@fedoraproject.org> - 3.7.2-1
- Update to 3.7.2
- open https://github.com/llaville/php-compat-info/pull/157