summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json7
-rw-r--r--installed.json209
-rw-r--r--php-bartlett-PHP-CompatInfo.spec37
3 files changed, 129 insertions, 124 deletions
diff --git a/composer.json b/composer.json
index 474d0a3..5aee5c7 100644
--- a/composer.json
+++ b/composer.json
@@ -4,10 +4,10 @@
"keywords": ["compatibility", "version"],
"type": "library",
"license": "BSD-3-Clause",
- "homepage": "https://github.com/llaville/php-compatinfo",
+ "homepage": "http://php5.laurent-laville.org/compatinfo/",
"support": {
- "source": "https://github.com/llaville/php-compatinfo",
- "issues": "https://github.com/llaville/php-compatinfo/issues"
+ "source": "https://github.com/llaville/php-compat-info",
+ "issues": "https://github.com/llaville/php-compat-info/issues"
},
"require": {
"php": "^7.4|^8.0",
@@ -36,6 +36,7 @@
"authors": [
{
"name": "Laurent Laville",
+ "email": "pear@laurent-laville.org",
"homepage": "https://github.com/llaville",
"role": "Lead"
},
diff --git a/installed.json b/installed.json
index 6332193..fffb6ae 100644
--- a/installed.json
+++ b/installed.json
@@ -2,23 +2,23 @@
"packages": [
{
"name": "bartlett/php-compatinfo-db",
- "version": "3.15.0",
- "version_normalized": "3.15.0.0",
+ "version": "3.16.1",
+ "version_normalized": "3.16.1.0",
"source": {
"type": "git",
"url": "https://github.com/llaville/php-compatinfo-db.git",
- "reference": "65080937bf2d2d7606230db0d847eae5be8999b8"
+ "reference": "c2b0356a6240b52140d940fe421517ae8b7cd539"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/llaville/php-compatinfo-db/zipball/65080937bf2d2d7606230db0d847eae5be8999b8",
- "reference": "65080937bf2d2d7606230db0d847eae5be8999b8",
+ "url": "https://api.github.com/repos/llaville/php-compatinfo-db/zipball/c2b0356a6240b52140d940fe421517ae8b7cd539",
+ "reference": "c2b0356a6240b52140d940fe421517ae8b7cd539",
"shasum": ""
},
"require": {
"composer/package-versions-deprecated": "^1.8",
"composer/semver": "^1.0|^2.0|^3.0",
- "doctrine/dbal": "^2.13.1||^3.1.1",
+ "doctrine/dbal": "^2.13.1|^3.1.4",
"doctrine/orm": "^2.7",
"ext-json": "*",
"ext-pcre": "*",
@@ -42,7 +42,7 @@
"psr/log": "^1.0",
"symfony/phpunit-bridge": "^5.1"
},
- "time": "2021-12-01T15:15:19+00:00",
+ "time": "2021-12-19T14:38:11+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -557,17 +557,17 @@
},
{
"name": "doctrine/common",
- "version": "3.2.0",
- "version_normalized": "3.2.0.0",
+ "version": "3.2.1",
+ "version_normalized": "3.2.1.0",
"source": {
"type": "git",
"url": "https://github.com/doctrine/common.git",
- "reference": "6d970a11479275300b5144e9373ce5feacfa9b91"
+ "reference": "e927fc2410c8723d053b8032e591cdff76587cdb"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/doctrine/common/zipball/6d970a11479275300b5144e9373ce5feacfa9b91",
- "reference": "6d970a11479275300b5144e9373ce5feacfa9b91",
+ "url": "https://api.github.com/repos/doctrine/common/zipball/e927fc2410c8723d053b8032e591cdff76587cdb",
+ "reference": "e927fc2410c8723d053b8032e591cdff76587cdb",
"shasum": ""
},
"require": {
@@ -575,15 +575,15 @@
"php": "^7.1 || ^8.0"
},
"require-dev": {
- "doctrine/coding-standard": "^6.0 || ^8.0",
- "phpstan/phpstan": "^0.12",
- "phpstan/phpstan-phpunit": "^0.12",
+ "doctrine/coding-standard": "^9.0",
+ "phpstan/phpstan": "^1.2.0",
+ "phpstan/phpstan-phpunit": "^1",
"phpunit/phpunit": "^7.5.20 || ^8.5 || ^9.0",
"squizlabs/php_codesniffer": "^3.0",
"symfony/phpunit-bridge": "^4.0.5",
"vimeo/psalm": "^4.4"
},
- "time": "2021-10-19T06:47:22+00:00",
+ "time": "2021-12-26T22:39:45+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -630,7 +630,7 @@
],
"support": {
"issues": "https://github.com/doctrine/common/issues",
- "source": "https://github.com/doctrine/common/tree/3.2.0"
+ "source": "https://github.com/doctrine/common/tree/3.2.1"
},
"funding": [
{
@@ -1156,17 +1156,17 @@
},
{
"name": "doctrine/orm",
- "version": "2.10.3",
- "version_normalized": "2.10.3.0",
+ "version": "2.10.4",
+ "version_normalized": "2.10.4.0",
"source": {
"type": "git",
"url": "https://github.com/doctrine/orm.git",
- "reference": "7b242753466508e1dd10f67c1baee95785f845c1"
+ "reference": "cccb2e2fdfed2969afb3d65c5ea82bafdefbe1a7"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/doctrine/orm/zipball/7b242753466508e1dd10f67c1baee95785f845c1",
- "reference": "7b242753466508e1dd10f67c1baee95785f845c1",
+ "url": "https://api.github.com/repos/doctrine/orm/zipball/cccb2e2fdfed2969afb3d65c5ea82bafdefbe1a7",
+ "reference": "cccb2e2fdfed2969afb3d65c5ea82bafdefbe1a7",
"shasum": ""
},
"require": {
@@ -1198,16 +1198,16 @@
"phpbench/phpbench": "^0.16.10 || ^1.0",
"phpstan/phpstan": "1.2.0",
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.4",
- "squizlabs/php_codesniffer": "3.6.1",
+ "squizlabs/php_codesniffer": "3.6.2",
"symfony/cache": "^4.4 || ^5.2",
"symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0",
- "vimeo/psalm": "4.13.1"
+ "vimeo/psalm": "4.15.0"
},
"suggest": {
"symfony/cache": "Provides cache support for Setup Tool with doctrine/cache 2.0",
"symfony/yaml": "If you want to use YAML Metadata Mapping Driver"
},
- "time": "2021-12-03T12:27:05+00:00",
+ "time": "2021-12-20T21:23:47+00:00",
"bin": [
"bin/doctrine"
],
@@ -1252,7 +1252,7 @@
],
"support": {
"issues": "https://github.com/doctrine/orm/issues",
- "source": "https://github.com/doctrine/orm/tree/2.10.3"
+ "source": "https://github.com/doctrine/orm/tree/2.10.4"
},
"install-path": "../doctrine/orm"
},
@@ -1871,17 +1871,17 @@
},
{
"name": "symfony/cache",
- "version": "v5.4.0",
- "version_normalized": "5.4.0.0",
+ "version": "v5.4.2",
+ "version_normalized": "5.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/cache.git",
- "reference": "d97d6d7f46cb69968f094e329abd987d5ee17c79"
+ "reference": "8aad4b69a10c5c51ab54672e78995860f5e447ec"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/cache/zipball/d97d6d7f46cb69968f094e329abd987d5ee17c79",
- "reference": "d97d6d7f46cb69968f094e329abd987d5ee17c79",
+ "url": "https://api.github.com/repos/symfony/cache/zipball/8aad4b69a10c5c51ab54672e78995860f5e447ec",
+ "reference": "8aad4b69a10c5c51ab54672e78995860f5e447ec",
"shasum": ""
},
"require": {
@@ -1919,7 +1919,7 @@
"symfony/messenger": "^4.4|^5.0|^6.0",
"symfony/var-dumper": "^4.4|^5.0|^6.0"
},
- "time": "2021-11-23T18:51:45+00:00",
+ "time": "2021-12-28T17:15:56+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1951,7 +1951,7 @@
"psr6"
],
"support": {
- "source": "https://github.com/symfony/cache/tree/v5.4.0"
+ "source": "https://github.com/symfony/cache/tree/v5.4.2"
},
"funding": [
{
@@ -2053,17 +2053,17 @@
},
{
"name": "symfony/config",
- "version": "v5.4.0",
- "version_normalized": "5.4.0.0",
+ "version": "v5.4.2",
+ "version_normalized": "5.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/config.git",
- "reference": "e39cf688c80fd79ab0a6a2d05a9facac9b2d534b"
+ "reference": "2e082dae50da563c639119b7b52347a2a3db4ba5"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/config/zipball/e39cf688c80fd79ab0a6a2d05a9facac9b2d534b",
- "reference": "e39cf688c80fd79ab0a6a2d05a9facac9b2d534b",
+ "url": "https://api.github.com/repos/symfony/config/zipball/2e082dae50da563c639119b7b52347a2a3db4ba5",
+ "reference": "2e082dae50da563c639119b7b52347a2a3db4ba5",
"shasum": ""
},
"require": {
@@ -2087,7 +2087,7 @@
"suggest": {
"symfony/yaml": "To use the yaml reference dumper"
},
- "time": "2021-11-28T15:25:38+00:00",
+ "time": "2021-12-15T11:06:13+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2115,7 +2115,7 @@
"description": "Helps you find, load, combine, autofill and validate configuration values of any kind",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/config/tree/v5.4.0"
+ "source": "https://github.com/symfony/config/tree/v5.4.2"
},
"funding": [
{
@@ -2135,17 +2135,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.1",
- "version_normalized": "5.4.1.0",
+ "version": "v5.4.2",
+ "version_normalized": "5.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "9130e1a0fc93cb0faadca4ee917171bd2ca9e5f4"
+ "reference": "a2c6b7ced2eb7799a35375fb9022519282b5405e"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/9130e1a0fc93cb0faadca4ee917171bd2ca9e5f4",
- "reference": "9130e1a0fc93cb0faadca4ee917171bd2ca9e5f4",
+ "url": "https://api.github.com/repos/symfony/console/zipball/a2c6b7ced2eb7799a35375fb9022519282b5405e",
+ "reference": "a2c6b7ced2eb7799a35375fb9022519282b5405e",
"shasum": ""
},
"require": {
@@ -2183,7 +2183,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2021-12-09T11:22:43+00:00",
+ "time": "2021-12-20T16:11:12+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2217,7 +2217,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.1"
+ "source": "https://github.com/symfony/console/tree/v5.4.2"
},
"funding": [
{
@@ -2237,17 +2237,17 @@
},
{
"name": "symfony/dependency-injection",
- "version": "v5.4.1",
- "version_normalized": "5.4.1.0",
+ "version": "v5.4.2",
+ "version_normalized": "5.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/dependency-injection.git",
- "reference": "9bd1ef389a2fe05fea7306b6155403e8a960d73d"
+ "reference": "ba94559be9738d77cd29e24b5d81cf3b89b7d628"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/dependency-injection/zipball/9bd1ef389a2fe05fea7306b6155403e8a960d73d",
- "reference": "9bd1ef389a2fe05fea7306b6155403e8a960d73d",
+ "url": "https://api.github.com/repos/symfony/dependency-injection/zipball/ba94559be9738d77cd29e24b5d81cf3b89b7d628",
+ "reference": "ba94559be9738d77cd29e24b5d81cf3b89b7d628",
"shasum": ""
},
"require": {
@@ -2281,7 +2281,7 @@
"symfony/proxy-manager-bridge": "Generate service proxies to lazy load them",
"symfony/yaml": ""
},
- "time": "2021-12-01T16:25:34+00:00",
+ "time": "2021-12-29T10:10:35+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2309,7 +2309,7 @@
"description": "Allows you to standardize and centralize the way objects are constructed in your application",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/dependency-injection/tree/v5.4.1"
+ "source": "https://github.com/symfony/dependency-injection/tree/v5.4.2"
},
"funding": [
{
@@ -2399,17 +2399,17 @@
},
{
"name": "symfony/doctrine-messenger",
- "version": "v6.0.1",
- "version_normalized": "6.0.1.0",
+ "version": "v6.0.2",
+ "version_normalized": "6.0.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/doctrine-messenger.git",
- "reference": "01e283ef81c5115e383163c334abffd7cc4adbde"
+ "reference": "744b67fc92afc080490b7e07fc084c285fe7af95"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/doctrine-messenger/zipball/01e283ef81c5115e383163c334abffd7cc4adbde",
- "reference": "01e283ef81c5115e383163c334abffd7cc4adbde",
+ "url": "https://api.github.com/repos/symfony/doctrine-messenger/zipball/744b67fc92afc080490b7e07fc084c285fe7af95",
+ "reference": "744b67fc92afc080490b7e07fc084c285fe7af95",
"shasum": ""
},
"require": {
@@ -2426,7 +2426,7 @@
"symfony/property-access": "^5.4|^6.0",
"symfony/serializer": "^5.4|^6.0"
},
- "time": "2021-12-08T15:13:44+00:00",
+ "time": "2021-12-29T10:14:09+00:00",
"type": "symfony-messenger-bridge",
"installation-source": "dist",
"autoload": {
@@ -2454,7 +2454,7 @@
"description": "Symfony Doctrine Messenger Bridge",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/doctrine-messenger/tree/v6.0.1"
+ "source": "https://github.com/symfony/doctrine-messenger/tree/v6.0.2"
},
"funding": [
{
@@ -2710,17 +2710,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.0",
- "version_normalized": "5.4.0.0",
+ "version": "v5.4.2",
+ "version_normalized": "5.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "d2f29dac98e96a98be467627bd49c2efb1bc2590"
+ "reference": "e77046c252be48c48a40816187ed527703c8f76c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/d2f29dac98e96a98be467627bd49c2efb1bc2590",
- "reference": "d2f29dac98e96a98be467627bd49c2efb1bc2590",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/e77046c252be48c48a40816187ed527703c8f76c",
+ "reference": "e77046c252be48c48a40816187ed527703c8f76c",
"shasum": ""
},
"require": {
@@ -2728,7 +2728,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2021-11-28T15:25:38+00:00",
+ "time": "2021-12-15T11:06:13+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2756,7 +2756,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.0"
+ "source": "https://github.com/symfony/finder/tree/v5.4.2"
},
"funding": [
{
@@ -2776,17 +2776,17 @@
},
{
"name": "symfony/messenger",
- "version": "v5.4.0",
- "version_normalized": "5.4.0.0",
+ "version": "v5.4.2",
+ "version_normalized": "5.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/messenger.git",
- "reference": "2b4b5acf641656ea0a3af35c4fa2289a66dab45d"
+ "reference": "c35f9937b3bde678377ec0d5879760ad007cb500"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/messenger/zipball/2b4b5acf641656ea0a3af35c4fa2289a66dab45d",
- "reference": "2b4b5acf641656ea0a3af35c4fa2289a66dab45d",
+ "url": "https://api.github.com/repos/symfony/messenger/zipball/c35f9937b3bde678377ec0d5879760ad007cb500",
+ "reference": "c35f9937b3bde678377ec0d5879760ad007cb500",
"shasum": ""
},
"require": {
@@ -2821,7 +2821,7 @@
"suggest": {
"enqueue/messenger-adapter": "For using the php-enqueue library as a transport."
},
- "time": "2021-11-23T15:22:30+00:00",
+ "time": "2021-12-16T21:52:00+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2849,7 +2849,7 @@
"description": "Helps applications send and receive messages to/from other applications or via message queues",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/messenger/tree/v5.4.0"
+ "source": "https://github.com/symfony/messenger/tree/v5.4.2"
},
"funding": [
{
@@ -3534,24 +3534,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.0",
- "version_normalized": "5.4.0.0",
+ "version": "v5.4.2",
+ "version_normalized": "5.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "5be20b3830f726e019162b26223110c8f47cf274"
+ "reference": "2b3ba8722c4aaf3e88011be5e7f48710088fb5e4"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/5be20b3830f726e019162b26223110c8f47cf274",
- "reference": "5be20b3830f726e019162b26223110c8f47cf274",
+ "url": "https://api.github.com/repos/symfony/process/zipball/2b3ba8722c4aaf3e88011be5e7f48710088fb5e4",
+ "reference": "2b3ba8722c4aaf3e88011be5e7f48710088fb5e4",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2021-11-28T15:25:38+00:00",
+ "time": "2021-12-27T21:01:00+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -3579,7 +3579,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.0"
+ "source": "https://github.com/symfony/process/tree/v5.4.2"
},
"funding": [
{
@@ -3599,17 +3599,17 @@
},
{
"name": "symfony/redis-messenger",
- "version": "v6.0.1",
- "version_normalized": "6.0.1.0",
+ "version": "v6.0.2",
+ "version_normalized": "6.0.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/redis-messenger.git",
- "reference": "418df4c4532b5855cd006f965539ed8d33408f23"
+ "reference": "30851275301c6e3689e2d06da7a8557e9f76155b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/redis-messenger/zipball/418df4c4532b5855cd006f965539ed8d33408f23",
- "reference": "418df4c4532b5855cd006f965539ed8d33408f23",
+ "url": "https://api.github.com/repos/symfony/redis-messenger/zipball/30851275301c6e3689e2d06da7a8557e9f76155b",
+ "reference": "30851275301c6e3689e2d06da7a8557e9f76155b",
"shasum": ""
},
"require": {
@@ -3621,7 +3621,7 @@
"symfony/property-access": "^5.4|^6.0",
"symfony/serializer": "^5.4|^6.0"
},
- "time": "2021-12-08T15:13:44+00:00",
+ "time": "2021-12-28T17:22:37+00:00",
"type": "symfony-messenger-bridge",
"installation-source": "dist",
"autoload": {
@@ -3649,7 +3649,7 @@
"description": "Symfony Redis extension Messenger Bridge",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/redis-messenger/tree/v6.0.1"
+ "source": "https://github.com/symfony/redis-messenger/tree/v6.0.2"
},
"funding": [
{
@@ -3738,17 +3738,17 @@
},
{
"name": "symfony/serializer",
- "version": "v5.4.0",
- "version_normalized": "5.4.0.0",
+ "version": "v5.4.2",
+ "version_normalized": "5.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/serializer.git",
- "reference": "66942cf6bf412ca72c39353596f4d37ee0f9059b"
+ "reference": "2dba9731463e0bb4fa9568ce67887ed6fa08e9bc"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/serializer/zipball/66942cf6bf412ca72c39353596f4d37ee0f9059b",
- "reference": "66942cf6bf412ca72c39353596f4d37ee0f9059b",
+ "url": "https://api.github.com/repos/symfony/serializer/zipball/2dba9731463e0bb4fa9568ce67887ed6fa08e9bc",
+ "reference": "2dba9731463e0bb4fa9568ce67887ed6fa08e9bc",
"shasum": ""
},
"require": {
@@ -3764,6 +3764,7 @@
"symfony/dependency-injection": "<4.4",
"symfony/property-access": "<5.4",
"symfony/property-info": "<5.3",
+ "symfony/uid": "<5.3",
"symfony/yaml": "<4.4"
},
"require-dev": {
@@ -3780,7 +3781,7 @@
"symfony/mime": "^4.4|^5.0|^6.0",
"symfony/property-access": "^5.4|^6.0",
"symfony/property-info": "^5.3|^6.0",
- "symfony/uid": "^5.1|^6.0",
+ "symfony/uid": "^5.3|^6.0",
"symfony/validator": "^4.4|^5.0|^6.0",
"symfony/var-dumper": "^4.4|^5.0|^6.0",
"symfony/var-exporter": "^4.4|^5.0|^6.0",
@@ -3795,7 +3796,7 @@
"symfony/var-exporter": "For using the metadata compiler.",
"symfony/yaml": "For using the default YAML mapping loader."
},
- "time": "2021-11-28T15:25:38+00:00",
+ "time": "2021-12-25T19:17:31+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -3823,7 +3824,7 @@
"description": "Handles serializing and deserializing data structures, including object graphs, into array structures or other formats like XML and JSON.",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/serializer/tree/v5.4.0"
+ "source": "https://github.com/symfony/serializer/tree/v5.4.2"
},
"funding": [
{
@@ -3993,17 +3994,17 @@
},
{
"name": "symfony/string",
- "version": "v6.0.1",
- "version_normalized": "6.0.1.0",
+ "version": "v6.0.2",
+ "version_normalized": "6.0.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "0cfed595758ec6e0a25591bdc8ca733c1896af32"
+ "reference": "bae261d0c3ac38a1f802b4dfed42094296100631"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/0cfed595758ec6e0a25591bdc8ca733c1896af32",
- "reference": "0cfed595758ec6e0a25591bdc8ca733c1896af32",
+ "url": "https://api.github.com/repos/symfony/string/zipball/bae261d0c3ac38a1f802b4dfed42094296100631",
+ "reference": "bae261d0c3ac38a1f802b4dfed42094296100631",
"shasum": ""
},
"require": {
@@ -4022,7 +4023,7 @@
"symfony/translation-contracts": "^2.0|^3.0",
"symfony/var-exporter": "^5.4|^6.0"
},
- "time": "2021-12-08T15:13:44+00:00",
+ "time": "2021-12-16T22:13:01+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -4061,7 +4062,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v6.0.1"
+ "source": "https://github.com/symfony/string/tree/v6.0.2"
},
"funding": [
{
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index d383064..e64ff3f 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-bartlett-PHP-CompatInfo
#
-# Copyright (c) 2011-2021 Remi Collet
+# Copyright (c) 2011-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -11,13 +11,13 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit 5978aea8eb937157c72b8217dcaac148e6f5ae7d
+%global gh_commit 4beab5e0a5c27fb81a3ba0b262b3ed85a19500be
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
%global gh_project php-compatinfo
-%global upstream_version 6.0.1
+%global upstream_version 6.0.2
#global upstream_prever RC1
Name: php-bartlett-PHP-CompatInfo
@@ -64,21 +64,21 @@ Requires: php-spl
Requires: php-xmlreader
# Bundled libraries
-Provides: bundled(php-bartlett-php-compatinfo-db) = 3.15.0
+Provides: bundled(php-bartlett-php-compatinfo-db) = 3.16.1
Provides: bundled(php-brick-math) = 0.9.3
Provides: bundled(php-composer-package-versions-deprecated) = 1.11.99.4
Provides: bundled(php-composer-semver) = 3.2.6
Provides: bundled(php-doctrine-annotations) = 1.13.2
Provides: bundled(php-doctrine-cache) = 2.1.1
Provides: bundled(php-doctrine-collections) = 1.6.8
-Provides: bundled(php-doctrine-common) = 3.2.0
+Provides: bundled(php-doctrine-common) = 3.2.1
Provides: bundled(php-doctrine-dbal) = 3.2.0
Provides: bundled(php-doctrine-deprecations) = v0.5.3
Provides: bundled(php-doctrine-event-manager) = 1.1.1
Provides: bundled(php-doctrine-inflector) = 2.0.4
Provides: bundled(php-doctrine-instantiator) = 1.4.0
Provides: bundled(php-doctrine-lexer) = 1.2.1
-Provides: bundled(php-doctrine-orm) = 2.10.3
+Provides: bundled(php-doctrine-orm) = 2.10.4
Provides: bundled(php-doctrine-persistence) = 2.2.3
Provides: bundled(php-nikic-php-parser) = v4.13.2
Provides: bundled(php-psr-cache) = 2.0.0
@@ -88,18 +88,18 @@ Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-ramsey-collection) = 1.2.2
Provides: bundled(php-ramsey-uuid) = 4.2.3
Provides: bundled(php-symfony-amqp-messenger) = v5.4.0
-Provides: bundled(php-symfony-cache) = v5.4.0
+Provides: bundled(php-symfony-cache) = v5.4.2
Provides: bundled(php-symfony-cache-contracts) = v2.5.0
-Provides: bundled(php-symfony-config) = v5.4.0
-Provides: bundled(php-symfony-console) = v5.4.1
-Provides: bundled(php-symfony-dependency-injection) = v5.4.1
+Provides: bundled(php-symfony-config) = v5.4.2
+Provides: bundled(php-symfony-console) = v5.4.2
+Provides: bundled(php-symfony-dependency-injection) = v5.4.2
Provides: bundled(php-symfony-deprecation-contracts) = v3.0.0
-Provides: bundled(php-symfony-doctrine-messenger) = v6.0.1
+Provides: bundled(php-symfony-doctrine-messenger) = v6.0.2
Provides: bundled(php-symfony-event-dispatcher) = v5.4.0
Provides: bundled(php-symfony-event-dispatcher-contracts) = v3.0.0
Provides: bundled(php-symfony-filesystem) = v6.0.0
-Provides: bundled(php-symfony-finder) = v5.4.0
-Provides: bundled(php-symfony-messenger) = v5.4.0
+Provides: bundled(php-symfony-finder) = v5.4.2
+Provides: bundled(php-symfony-messenger) = v5.4.2
Provides: bundled(php-symfony-polyfill-ctype) = v1.23.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.23.1
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.23.0
@@ -108,13 +108,13 @@ Provides: bundled(php-symfony-polyfill-php72) = v1.23.0
Provides: bundled(php-symfony-polyfill-php73) = v1.23.0
Provides: bundled(php-symfony-polyfill-php80) = v1.23.1
Provides: bundled(php-symfony-polyfill-php81) = v1.23.0
-Provides: bundled(php-symfony-process) = v5.4.0
-Provides: bundled(php-symfony-redis-messenger) = v6.0.1
+Provides: bundled(php-symfony-process) = v5.4.2
+Provides: bundled(php-symfony-redis-messenger) = v6.0.2
Provides: bundled(php-symfony-requirements-checker) = v2.0.1
-Provides: bundled(php-symfony-serializer) = v5.4.0
+Provides: bundled(php-symfony-serializer) = v5.4.2
Provides: bundled(php-symfony-service-contracts) = v2.4.1
Provides: bundled(php-symfony-stopwatch) = v5.4.0
-Provides: bundled(php-symfony-string) = v6.0.1
+Provides: bundled(php-symfony-string) = v6.0.2
Provides: bundled(php-symfony-var-exporter) = v6.0.0
Provides: phpcompatinfo = %{version}
@@ -180,6 +180,9 @@ install -D -p -m 755 %{SOURCE1} %{buildroot}%{_datadir}/%{name}/fedora-
%changelog
+* Mon Jan 3 2022 Remi Collet <remi@remirepo.net> - 6.0.2-1
+- update to 6.0.2
+
* Mon Dec 13 2021 Remi Collet <remi@remirepo.net> - 6.0.1-1
- update to 6.0.1