summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-bartlett-PHP-CompatInfo.spec15
1 files changed, 10 insertions, 5 deletions
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 94c7d3c..5fdf1a8 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -11,7 +11,7 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit 2aed4fbbed13290c160f24ca1befc58ddd42cda8
+%global gh_commit 5b58fb55f2a759f6c134d1649d1e1df1b8cd5cf2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
@@ -27,7 +27,7 @@
Name: php-bartlett-PHP-CompatInfo
Version: 5.3.0
-%global specrel 0
+%global specrel 1
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -137,9 +137,11 @@ cp %{SOURCE2} src/Bartlett/CompatInfo/autoload.php
# Cleanup patched files
find src -name \*rpm -delete -print
-# Set package version
-sed -e 's/@package_version@/%{version}%{?prever}/' \
- -i $(find src -name \*.php) bin/phpcompatinfo
+# Check package version
+FILE=src/Bartlett/CompatInfo/Console/Application.php
+grep " VERSION" $FILE
+sed -e '/VERSION/s/5.3.x-dev/%{version}/' -i $FILE
+grep %{version} $FILE
%build
@@ -195,6 +197,9 @@ fi
%changelog
+* Wed Jul 8 2020 Remi Collet <remi@remirepo.net> - 5.3.0-1
+- update to 5.3.0
+
* Mon Jul 6 2020 Remi Collet <remi@remirepo.net> - 5.3.0-0
- test build for upcoming 5.3.0
- raise dependency on PHP 7.1.3