summaryrefslogtreecommitdiffstats
path: root/php-bartlett-PHP-CompatInfo.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-18 11:43:21 +0100
committerRemi Collet <remi@php.net>2022-01-18 11:43:21 +0100
commita596a217479c44aa5c2f0d43b98ec55b52284ffc (patch)
treeb88e67c57b6f332467a9e26fba2a420ed5c56a15 /php-bartlett-PHP-CompatInfo.spec
parenta41f6d64a524fd237b211e678cbabad21a8fdb39 (diff)
update to 6.1.1
update bundled bartlett/php-compatinfo-db 3.17.1
Diffstat (limited to 'php-bartlett-PHP-CompatInfo.spec')
-rw-r--r--php-bartlett-PHP-CompatInfo.spec49
1 files changed, 31 insertions, 18 deletions
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 11b1349..75ed732 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -11,13 +11,13 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit e40303a34d7657a92c82cc7cc61c50b5a1f095bd
+%global gh_commit 553a953cf4e823700aff8660a4cf6d354fc4aafd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
%global gh_project php-compatinfo
-%global upstream_version 6.1.0
+%global upstream_version 6.1.1
#global upstream_prever RC1
Name: php-bartlett-PHP-CompatInfo
@@ -39,16 +39,7 @@ Patch0: %{name}-6.0.0-rpm.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.4
BuildRequires: php-cli
-BuildRequires: php-dom
BuildRequires: php-json
-BuildRequires: php-libxml
-BuildRequires: php-pcre
-BuildRequires: php-phar
-BuildRequires: php-pdo
-BuildRequires: php-pdo_sqlite
-BuildRequires: php-simplexml
-BuildRequires: php-spl
-BuildRequires: php-xmlreader
Requires: php(language) >= 7.4
Requires: php-cli
@@ -64,23 +55,22 @@ Requires: php-spl
Requires: php-xmlreader
# Bundled libraries
-Provides: bundled(php-bartlett-php-compatinfo-db) = 3.17.0
+Provides: bundled(php-bartlett-php-compatinfo-db) = 3.17.1
Provides: bundled(php-bartlett-sarif-php-sdk) = 1.0.1
Provides: bundled(php-brick-math) = 0.9.3
-Provides: bundled(php-composer-package-versions-deprecated) = 1.11.99.4
Provides: bundled(php-composer-semver) = 3.2.7
Provides: bundled(php-doctrine-annotations) = 1.13.2
Provides: bundled(php-doctrine-cache) = 2.1.1
Provides: bundled(php-doctrine-collections) = 1.6.8
Provides: bundled(php-doctrine-common) = 3.2.1
-Provides: bundled(php-doctrine-dbal) = 3.2.1
+Provides: bundled(php-doctrine-dbal) = 3.3.0
Provides: bundled(php-doctrine-deprecations) = v0.5.3
Provides: bundled(php-doctrine-event-manager) = 1.1.1
Provides: bundled(php-doctrine-inflector) = 2.0.4
Provides: bundled(php-doctrine-instantiator) = 1.4.0
-Provides: bundled(php-doctrine-lexer) = 1.2.1
-Provides: bundled(php-doctrine-orm) = 2.10.4
-Provides: bundled(php-doctrine-persistence) = 2.2.3
+Provides: bundled(php-doctrine-lexer) = 1.2.2
+Provides: bundled(php-doctrine-orm) = 2.11.0
+Provides: bundled(php-doctrine-persistence) = 2.3.0
Provides: bundled(php-nikic-php-parser) = v4.13.2
Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
@@ -133,7 +123,7 @@ show content of dictionary references.
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
-# Gather all license files and cleanup tests
+: Gather all license files and cleanup tests
mv vendor/composer/LICENSE composer_LICENSE
for vendor in $(ls vendor)
do
@@ -145,6 +135,23 @@ do
done
rm -r tests
+: List bundled libraries and Licenses
+php -r '
+ $pkgs = file_get_contents("vendor/composer/installed.json");
+ $pkgs = json_decode($pkgs, true);
+ if (!is_array($pkgs) || !isset($pkgs["packages"])) {
+ echo "cant decode json file\n";
+ exit(3);
+ }
+ $lic = [];
+ foreach($pkgs["packages"] as $pkg) {
+ printf("Provides: bundled(php-%s) = %s\n", str_replace(["/", "_"], ["-", "-"], $pkg["name"]), $pkg["version"]);
+ $lic = array_merge($lic, $pkg["license"]);
+ }
+ sort($lic);
+ printf("\nLicense: %s\n", implode(" and ", array_unique($lic)));'
+
+
%build
# Nothing
@@ -173,12 +180,18 @@ install -D -p -m 755 %{SOURCE1} %{buildroot}%{_datadir}/%{name}/fedora-
%{!?_licensedir:%global license %%doc}
%license *LICENSE
%doc README.*
+%doc composer.json
+%doc vendor/composer/installed.json
%{_bindir}/phpcompatinfo
%{_datadir}/%{name}
%{_mandir}/man1/phpcompatinfo.1*
%changelog
+* Tue Jan 18 2022 Remi Collet <remi@remirepo.net> - 6.1.1-1
+- update to 6.1.1
+- update bundled bartlett/php-compatinfo-db 3.17.1
+
* Thu Jan 6 2022 Remi Collet <remi@remirepo.net> - 6.1.0-1
- update to 6.1.0