summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-07-25 08:05:48 +0200
committerRemi Collet <fedora@famillecollet.com>2013-07-25 08:05:48 +0200
commitfcc080258424a3bc66e74462d0af7a5a919f6c15 (patch)
treee817843911bb92af154948cfd68eaf01bd7d4df9
parentb10a046a917f9bdc8e7ed4cb777bb9808e6a8ef2 (diff)
php-bartlett-PHP-CompatInfo: 2.20.0
-rw-r--r--PHP_CompatInfo-git.patch131
-rw-r--r--PHP_CompatInfo-intl.patch83
-rw-r--r--php-bartlett-PHP-CompatInfo.spec16
3 files changed, 140 insertions, 90 deletions
diff --git a/PHP_CompatInfo-git.patch b/PHP_CompatInfo-git.patch
new file mode 100644
index 0000000..0e729b0
--- /dev/null
+++ b/PHP_CompatInfo-git.patch
@@ -0,0 +1,131 @@
+From 129dc0cf6c7173bd94a962437f265d37f6174ec1 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Thu, 25 Jul 2013 07:42:36 +0200
+Subject: [PATCH 1/3] fix mongo ref for new constant
+
+---
+ PHP/CompatInfo/Reference/mongo.php | 25 +++++++++++++++++++++++++
+ 1 file changed, 25 insertions(+)
+
+diff --git a/PHP/CompatInfo/Reference/mongo.php b/PHP/CompatInfo/Reference/mongo.php
+index de7706a..aee9ec4 100644
+--- a/PHP/CompatInfo/Reference/mongo.php
++++ b/PHP/CompatInfo/Reference/mongo.php
+@@ -195,4 +195,29 @@ class PHP_CompatInfo_Reference_Mongo
+ return $functions;
+ }
+
++ /**
++ * Gets informations about constants
++ *
++ * @param string $extension (optional) NULL for PHP version,
++ * TRUE if extension version
++ * @param string $version (optional) php or extension version
++ * @param string $condition (optional) particular relationship with $version
++ * Same operator values as used by version_compare
++ *
++ * @return array
++ */
++ public function getConstants($extension = null, $version = null, $condition = null)
++ {
++ $this->setFilter(func_get_args());
++
++ $constants = array();
++
++ $release = '1.4.2'; // 2013-07-23
++ $items = array(
++ 'MONGO_STREAMS' => array('5.2.6', ''),
++ );
++ $this->applyFilter($release, $items, $constants);
++
++ return $constants;
++ }
+ }
+--
+1.8.3.1
+
+From 5ba5dcb04f63956c53bca33d080135a5d4a7364e Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Thu, 25 Jul 2013 07:43:24 +0200
+Subject: [PATCH 2/3] fix sockets reference
+
+---
+ PHP/CompatInfo/Reference/sockets.php | 1 +
+ tests/Reference/SocketsTest.php | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/PHP/CompatInfo/Reference/sockets.php b/PHP/CompatInfo/Reference/sockets.php
+index a5ecb12..563bde6 100644
+--- a/PHP/CompatInfo/Reference/sockets.php
++++ b/PHP/CompatInfo/Reference/sockets.php
+@@ -302,6 +302,7 @@ class PHP_CompatInfo_Reference_Sockets
+ 'SOL_TCP' => array('4.1.0', ''),
+ 'SOL_UDP' => array('4.1.0', ''),
+ 'SOMAXCONN' => array('4.1.0', ''),
++ 'SO_BINDTODEVICE' => array('5.5.1', ''),
+ 'SO_BROADCAST' => array('4.1.0', ''),
+ 'SO_DEBUG' => array('4.1.0', ''),
+ 'SO_DONTROUTE' => array('4.1.0', ''),
+diff --git a/tests/Reference/SocketsTest.php b/tests/Reference/SocketsTest.php
+index 4175416..e607741 100644
+--- a/tests/Reference/SocketsTest.php
++++ b/tests/Reference/SocketsTest.php
+@@ -188,6 +188,7 @@ class PHP_CompatInfo_Reference_SocketsTest
+ 'MSG_MORE',
+ 'MSG_WAITFORONE',
+ 'MSG_CMSG_CLOEXEC',
++ 'SO_BINDTODEVICE',
+ 'SO_REUSEPORT',
+ 'SO_FAMILY',
+ 'TCP_NODELAY',
+--
+1.8.3.1
+
+From 8fee07282ac7b9e15bea71207235a68120b5d15d Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Thu, 25 Jul 2013 07:44:01 +0200
+Subject: [PATCH 3/3] fix standard: chroot is optionnal
+
+---
+ PHP/CompatInfo/Reference/standard.php | 2 +-
+ tests/Reference/StandardTest.php | 4 +++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/PHP/CompatInfo/Reference/standard.php b/PHP/CompatInfo/Reference/standard.php
+index 15dd325..152ddb9 100644
+--- a/PHP/CompatInfo/Reference/standard.php
++++ b/PHP/CompatInfo/Reference/standard.php
+@@ -492,7 +492,7 @@ class PHP_CompatInfo_Reference_Standard
+ 'array_reduce' => array('4.0.5', ''),
+ 'array_search' => array('4.0.5', ''),
+ 'call_user_method_array' => array('4.0.5', ''),
+- 'chroot' => array('4.0.5', self::LATEST_PHP_5_3),
++ 'chroot' => array('4.0.5', ''),
+ 'is_scalar' => array('4.0.5', ''),
+ 'strcoll' => array('4.0.5', ''),
+ );
+diff --git a/tests/Reference/StandardTest.php b/tests/Reference/StandardTest.php
+index fa8201f..44749fd 100644
+--- a/tests/Reference/StandardTest.php
++++ b/tests/Reference/StandardTest.php
+@@ -55,6 +55,8 @@ class PHP_CompatInfo_Reference_StandardTest
+
+ if (DIRECTORY_SEPARATOR == '/') {
+ $this->optionalfunctions = array(
++ // requires HAVE_CHROOT
++ 'chroot',
+ // remove in some Linux distribution (Redhat, ...)
+ 'php_egg_logo_guid',
+ );
+@@ -68,7 +70,7 @@ class PHP_CompatInfo_Reference_StandardTest
+ 'money_format',
+ // requires HAVE_GETRUSAGE (linux only)
+ 'getrusage',
+- // requires HAVE_CHROOT (linux only)
++ // requires HAVE_CHROOT
+ 'chroot',
+ // requires HAVE_FTOK (linux only)
+ 'ftok',
+--
+1.8.3.1
+
diff --git a/PHP_CompatInfo-intl.patch b/PHP_CompatInfo-intl.patch
deleted file mode 100644
index 73abe74..0000000
--- a/PHP_CompatInfo-intl.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-diff --git a/PHP/CompatInfo/Reference/intl.php b/PHP/CompatInfo/Reference/intl.php
-index 64a088f..6266150 100644
---- a/PHP/CompatInfo/Reference/intl.php
-+++ b/PHP/CompatInfo/Reference/intl.php
-@@ -342,6 +342,10 @@ class PHP_CompatInfo_Reference_Intl
- => array('5.5.0', ''),
- 'intlcal_get_minimum' => array('5.5.0', ''),
- 'intlcal_get_now' => array('5.5.0', ''),
-+ 'intlcal_get_repeated_wall_time_option'
-+ => array('5.5.0', ''),
-+ 'intlcal_get_skipped_wall_time_option'
-+ => array('5.5.0', ''),
- 'intlcal_get_time' => array('5.5.0', ''),
- 'intlcal_get_time_zone' => array('5.5.0', ''),
- 'intlcal_get_type' => array('5.5.0', ''),
-@@ -355,6 +359,10 @@ class PHP_CompatInfo_Reference_Intl
- 'intlcal_set' => array('5.5.0', ''),
- 'intlcal_set_first_day_of_week' => array('5.5.0', ''),
- 'intlcal_set_lenient' => array('5.5.0', ''),
-+ 'intlcal_set_repeated_wall_time_option'
-+ => array('5.5.0', ''),
-+ 'intlcal_set_skipped_wall_time_option'
-+ => array('5.5.0', ''),
- 'intlcal_set_time' => array('5.5.0', ''),
- 'intlcal_set_time_zone' => array('5.5.0', ''),
- 'intlcal_to_date_time' => array('5.5.0', ''),
-@@ -377,6 +385,7 @@ class PHP_CompatInfo_Reference_Intl
- 'intltz_get_offset' => array('5.5.0', ''),
- 'intltz_get_raw_offset' => array('5.5.0', ''),
- 'intltz_get_region' => array('5.5.0', ''),
-+ 'intltz_get_unknown' => array('5.5.0', ''),
- 'intltz_get_tz_data_version' => array('5.5.0', ''),
- 'intltz_has_same_rules' => array('5.5.0', ''),
- 'intltz_to_date_time_zone' => array('5.5.0', ''),
-diff --git a/tests/Reference/IntlTest.php b/tests/Reference/IntlTest.php
-index 8636f4f..22c1717 100644
---- a/tests/Reference/IntlTest.php
-+++ b/tests/Reference/IntlTest.php
-@@ -51,13 +51,6 @@ class PHP_CompatInfo_Reference_IntlTest
- if (PATH_SEPARATOR == ';') {
- // Win*
- $this->optionalclasses = array('IntlException');
-- $this->ignoredfunctions = array(
-- 'intltz_get_unknown',
-- 'intlcal_get_repeated_wall_time_option',
-- 'intlcal_get_skipped_wall_time_option',
-- 'intlcal_set_repeated_wall_time_option',
-- 'intlcal_set_skipped_wall_time_option',
-- );
- }
-
- if (version_compare(INTL_ICU_VERSION, '3.8.0', 'lt')) {
-@@ -70,6 +63,30 @@ class PHP_CompatInfo_Reference_IntlTest
- );
- }
-
-+ if (version_compare(INTL_ICU_VERSION, '4.8', 'lt')) {
-+ // requires libicu >= 4.8
-+ $this->optionalfunctions = array_merge(
-+ $this->optionalfunctions,
-+ array(
-+ 'intltz_create_time_zone_id_enumeration',
-+ 'intltz_get_region',
-+ )
-+ );
-+ }
-+ if (version_compare(INTL_ICU_VERSION, '49', 'lt')) {
-+ // requires libicu >= 49 (version scheme change 4.9 become 49)
-+ $this->optionalfunctions = array_merge(
-+ $this->optionalfunctions,
-+ array(
-+ 'intltz_get_unknown',
-+ 'intlcal_get_repeated_wall_time_option',
-+ 'intlcal_get_skipped_wall_time_option',
-+ 'intlcal_set_repeated_wall_time_option',
-+ 'intlcal_set_skipped_wall_time_option',
-+ )
-+ );
-+ }
-+
- /*
- On Windows platform extension intl 1.1.0 :
- - uses libicu 4.6.1 for PHP 5.4.1 or greater
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index c8616b4..36a4e37 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -15,7 +15,7 @@
Name: php-bartlett-PHP-CompatInfo
-Version: 2.19.0
+Version: 2.20.0
Release: 1%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -32,8 +32,8 @@ Source1: https://raw.github.com/llaville/php-compat-info/master/misc/phpc
# Add .install .module to fileExtensions (for drupal)
Patch0: %{pear_name}-conf.patch
-# https://github.com/llaville/php-compat-info/pull/95
-Patch1: %{pear_name}-intl.patch
+# https://github.com/llaville/php-compat-info/pull/98
+Patch1: %{pear_name}-git.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -88,8 +88,7 @@ cp phpcompatinfo.xml.dist phpcompatinfo.xml
%patch1 -p1 -b .ref
# remove checksum for patched files
-sed -e '/intl.php/s/md5sum.*name/name/' \
- -e '/IntlTest.php/s/md5sum.*name/name/' \
+sed -e 's/md5sum.*name/name/' \
../package.xml >%{name}.xml
@@ -132,8 +131,8 @@ rm -f tests/Reference/XslTest.php
%endif
# OK, but incomplete or skipped tests!
-# Tests: 816, Assertions: 11365, Skipped: 72, when most extensions installed
-# Tests: 550, Assertions: 6834, Skipped: 378, in mock
+# Tests: 809, Assertions: 10993, Skipped: 80, when most extensions installed
+# Tests: 550, Assertions: 6830, Skipped: 378, in mock
# Reference tests need some fixes for EL-5, so ignore result for now
%{_bindir}/phpunit \
-d date.timezone=UTC \
@@ -175,6 +174,9 @@ fi
%changelog
+* Thu Jul 25 2013 Remi Collet <remi@fedoraproject.org> - 2.20.0-1
+- Update to 2.20.0
+
* Fri Jul 12 2013 Remi Collet <remi@fedoraproject.org> - 2.19.0-1
- Update to 2.19.0
- add module and install to fileExtensions in default configuration