summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-09 18:43:02 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-09 18:43:02 +0100
commited675fd0ba2bccf5aab634c7964ec247151340e1 (patch)
tree9376da54ee5eb4fa9b768c396725caa394128bed
parent3205739896dd567d4987c25eddb31f6674db367c (diff)
php-bartlett-PHP-CompatInfo: display DB version
-rw-r--r--php-bartlett-PHP-CompatInfo-5.0.0-rpm.patch14
-rw-r--r--php-bartlett-PHP-CompatInfo.spec11
2 files changed, 24 insertions, 1 deletions
diff --git a/php-bartlett-PHP-CompatInfo-5.0.0-rpm.patch b/php-bartlett-PHP-CompatInfo-5.0.0-rpm.patch
index 5a4a301..ed5eed3 100644
--- a/php-bartlett-PHP-CompatInfo-5.0.0-rpm.patch
+++ b/php-bartlett-PHP-CompatInfo-5.0.0-rpm.patch
@@ -83,3 +83,17 @@ diff -up ./bin/phpcompatinfo.rpm ./bin/phpcompatinfo
+$application = new Application($appName, '@package_version@');
$application->run();
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
+--- ./src/Bartlett/CompatInfo/Console/Application.php.rpm 2016-03-09 18:38:00.713180108 +0100
++++ ./src/Bartlett/CompatInfo/Console/Application.php 2016-03-09 18:36:09.737741387 +0100
+@@ -52,9 +52,10 @@
+ $v = Environment::versionRefDb();
+
+ return sprintf(
+- '<info>%s</info> version <comment>%s</comment> DB built <comment>%s</comment>',
++ '<info>%s</info> version <comment>%s</comment> DB version <comment>%s</comment> built <comment>%s</comment>',
+ $this->getName(),
+ $this->getVersion(),
++ $v['build.version'],
+ $v['build.string']
+ );
+ }
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 3696e55..18a6498 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -17,7 +17,7 @@
Name: php-bartlett-PHP-CompatInfo
Version: 5.0.0
-%global specrel 1
+%global specrel 2
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -143,6 +143,12 @@ ln -s %{buildroot}%{_datadir}/php/Bartlett/CompatInfo/autoload.php vendor/
%{_bindir}/phpunit \
--include-path %{buildroot}%{_datadir}/php \
-d memory_limit=1G
+
+if which php70; then
+ php70 %{_bindir}/phpunit \
+ --include-path %{buildroot}%{_datadir}/php \
+ -d memory_limit=1G
+fi
%endif
@@ -165,6 +171,9 @@ fi
%changelog
+* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 5.0.0-2
+- display DB version instead of build date
+
* Thu Dec 10 2015 Remi Collet <remi@fedoraproject.org> - 5.0.0-1
- update to 5.0.0
- raise dependency on bartlett/php-reflect ~4.0