summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-12 09:21:43 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-12 09:21:43 +0200
commitaee4908d89e40f545faec619e5af45678f79366d (patch)
tree3ae7fdf7693273a70c1702f45b3c190654d1d60d
parent9273bd4970897741281807aaca8e47ecd962d035 (diff)
php-bartlett-PHP-CompatInfo: 2.15.0
-rw-r--r--0028-fix-reference-for-datetimeinterface.patch49
-rw-r--r--0029-fix-reference-curl-wrappers-enabled.patch49
-rw-r--r--0030-fix-sphinx-test.patch29
-rw-r--r--0031-fix-opcache-reference-php550beta3.patch29
-rw-r--r--php-bartlett-PHP-CompatInfo.spec21
5 files changed, 173 insertions, 4 deletions
diff --git a/0028-fix-reference-for-datetimeinterface.patch b/0028-fix-reference-for-datetimeinterface.patch
new file mode 100644
index 0000000..5d4ec07
--- /dev/null
+++ b/0028-fix-reference-for-datetimeinterface.patch
@@ -0,0 +1,49 @@
+From c85563b06140afa310a8208a5695f9ad2d3a312b Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Thu, 4 Apr 2013 11:13:05 +0200
+Subject: [PATCH] fix data ref for php 5.5 (DateTimeInterface)
+
+---
+ PHP/CompatInfo/Reference/date.php | 26 ++++++++++++++++++++++++++
+ 1 file changed, 26 insertions(+)
+
+diff --git a/PHP/CompatInfo/Reference/date.php b/PHP/CompatInfo/Reference/date.php
+index 1e84586..f141613 100644
+--- a/PHP/CompatInfo/Reference/date.php
++++ b/PHP/CompatInfo/Reference/date.php
+@@ -87,6 +87,32 @@ public function getClasses($extension = null, $version = null, $condition = null
+ }
+
+ /**
++ * Gets informations about interfaces
++ *
++ * @param string $extension (optional) NULL for PHP version,
++ * TRUE if extension version
++ * @param string $version (optional) php or extension version
++ * @param string $condition (optional) particular relationship with $version
++ * Same operator values as used by version_compare
++ *
++ * @return array
++ */
++ public function getInterfaces($extension = null, $version = null, $condition = null)
++ {
++ $this->setFilter(func_get_args());
++
++ $interfaces = array();
++
++ $release = '5.5.0'; // not yet
++ $items = array(
++ 'DateTimeInterface' => array('5.5.0-dev', ''),
++ );
++ $this->applyFilter($release, $items, $interfaces);
++
++ return $interfaces;
++ }
++
++ /**
+ * Gets informations about functions
+ *
+ * @param string $extension (optional) NULL for PHP version,
+--
+1.8.1.5
+
diff --git a/0029-fix-reference-curl-wrappers-enabled.patch b/0029-fix-reference-curl-wrappers-enabled.patch
new file mode 100644
index 0000000..def5a3b
--- /dev/null
+++ b/0029-fix-reference-curl-wrappers-enabled.patch
@@ -0,0 +1,49 @@
+From 2b72e131738149824ae06904ea7a1505ceb72da8 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Thu, 4 Apr 2013 11:17:07 +0200
+Subject: [PATCH] fix curl ref for php 5.4.15 (CURL_WRAPPERS_ENABLE)
+
+---
+ PHP/CompatInfo/Reference/curl.php | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/PHP/CompatInfo/Reference/curl.php b/PHP/CompatInfo/Reference/curl.php
+index 507bea0..a5f6488 100644
+--- a/PHP/CompatInfo/Reference/curl.php
++++ b/PHP/CompatInfo/Reference/curl.php
+@@ -172,6 +172,7 @@ public function getConstants($extension = null, $version = null, $condition = nu
+ 'CURL_VERSION_KERBEROS4' => array('4.0.2', ''),
+ 'CURL_VERSION_LIBZ' => array('4.0.2', ''),
+ 'CURL_VERSION_SSL' => array('4.0.2', ''),
++ 'CURL_WRAPPERS_ENABLE' => array('5.4.15', ''),
+ 'CURL_WRITEFUNC_PAUSE' => array('5.5.0-dev', ''),
+
+ 'CURLAUTH_ANY' => array('4.0.2', ''),
+--
+1.8.1.5
+
+From 519b2819557c82a7b34825a71e9c72359fe1d5e7 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Sat, 6 Apr 2013 07:00:29 +0200
+Subject: [PATCH] fix curl ref for php 5.4.15 (CURL_WRAPPERS_ENABLED)
+
+---
+ PHP/CompatInfo/Reference/curl.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/PHP/CompatInfo/Reference/curl.php b/PHP/CompatInfo/Reference/curl.php
+index a5f6488..879208f 100644
+--- a/PHP/CompatInfo/Reference/curl.php
++++ b/PHP/CompatInfo/Reference/curl.php
+@@ -172,7 +172,7 @@ public function getConstants($extension = null, $version = null, $condition = nu
+ 'CURL_VERSION_KERBEROS4' => array('4.0.2', ''),
+ 'CURL_VERSION_LIBZ' => array('4.0.2', ''),
+ 'CURL_VERSION_SSL' => array('4.0.2', ''),
+- 'CURL_WRAPPERS_ENABLE' => array('5.4.15', ''),
++ 'CURL_WRAPPERS_ENABLED' => array('5.4.15', ''),
+ 'CURL_WRITEFUNC_PAUSE' => array('5.5.0-dev', ''),
+
+ 'CURLAUTH_ANY' => array('4.0.2', ''),
+--
+1.8.1.5
+
diff --git a/0030-fix-sphinx-test.patch b/0030-fix-sphinx-test.patch
new file mode 100644
index 0000000..73bc64a
--- /dev/null
+++ b/0030-fix-sphinx-test.patch
@@ -0,0 +1,29 @@
+From d75d31cc71065a6c7f44de9f029e255dce18aab9 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Fri, 12 Apr 2013 08:53:32 +0200
+Subject: [PATCH] fix sphinx reference test
+
+---
+ tests/Reference/SphinxTest.php | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/tests/Reference/SphinxTest.php b/tests/Reference/SphinxTest.php
+index d91ef30..39714bf 100644
+--- a/tests/Reference/SphinxTest.php
++++ b/tests/Reference/SphinxTest.php
+@@ -42,9 +42,12 @@ protected function setUp()
+ {
+ // Constants conditionnaly exists (according to libsphinx version)
+ $this->optionalconstants = array(
++ 'SPH_RANK_EXPR',
+ 'SPH_RANK_FIELDMASK',
+ 'SPH_RANK_MATCHANY',
+ 'SPH_RANK_PROXIMITY',
++ 'SPH_RANK_SPH04',
++ 'SPH_RANK_TOTAL',
+ );
+ $this->obj = new PHP_CompatInfo_Reference_Sphinx();
+ parent::setUp();
+--
+1.8.1.5
+
diff --git a/0031-fix-opcache-reference-php550beta3.patch b/0031-fix-opcache-reference-php550beta3.patch
new file mode 100644
index 0000000..e6f14c2
--- /dev/null
+++ b/0031-fix-opcache-reference-php550beta3.patch
@@ -0,0 +1,29 @@
+From b84b0440e26be71b2f9bd6ab547859add813a236 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Fri, 12 Apr 2013 08:57:25 +0200
+Subject: [PATCH] add opcache_invalidate (7.0.2-dev, or PHP 5.5.0beta3)
+
+---
+ PHP/CompatInfo/Reference/zendopcache.php | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/PHP/CompatInfo/Reference/zendopcache.php b/PHP/CompatInfo/Reference/zendopcache.php
+index c488024..a326bdf 100644
+--- a/PHP/CompatInfo/Reference/zendopcache.php
++++ b/PHP/CompatInfo/Reference/zendopcache.php
+@@ -85,6 +85,12 @@ public function getFunctions($extension = null, $version = null, $condition = nu
+ );
+ $this->applyFilter($release, $items, $functions);
+
++ $release = '7.0.2'; // not yet
++ $items = array(
++ 'opcache_invalidate' => array('5.2.0', ''),
++ );
++ $this->applyFilter($release, $items, $functions);
++
+ return $functions;
+ }
+ }
+--
+1.8.1.5
+
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index caee7b1..45ce49f 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -8,7 +8,7 @@
Name: php-bartlett-PHP-CompatInfo
-Version: 2.14.1
+Version: 2.15.0
Release: 1%{?dist}
Summary: Find out version and the extensions required for a piece of code to run
@@ -49,6 +49,10 @@ Patch24: 0024-fix-gd-reference-for-php-5.5.0alpha6.patch
Patch25: 0025-array_column.patch
Patch26: 0026-fix-gd-reference-for-php-5.5.0beta2.patch
Patch27: 0027-fix-curl-ref-for-latest-libcurl.patch
+Patch28: 0028-fix-reference-for-datetimeinterface.patch
+Patch29: 0029-fix-reference-curl-wrappers-enabled.patch
+Patch30: 0030-fix-sphinx-test.patch
+Patch31: 0031-fix-opcache-reference-php550beta3.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -69,7 +73,7 @@ Requires: php-pcre
Requires: php-reflection
Requires: php-spl
Requires: php-pear(PEAR) >= 1.9.0
-Requires: php-pear(%{channel}/PHP_Reflect) >= 1.6.1
+Requires: php-pear(%{channel}/PHP_Reflect) >= 1.6.2
Requires: php-pear(Console_CommandLine) >= 1.2.0
# Optional
Requires: php-pear(pear.phpunit.de/PHPUnit) >= 3.6.0
@@ -127,6 +131,10 @@ cp phpcompatinfo.xml.dist phpcompatinfo.xml
%patch25 -p1
%patch26 -p1
%patch27 -p1
+%patch28 -p1
+%patch29 -p1
+%patch30 -p1
+%patch31 -p1
# remove checksum for patched files
sed -e 's/md5sum.*name/name/' \
@@ -208,6 +216,11 @@ fi
%changelog
+* Fri Apr 12 2013 Remi Collet <remi@fedoraproject.org> - 2.15.0-1
+- Update to 2.15.0
+- raise dependencies, PHP_Reflect 1.6.2
+- add more patches for PHP 5.5 reference
+
* Tue Apr 02 2013 Remi Collet <remi@fedoraproject.org> - 2.14.1-1
- Update to 2.14.1
- make cache path user dependent
@@ -334,7 +347,7 @@ fi
- Version 2.1.0 (stable) - API 2.1.0 (stable)
- fix documentation for asciidoc 8.4
-* Sat Jun 02 2011 Remi Collet <Fedora@FamilleCollet.com> - 2.0.0-1
+* Sat Jun 04 2011 Remi Collet <Fedora@FamilleCollet.com> - 2.0.0-1
- Version 2.0.0 (stable) - API 2.0.0 (stable)
- add HTML documentation
@@ -344,7 +357,7 @@ fi
* Fri Mar 25 2011 Remi Collet <Fedora@FamilleCollet.com> - 2.0.0-0.2.RC3
- Version 2.0.0RC3
-* Wed Feb 25 2011 Remi Collet <Fedora@FamilleCollet.com> - 2.0.0-0.1.RC2
+* Wed Feb 23 2011 Remi Collet <Fedora@FamilleCollet.com> - 2.0.0-0.1.RC2
- Version 2.0.0RC2
- Initial Release